summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-analyzer/ethloop
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-analyzer/ethloop')
-rw-r--r--net-analyzer/ethloop/Manifest1
-rw-r--r--net-analyzer/ethloop/ethloop-10-r3.ebuild30
-rw-r--r--net-analyzer/ethloop/files/ethloop-10-gcc45.patch32
-rw-r--r--net-analyzer/ethloop/metadata.xml6
4 files changed, 69 insertions, 0 deletions
diff --git a/net-analyzer/ethloop/Manifest b/net-analyzer/ethloop/Manifest
new file mode 100644
index 000000000000..1a3cc6b18268
--- /dev/null
+++ b/net-analyzer/ethloop/Manifest
@@ -0,0 +1 @@
+DIST ethloop10.tgz 3912 SHA256 d1f7b4500946dc6c0e6fe031fcebc789d9e061645cd775fe4005820a75039b86 SHA512 82ac0114d0d539f5c057101e1e1f0e2eac32e0bd482bd62e6305f7c4863d0776dcff7bc85167dbcfb136d0b430c9008241c2c0250713beb2703cb052b9b71e63 WHIRLPOOL aa0af08ce518c38bf44ea639f5a4466a4d68e1dd1cc2c2b28283f6e8b4fd27f00a157f5ce80a45a6e46f8c0d916f44f675889e0253509639be36bf1d451a4336
diff --git a/net-analyzer/ethloop/ethloop-10-r3.ebuild b/net-analyzer/ethloop/ethloop-10-r3.ebuild
new file mode 100644
index 000000000000..21451ec53fba
--- /dev/null
+++ b/net-analyzer/ethloop/ethloop-10-r3.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Local simulator for testing Linux QoS disciplines"
+HOMEPAGE="http://luxik.cdi.cz/~devik/qos/ethloop/"
+SRC_URI="http://luxik.cdi.cz/~devik/qos/ethloop/ethloop10.tgz"
+
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc x86"
+RESTRICT="mirror bindist"
+
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gcc45.patch
+}
+
+src_compile() {
+ emake CC=$(tc-getCC) CFLAGS="${CFLAGS}"
+}
+
+src_install() {
+ dosbin ethloop
+}
diff --git a/net-analyzer/ethloop/files/ethloop-10-gcc45.patch b/net-analyzer/ethloop/files/ethloop-10-gcc45.patch
new file mode 100644
index 000000000000..75b951102245
--- /dev/null
+++ b/net-analyzer/ethloop/files/ethloop-10-gcc45.patch
@@ -0,0 +1,32 @@
+Fix recv call (bug #336755), add some more includes.
+
+--- a/ethloop.c 2002-05-03 15:13:20.000000000 +0200
++++ b/ethloop.c 2010-12-27 18:21:24.000000000 +0100
+@@ -1,5 +1,7 @@
+ /* vim: cin sw=4 ts=4
+ */
++#include <arpa/inet.h> /* htons() */
++#include <sys/types.h> /* recv() */
+ #include <sys/socket.h>
+ #include <sys/ioctl.h>
+ #include <sys/poll.h>
+@@ -13,6 +15,7 @@
+ #include <stdlib.h>
+ #include <sys/time.h>
+ #include <signal.h>
++#include <string.h>
+
+ int sock;
+
+@@ -133,9 +136,9 @@
+ int recv_raw(int tmo)
+ {
+ struct pollfd pf = {sock,POLLIN,0};
+- int r; unsigned short proto;
++ ssize_t r; unsigned short proto;
+ if(poll(&pf,1,tmo) <= 0) return 0;
+- r = recv(sock,&buf,1550,0);
++ r = recv(sock,&buf,sizeof(buf),0);
+ if (r <= 0) {
+ printf("error recv (%d)\n",r);
+ return 0;
diff --git a/net-analyzer/ethloop/metadata.xml b/net-analyzer/ethloop/metadata.xml
new file mode 100644
index 000000000000..3f03418f6fe4
--- /dev/null
+++ b/net-analyzer/ethloop/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>netmon</herd>
+<longdescription>Local simulator for testing Linux QoS disciplines</longdescription>
+</pkgmetadata>