summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-07-31 00:13:35 +0100
committerSam James <sam@gentoo.org>2021-07-31 00:29:54 +0100
commitb847d6e6f2476d03017e1e89f98e63b4901e5b8b (patch)
tree311afe7f304e6b282b967338478915adbf5082d4 /net-analyzer/fail2ban
parentmedia-sound/pulseaudio: [QA] call tmpfiles_process in pkg_postinst (diff)
downloadgentoo-b847d6e6f2476d03017e1e89f98e63b4901e5b8b.tar.gz
gentoo-b847d6e6f2476d03017e1e89f98e63b4901e5b8b.tar.bz2
gentoo-b847d6e6f2476d03017e1e89f98e63b4901e5b8b.zip
net-analyzer/fail2ban: [QA] call tmpfiles_process in pkg_postinst
This is needed to actually apply the tmpfiles configuration we've installed in the ebuild. See tmpfiles.eclass documentation. Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-analyzer/fail2ban')
-rw-r--r--net-analyzer/fail2ban/fail2ban-0.11.2.ebuild2
-rw-r--r--net-analyzer/fail2ban/fail2ban-9999.ebuild2
2 files changed, 4 insertions, 0 deletions
diff --git a/net-analyzer/fail2ban/fail2ban-0.11.2.ebuild b/net-analyzer/fail2ban/fail2ban-0.11.2.ebuild
index caf428f0ca77..3096e694a197 100644
--- a/net-analyzer/fail2ban/fail2ban-0.11.2.ebuild
+++ b/net-analyzer/fail2ban/fail2ban-0.11.2.ebuild
@@ -95,6 +95,8 @@ pkg_preinst() {
}
pkg_postinst() {
+ tmpfiles_process ${PN}-tmpfiles.conf
+
if [[ ${previous_less_than_0_7} = 0 ]] ; then
elog
elog "Configuration files are now in /etc/fail2ban/"
diff --git a/net-analyzer/fail2ban/fail2ban-9999.ebuild b/net-analyzer/fail2ban/fail2ban-9999.ebuild
index d0d4d4ef18f7..2ad8f462e23d 100644
--- a/net-analyzer/fail2ban/fail2ban-9999.ebuild
+++ b/net-analyzer/fail2ban/fail2ban-9999.ebuild
@@ -92,6 +92,8 @@ pkg_preinst() {
}
pkg_postinst() {
+ tmpfiles_process ${PN}-tmpfiles.conf
+
if [[ ${previous_less_than_0_7} == 0 ]] ; then
elog
elog "Configuration files are now in /etc/fail2ban/"