summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-analyzer/nagircbot
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-analyzer/nagircbot')
-rw-r--r--net-analyzer/nagircbot/Manifest1
-rw-r--r--net-analyzer/nagircbot/files/conf2
-rwxr-xr-xnet-analyzer/nagircbot/files/init20
-rw-r--r--net-analyzer/nagircbot/metadata.xml5
-rw-r--r--net-analyzer/nagircbot/nagircbot-0.0.33.ebuild40
5 files changed, 68 insertions, 0 deletions
diff --git a/net-analyzer/nagircbot/Manifest b/net-analyzer/nagircbot/Manifest
new file mode 100644
index 000000000000..ccf5ccd61af0
--- /dev/null
+++ b/net-analyzer/nagircbot/Manifest
@@ -0,0 +1 @@
+DIST nagircbot-0.0.33.tgz 20085 SHA256 7a7c63a409bdad125b19ec852a772746eda2b1feef71bbdf58bd2a2c785a0887 SHA512 1e4d69cef4a425e8540ff408688cf7899c04098ec47acbd6da601f48e01f808958982e7d8a1519934bd5aa895fe0f8dedc51d80460f85097355d5bdea79fd708 WHIRLPOOL 4a3b89fd0234f0643fde0824bb538617d7dc3f9736ddc18dcfacc6aa217417ed9f25adad2e0f9525b0b90b424c7a9ef95d6b349a997a5143bbe4db72bc751723
diff --git a/net-analyzer/nagircbot/files/conf b/net-analyzer/nagircbot/files/conf
new file mode 100644
index 000000000000..79fc899e11bd
--- /dev/null
+++ b/net-analyzer/nagircbot/files/conf
@@ -0,0 +1,2 @@
+# Put nagircbot arguments here
+# BOTCONF="-f /var/nagios/status.dat -s irc.freenode.net:6667 -c channel -k password -n name"
diff --git a/net-analyzer/nagircbot/files/init b/net-analyzer/nagircbot/files/init
new file mode 100755
index 000000000000..b349593ca2f1
--- /dev/null
+++ b/net-analyzer/nagircbot/files/init
@@ -0,0 +1,20 @@
+#!/sbin/runscript
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+depend() {
+ use net
+}
+
+start() {
+ ebegin "Starting nagircbot"
+ start-stop-daemon --start -x /usr/bin/nagircbot -- $BOTCONF
+ eend $? "Failed to start nagircbot"
+}
+
+stop() {
+ ebegin "Stopping nagircbot"
+ start-stop-daemon --stop -x /usr/bin/nagircbot
+ eend $? "Failed to stop nagircbot"
+}
diff --git a/net-analyzer/nagircbot/metadata.xml b/net-analyzer/nagircbot/metadata.xml
new file mode 100644
index 000000000000..d7649f4b8eb2
--- /dev/null
+++ b/net-analyzer/nagircbot/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sysadmin</herd>
+</pkgmetadata>
diff --git a/net-analyzer/nagircbot/nagircbot-0.0.33.ebuild b/net-analyzer/nagircbot/nagircbot-0.0.33.ebuild
new file mode 100644
index 000000000000..5712d19a96e0
--- /dev/null
+++ b/net-analyzer/nagircbot/nagircbot-0.0.33.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit toolchain-funcs
+
+DESCRIPTION="An irc bot that alerts you to nagios changes"
+HOMEPAGE="http://www.vanheusden.com/nagircbot"
+SRC_URI="http://www.vanheusden.com/nagircbot/${P}.tgz"
+
+LICENSE="GPL-2" # GPL-2 only
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+CDEPEND="dev-libs/openssl"
+DEPEND="virtual/pkgconfig
+ ${CDEPEND}"
+RDEPEND="net-analyzer/nagios-core
+ ${CDEPEND}"
+
+src_prepare() {
+cp -av Makefile{,.org}
+ sed -i Makefile \
+ -e 's:-lcrypto -lssl:$(shell pkg-config --libs openssl):g' \
+ -e 's:-O2::g;s:-g::g' \
+ || die
+}
+
+src_compile() {
+ emake CC=$(tc-getCC) CXX=$(tc-getCXX)
+}
+
+src_install() {
+ dobin nagircbot
+ newconfd "${FILESDIR}"/conf nagircbot
+ newinitd "${FILESDIR}"/init nagircbot
+}