summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGiuseppe Foti <foti.giuseppe@gmail.com>2024-04-25 21:27:51 +0200
committerFlorian Schmaus <flow@gentoo.org>2024-04-30 10:15:20 +0200
commit0f8739f3e39f93cbaf8f49a3cff8d86b6278e929 (patch)
treedf573eb85f5ac9d6d3f2d524a789145e5b48be6e /net-analyzer
parentapp-pda/usbmuxd: add 1.1.1_p20231011 (diff)
downloadgentoo-0f8739f3e39f93cbaf8f49a3cff8d86b6278e929.tar.gz
gentoo-0f8739f3e39f93cbaf8f49a3cff8d86b6278e929.tar.bz2
gentoo-0f8739f3e39f93cbaf8f49a3cff8d86b6278e929.zip
net-analyzer/python-gvm: add 24.3.0
Signed-off-by: Giuseppe Foti <foti.giuseppe@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/36425 Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/python-gvm/Manifest1
-rw-r--r--net-analyzer/python-gvm/python-gvm-24.3.0.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/net-analyzer/python-gvm/Manifest b/net-analyzer/python-gvm/Manifest
index 72ac45aa37e9..635607a85a25 100644
--- a/net-analyzer/python-gvm/Manifest
+++ b/net-analyzer/python-gvm/Manifest
@@ -1 +1,2 @@
DIST python-gvm-24.1.0.tar.gz 287497 BLAKE2B 049154d5a516c56885c06e2a83884736c9e4009e1e69a817e541f1317d4fe0cb886f98ed1572bcb55bcfdd40ed7da6639ba52cc89b113731f24d941de3f6195b SHA512 d70d3c654aefb6e5949e35f68fd1585c243988a41165c9fefb54c8fe6dd24694391553201a95558d3fd4a6e8c88783a1fc4d2205ce9ae1a7d2fc2dafdf19825b
+DIST python-gvm-24.3.0.tar.gz 278134 BLAKE2B 0da2b7d33164f7db773b51d917755678639f58f63438c23fac95fc3ebeb0412e470ee834804d327b4b46b379672d8f3fd673e0cfdf93f7fc65fe31393a5f3509 SHA512 d6e9dcaf3e776309b18b11393049e2edd08884241a2d050806d9b82dcc91d12e2a121f532b311a83e8f9bf367694b41efe66a9a8eefbe1bfb7bb7453ce08715c
diff --git a/net-analyzer/python-gvm/python-gvm-24.3.0.ebuild b/net-analyzer/python-gvm/python-gvm-24.3.0.ebuild
new file mode 100644
index 000000000000..1f81a8089e3f
--- /dev/null
+++ b/net-analyzer/python-gvm/python-gvm-24.3.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+DISTUTILS_USE_PEP517=poetry
+
+inherit distutils-r1
+
+DESCRIPTION="Greenbone Vulnerability Management Python Library"
+HOMEPAGE="https://www.greenbone.net https://github.com/greenbone/python-gvm/"
+SRC_URI="https://github.com/greenbone/python-gvm/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/defusedxml-0.6[${PYTHON_USEDEP}]
+ >=dev-python/lxml-4.5.0[${PYTHON_USEDEP}]
+ >=dev-python/paramiko-2.7.1[${PYTHON_USEDEP}]
+ >=dev-python/typing-extensions-4.9.0[${PYTHON_USEDEP}]
+ test? (
+ >=net-analyzer/pontos-22.7.2[${PYTHON_USEDEP}]
+ )
+"
+DEPEND="${RDEPEND}"
+
+distutils_enable_tests unittest
+
+src_prepare() {
+ distutils-r1_src_prepare
+
+ # drop connection tests
+ rm -r tests/connections || die
+}