summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-irc/ngircd
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-irc/ngircd')
-rw-r--r--net-irc/ngircd/Manifest1
-rw-r--r--net-irc/ngircd/files/ngircd.init.d21
-rw-r--r--net-irc/ngircd/metadata.xml8
-rw-r--r--net-irc/ngircd/ngircd-20.3.ebuild80
4 files changed, 110 insertions, 0 deletions
diff --git a/net-irc/ngircd/Manifest b/net-irc/ngircd/Manifest
new file mode 100644
index 000000000000..21d5b8ab52ba
--- /dev/null
+++ b/net-irc/ngircd/Manifest
@@ -0,0 +1 @@
+DIST ngircd-20.3.tar.gz 479982 SHA256 55d7c74c6df790b11a68c07f39836d581965087efb618d3e9a6bec855364c2f9 SHA512 8bc36a66e893873fade6dcadb07bf561fb25156714ba30168cf2e399e50f4dd80592fd7fcdb6c8d1083fa7c5e839b0da3a27ed4ce2041a2c5ab2b9581def948c WHIRLPOOL 379ef30a2e23dfc3a523d85e9f2c1531b8079d0880b5f46b9cdb803af873fc943d25186ebc0b9294da26140b46a37a4ebd2b86f3c7cf17acd3a802e4a395dd1e
diff --git a/net-irc/ngircd/files/ngircd.init.d b/net-irc/ngircd/files/ngircd.init.d
new file mode 100644
index 000000000000..1736073bfe9c
--- /dev/null
+++ b/net-irc/ngircd/files/ngircd.init.d
@@ -0,0 +1,21 @@
+#!/sbin/runscript
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+depend() {
+ need net
+ provide ircd
+}
+
+start() {
+ ebegin "Starting ngIRCd"
+ start-stop-daemon --start --quiet --exec /usr/sbin/ngircd
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping ngIRCd"
+ start-stop-daemon --stop --quiet --exec /usr/sbin/ngircd
+ eend $?
+}
diff --git a/net-irc/ngircd/metadata.xml b/net-irc/ngircd/metadata.xml
new file mode 100644
index 000000000000..0761e008930c
--- /dev/null
+++ b/net-irc/ngircd/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>net-irc</herd>
+<use>
+ <flag name='ident'>Enables support for <pkg>net-libs/libident</pkg></flag>
+</use>
+</pkgmetadata>
diff --git a/net-irc/ngircd/ngircd-20.3.ebuild b/net-irc/ngircd/ngircd-20.3.ebuild
new file mode 100644
index 000000000000..1a7281c86a61
--- /dev/null
+++ b/net-irc/ngircd/ngircd-20.3.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit autotools-utils eutils user
+
+DESCRIPTION="A IRC server written from scratch"
+HOMEPAGE="http://ngircd.barton.de/"
+SRC_URI="ftp://ngircd.barton.de/pub/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 x86 ~x64-macos"
+IUSE="debug gnutls ident ipv6 pam ssl tcpd zlib"
+
+RDEPEND="
+ ident? ( net-libs/libident )
+ ssl? (
+ gnutls? ( net-libs/gnutls )
+ !gnutls? ( dev-libs/openssl )
+ )
+ pam? ( virtual/pam )
+ tcpd? ( sys-apps/tcp-wrappers )
+ zlib? ( sys-libs/zlib )
+"
+DEPEND="${RDEPEND}
+ >=sys-apps/sed-4
+"
+
+RESTRICT="test"
+
+src_configure() {
+ if ! use prefix; then
+ sed -i \
+ -e "s:;ServerUID = 65534:ServerUID = ngircd:" \
+ -e "s:;ServerGID = 65534:ServerGID = nogroup:" \
+ doc/sample-ngircd.conf.tmpl || die
+ fi
+
+ local myeconfargs=(
+ --docdir="${EPREFIX}"/usr/share/doc/${PF}
+ --sysconfdir="${EPREFIX}"/etc/ngircd
+ $(use_enable ipv6)
+ $(use_with zlib)
+ $(use_with tcpd tcp-wrappers)
+ $(use_with ident)
+ $(use_with pam)
+ $(use_enable debug)
+ $(use_enable debug sniffer)
+ )
+
+ if use ssl; then
+ myeconfargs+=(
+ $(use_with !gnutls openssl)
+ $(use_with gnutls)
+ )
+ else
+ myeconfargs+=(
+ --without-gnutls
+ --without-ssl
+ )
+ fi
+
+ autotools-utils_src_configure
+}
+
+src_install() {
+ autotools-utils_src_install
+
+ newinitd "${FILESDIR}"/ngircd.init.d ngircd
+}
+
+pkg_postinst() {
+ if ! use prefix; then
+ enewuser ngircd
+ chown ngircd "${ROOT}"/etc/ngircd/ngircd.conf
+ fi
+}