summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWade Cline <wadecline@hotmail.com>2022-05-02 20:18:24 -0700
committerIonen Wolkens <ionen@gentoo.org>2022-05-17 07:38:22 -0400
commitc487ffd83c81a7ec580d3af40ba98d0c421397e6 (patch)
tree179ca022c5fb6fb4994924245d6d0134d5961b42 /net-irc
parentsys-auth/pam_mount: Remove old versions (diff)
downloadgentoo-c487ffd83c81a7ec580d3af40ba98d0c421397e6.tar.gz
gentoo-c487ffd83c81a7ec580d3af40ba98d0c421397e6.tar.bz2
gentoo-c487ffd83c81a7ec580d3af40ba98d0c421397e6.zip
net-irc/inspircd: Add v3.13.0
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Wade Cline <wadecline@hotmail.com> Closes: https://github.com/gentoo/gentoo/pull/25396 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/inspircd/Manifest3
-rw-r--r--net-irc/inspircd/inspircd-3.13.0.ebuild114
2 files changed, 117 insertions, 0 deletions
diff --git a/net-irc/inspircd/Manifest b/net-irc/inspircd/Manifest
index 519937671bd7..7a62c410998e 100644
--- a/net-irc/inspircd/Manifest
+++ b/net-irc/inspircd/Manifest
@@ -1,2 +1,5 @@
DIST inspircd-3.12.0-fix-path-builds.patch.bz2 4570 BLAKE2B 2c2cea615f9e170c249868a60dcf698ba130b33e6e0553bb8c3070698332e643f3d58fc823fe92621e5498c8606b8334afe1536c9772a24f389010a93b72bc09 SHA512 e20171d6c94c163c414c0aa2a02a22ec2de02ec20a00542ada0181abc46e229f7e9d9108b88895a1ad6134b72e3fdab6e80b6c6b33e10b8be73f3a28130c0adb
DIST inspircd-3.12.0.tar.gz 864630 BLAKE2B eb8fc009347777bdd1e1b119465a6e9f7b6f563c855607905ae256dd0f433d460872d185d2b17ca5033dad7fc07d1e049ce714bf92b91033e5157f796c1451ed SHA512 b8ad5bef5c4ea493bb77976cf75861efb445792696b536eab875c7c5e1a5fa679a5ad48c73a2bcb448871b4398f8370cde326abf389fc21db7e5fd24cfcdca59
+DIST inspircd-3.13.0-fix-path-builds.patch.bz2 4719 BLAKE2B f0a278f2cba6a6c84c60ef34c9f15b2fbd4ecad4a3e16944b4a50437209447c70db2faffcb6f0a18a5b970721ceaea041763e5ca237129211cf8c3bb8d925bb5 SHA512 124ba020382f9efbcc1a6d79f5b6ace61a70c6b86d46ce1067d9a05172ac77db7b06c3b61037f158d2fff3356bf897fae4504212b56a242c27fa42f5ba12a3ad
+DIST inspircd-3.13.0-fix-template-files.patch.bz2 785 BLAKE2B ee559a1e92c7ff1b985fffff815e2d12c8ebda5424583fb72cd9f4997806ee0e1571f983b024b6bf1a11077b763cf30a0b05a7ff12c25a51f8020ff3360ef597 SHA512 80a35c94753c1e32c7d58778031ab02ee70afdf9968ca647079d5a8c124c2bd10473a67609c8e9d48bc66ae94ba49dc9dab49a96cdc864a418f1f48d74ba80c9
+DIST inspircd-3.13.0.tar.gz 868027 BLAKE2B 9d31917d076329d255f3b29a394a1329f286d3178573063e5af48148c14ba8a4c6b78e90251ec9d8df9dc10726435dd4aff381c65d81c902034ea527aabac51f SHA512 1466e6b4259ea0f1e62342133a6720839e01eea24f67398ab47f9d5d63703cb934b867c705f07c8e0d3a0fa25c20f9b20ce3f5dbc7bbe7c4f2d5d02b7a170cca
diff --git a/net-irc/inspircd/inspircd-3.13.0.ebuild b/net-irc/inspircd/inspircd-3.13.0.ebuild
new file mode 100644
index 000000000000..48edcd50c9a7
--- /dev/null
+++ b/net-irc/inspircd/inspircd-3.13.0.ebuild
@@ -0,0 +1,114 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit systemd toolchain-funcs
+
+DESCRIPTION="Inspire IRCd - The Stable, High-Performance Modular IRCd"
+HOMEPAGE="https://www.inspircd.org/"
+SRC_URI="
+ https://github.com/inspircd/inspircd/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ https://github.com/clinew/gentoo-distfiles/raw/master/inspircd-${PV}-fix-path-builds.patch.bz2
+ https://github.com/clinew/gentoo-distfiles/raw/master/inspircd-${PV}-fix-template-files.patch.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="debug gnutls ldap maxminddb mbedtls mysql pcre postgres re2 regex-posix regex-stdlib sqlite ssl sslrehashsignal tre"
+
+RDEPEND="
+ acct-group/inspircd
+ acct-user/inspircd
+ dev-lang/perl
+ gnutls? ( net-libs/gnutls:= dev-libs/libgcrypt:0 )
+ ldap? ( net-nds/openldap:= )
+ maxminddb? ( dev-libs/libmaxminddb:= )
+ mbedtls? ( net-libs/mbedtls:= )
+ mysql? ( dev-db/mysql-connector-c:= )
+ pcre? ( dev-libs/libpcre )
+ postgres? ( dev-db/postgresql:= )
+ re2? ( dev-libs/re2:= )
+ sqlite? ( >=dev-db/sqlite-3.0 )
+ ssl? ( dev-libs/openssl:= )
+ tre? ( dev-libs/tre )"
+DEPEND="${RDEPEND}"
+
+DOCS=( docs/. .configure/apparmor )
+PATCHES=(
+ "${WORKDIR}"/${P}-fix-path-builds.patch
+ "${WORKDIR}"/${P}-fix-template-files.patch)
+
+src_prepare() {
+ default
+}
+
+src_configure() {
+ local extras=""
+
+ use gnutls && extras+="ssl_gnutls,"
+ use ldap && extras+="ldap,"
+ use maxminddb && extras+="geo_maxmind,"
+ use mbedtls && extras+="ssl_mbedtls,"
+ use mysql && extras+="mysql,"
+ use pcre && extras+="regex_pcre,"
+ use postgres && extras+="pgsql,"
+ use re2 && extras+="regex_re2,"
+ use regex-posix && extras+="regex_posix,"
+ use regex-stdlib && extras+="regex_stdlib,"
+ use sqlite && extras+="sqlite3,"
+ use ssl && extras+="ssl_openssl,"
+ use sslrehashsignal && extras+="sslrehashsignal,"
+ use tre && extras+="regex_tre,"
+
+ # The first configuration run enables certain "extra" InspIRCd
+ # modules, the second run generates the actual makefile.
+ if [[ -n "${extras}" ]]; then
+ ./configure --enable-extras=${extras%,}
+ fi
+
+ local myconf=(
+ --disable-auto-extras
+ --disable-ownership
+ --system
+ --binary-dir="/usr/bin"
+ --data-dir="/var/lib/${PN}/data"
+ --example-dir="/usr/share/doc/${PV}"
+ --manual-dir="/usr/share/man"
+ --module-dir="/usr/$(get_libdir)/${PN}/modules")
+ CXX="$(tc-getCXX)" ./configure "${myconf[@]}"
+}
+
+src_compile() {
+ emake LDFLAGS="${LDFLAGS}" CXXFLAGS="${CXXFLAGS}" $(usev debug INSPIRCD_DEBUG=2) INSPIRCD_VERBOSE=1
+}
+
+src_install() {
+ default
+
+ insinto "/usr/include/${PN}"
+ doins -r include/.
+
+ newinitd "${FILESDIR}/${PN}.initd" "${PN}"
+ newconfd "${FILESDIR}/${PN}.confd" "${PN}"
+ systemd_dounit .configure/inspircd.service
+
+ keepdir "/var/log/${PN}"
+ insinto "/etc/logrotate.d"
+ newins .configure/logrotate "${PN}"
+
+ diropts -o"${PN}" -g"${PN}" -m0700
+ keepdir "/var/lib/${PN}/data"
+
+ rmdir "${ED}"/run{/inspircd,} || die
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ # This is a new installation
+ elog "You will find example configuration files under "
+ elog "/usr/share/doc/${PN}"
+ elog "Read the ${PN}.conf.example file carefully before "
+ elog "starting the service."
+ fi
+}