summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-01-07 15:29:28 +0000
committerSam James <sam@gentoo.org>2024-01-07 15:34:12 +0000
commit7a49e97ae0a06dd1c6f9cc798794f6f432174bf6 (patch)
treed3c7747b7bfa3f33df6356d92c641eb0858861b2 /net-libs/glib-networking
parentdev-qt/qtbase: skip tst_qtimer (randomly hangs) (diff)
downloadgentoo-7a49e97ae0a06dd1c6f9cc798794f6f432174bf6.tar.gz
gentoo-7a49e97ae0a06dd1c6f9cc798794f6f432174bf6.tar.bz2
gentoo-7a49e97ae0a06dd1c6f9cc798794f6f432174bf6.zip
net-libs/glib-networking: fix libproxy tests
Depending on the (network) environment, glib may or may not conclude that the network is available which causes libproxy to return direct://. Fake the connectivity test using GIO_USE_NETWORK_MONITOR=base which assumes we're always online. Bug: https://github.com/libproxy/libproxy/issues/260 Closes: https://bugs.gentoo.org/914382 Thanks-to: Mart Raudsepp <leio@gentoo.org> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-libs/glib-networking')
-rw-r--r--net-libs/glib-networking/glib-networking-2.76.1.ebuild7
-rw-r--r--net-libs/glib-networking/glib-networking-2.78.0.ebuild7
2 files changed, 12 insertions, 2 deletions
diff --git a/net-libs/glib-networking/glib-networking-2.76.1.ebuild b/net-libs/glib-networking/glib-networking-2.76.1.ebuild
index 63096b664380..b662291fbe8c 100644
--- a/net-libs/glib-networking/glib-networking-2.76.1.ebuild
+++ b/net-libs/glib-networking/glib-networking-2.76.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -58,6 +58,11 @@ multilib_src_configure() {
}
multilib_src_test() {
+ # Pretend the network is available so we get real libproxy parsing
+ # output rather than it giving up early in e.g. systemd-nspawn in some
+ # cases.
+ # https://github.com/libproxy/libproxy/issues/260 (bug #914382)
+ local -x GIO_USE_NETWORK_MONITOR=base
dbus-run-session meson test -C "${BUILD_DIR}" || die 'tests failed'
}
diff --git a/net-libs/glib-networking/glib-networking-2.78.0.ebuild b/net-libs/glib-networking/glib-networking-2.78.0.ebuild
index d69dd2a0427c..725cbc323cd4 100644
--- a/net-libs/glib-networking/glib-networking-2.78.0.ebuild
+++ b/net-libs/glib-networking/glib-networking-2.78.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -58,6 +58,11 @@ multilib_src_configure() {
}
multilib_src_test() {
+ # Pretend the network is available so we get real libproxy parsing
+ # output rather than it giving up early in e.g. systemd-nspawn in some
+ # cases.
+ # https://github.com/libproxy/libproxy/issues/260 (bug #914382)
+ local -x GIO_USE_NETWORK_MONITOR=base
dbus-run-session meson test -C "${BUILD_DIR}" || die 'tests failed'
}