summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2023-08-25 13:52:29 +0200
committerAlexis Ballier <aballier@gentoo.org>2023-08-25 14:54:03 +0200
commit07210e5dd340344e240296b6a86cd7724b498466 (patch)
treedbc7c9cf2b57dafe076c2f0f9be48f81b0751906 /net-libs/ignition-msgs
parentdev-util/ignition-cmake: Fix find protobuf (diff)
downloadgentoo-07210e5dd340344e240296b6a86cd7724b498466.tar.gz
gentoo-07210e5dd340344e240296b6a86cd7724b498466.tar.bz2
gentoo-07210e5dd340344e240296b6a86cd7724b498466.zip
net-libs/ignition-msgs: fix build with latest protobuf
Closes: https://bugs.gentoo.org/912890 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'net-libs/ignition-msgs')
-rw-r--r--net-libs/ignition-msgs/files/protobuf.patch13
-rw-r--r--net-libs/ignition-msgs/ignition-msgs-5.11.0.ebuild1
2 files changed, 14 insertions, 0 deletions
diff --git a/net-libs/ignition-msgs/files/protobuf.patch b/net-libs/ignition-msgs/files/protobuf.patch
new file mode 100644
index 000000000000..5a441ae4d2a9
--- /dev/null
+++ b/net-libs/ignition-msgs/files/protobuf.patch
@@ -0,0 +1,13 @@
+Index: gz-msgs-ignition-msgs5_5.11.0/CMakeLists.txt
+===================================================================
+--- gz-msgs-ignition-msgs5_5.11.0.orig/CMakeLists.txt
++++ gz-msgs-ignition-msgs5_5.11.0/CMakeLists.txt
+@@ -62,7 +62,7 @@ message(STATUS "\n\n-- ====== Finding De
+
+ #--------------------------------------
+ # Find Protobuf
+-set(REQ_PROTOBUF_VER 3)
++set(REQ_PROTOBUF_VER 4)
+ ign_find_package(IgnProtobuf
+ VERSION ${REQ_PROTOBUF_VER}
+ REQUIRED
diff --git a/net-libs/ignition-msgs/ignition-msgs-5.11.0.ebuild b/net-libs/ignition-msgs/ignition-msgs-5.11.0.ebuild
index 552d7c3fb165..647b49fb7925 100644
--- a/net-libs/ignition-msgs/ignition-msgs-5.11.0.ebuild
+++ b/net-libs/ignition-msgs/ignition-msgs-5.11.0.ebuild
@@ -23,3 +23,4 @@ DEPEND="${RDEPEND}
BDEPEND="dev-util/ignition-cmake:2"
CMAKE_BUILD_TYPE=RelWithDebInfo
S="${WORKDIR}/gz-msgs-ignition-msgs5_${PV}"
+PATCHES=( "${FILESDIR}/protobuf.patch" )