summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-04-22 19:23:25 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2024-04-22 19:51:44 +0200
commit4e50514a48aa653e2139607641d4aeaf8b00597c (patch)
tree1bcf55539a3d4e6c6a8fdd024503c8f7c9d3d6a2 /net-libs/libquotient
parentnet-misc/rygel: Stabilize 0.42.5 x86, #928804 (diff)
downloadgentoo-4e50514a48aa653e2139607641d4aeaf8b00597c.tar.gz
gentoo-4e50514a48aa653e2139607641d4aeaf8b00597c.tar.bz2
gentoo-4e50514a48aa653e2139607641d4aeaf8b00597c.zip
net-libs/libquotient: add 0.8.2
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'net-libs/libquotient')
-rw-r--r--net-libs/libquotient/Manifest1
-rw-r--r--net-libs/libquotient/libquotient-0.8.2.ebuild94
2 files changed, 95 insertions, 0 deletions
diff --git a/net-libs/libquotient/Manifest b/net-libs/libquotient/Manifest
index d9f576ea6047..47ece71d2f16 100644
--- a/net-libs/libquotient/Manifest
+++ b/net-libs/libquotient/Manifest
@@ -1 +1,2 @@
DIST libquotient-0.8.1.2.tar.gz 730435 BLAKE2B 7c43bc394d46ddb600c683d771add48f9a20d205ce61796b27a34933521e38be2b3b331263ffc6bb00fd1197a195b295e3311d52d8d74cdfe51453954cb79ae1 SHA512 ff11f1e9093004461425179fcab630237bf1d28f6e5abe6486d657b455b560884047715fccff5b31f26275ffd423df787014aaac35c556eddb1842e8e68841ce
+DIST libquotient-0.8.2.tar.gz 744095 BLAKE2B c33016e4eda22e0a363f06ab4545d17010519b8d778566c1bae29e4c7d6563280f4ce3c1235f7d75f55ce4a8971ef5ce23e45f1d3a0edc043e23857d805a824f SHA512 3d971439f8a89609930ca1648f6cf1bdb59f3ad492af1a15a7f8a13d06c81bd5bfffa1dd732ef5156fab8a9ea2ba3e98376bf76511db17bdeee17641a772b762
diff --git a/net-libs/libquotient/libquotient-0.8.2.ebuild b/net-libs/libquotient/libquotient-0.8.2.ebuild
new file mode 100644
index 000000000000..7ff01c1da407
--- /dev/null
+++ b/net-libs/libquotient/libquotient-0.8.2.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake multibuild
+
+DESCRIPTION="Qt-based SDK to develop applications for Matrix"
+HOMEPAGE="https://github.com/quotient-im/libQuotient"
+SRC_URI="https://github.com/quotient-im/libQuotient/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/libQuotient-${PV}"
+
+LICENSE="LGPL-2+"
+SLOT="0/${PV}" # FIXME: check soname on next version bump
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+IUSE="+qt5 qt6 test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-libs/olm
+ dev-libs/openssl:=
+ qt5? (
+ dev-libs/qtkeychain:=[qt5(+)]
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtmultimedia:5
+ dev-qt/qtnetwork:5[ssl]
+ dev-qt/qtsql:5
+ )
+ qt6? (
+ >=dev-libs/qtkeychain-0.14.1-r1:=[qt6]
+ dev-qt/qtbase:6[gui,network,sql,ssl]
+ dev-qt/qtmultimedia:6
+ )
+"
+DEPEND="${RDEPEND}
+ test? (
+ qt5? (
+ dev-qt/qtconcurrent:5
+ dev-qt/qttest:5
+ )
+ qt6? ( dev-qt/qtbase:6[concurrent] )
+ )
+"
+
+PATCHES=(
+ # downstream patches
+ "${FILESDIR}"/${PN}-0.8.0-no-android.patch
+ "${FILESDIR}"/${PN}-0.8.0-no-tests.patch
+)
+
+pkg_setup() {
+ MULTIBUILD_VARIANTS=( $(usev qt5) $(usev qt6) )
+}
+
+src_configure() {
+ my_src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TESTING=$(usex test)
+ -DQuotient_ENABLE_E2EE=ON
+ )
+
+ if [[ ${MULTIBUILD_VARIANT} == qt6 ]]; then
+ mycmakeargs+=( -DBUILD_WITH_QT6=ON )
+ else
+ mycmakeargs+=( -DBUILD_WITH_QT6=OFF )
+ fi
+
+ use test && mycmakeargs+=(
+ -DQuotient_INSTALL_TESTS=OFF
+ )
+ cmake_src_configure
+ }
+
+ multibuild_foreach_variant my_src_configure
+}
+
+src_compile() {
+ multibuild_foreach_variant cmake_src_compile
+}
+
+src_install() {
+ multibuild_foreach_variant cmake_src_install
+}
+
+src_test() {
+ # https://github.com/quotient-im/libQuotient/issues/435
+ # testolmaccount requires network connection/server set up
+ local myctestargs=(
+ -j1
+ -E "(testolmaccount)"
+ )
+ multibuild_foreach_variant cmake_src_test
+}