summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-06-08 12:23:20 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2023-06-08 13:35:20 +0200
commit5905b7a2cc391dc2da6f180e48321746ecbe77b9 (patch)
tree16f4e8401a3e6707463fef19570a62b3fa3bca79 /net-libs/libquotient
parentnet-libs/libquotient: Enable E2EE (diff)
downloadgentoo-5905b7a2cc391dc2da6f180e48321746ecbe77b9.tar.gz
gentoo-5905b7a2cc391dc2da6f180e48321746ecbe77b9.tar.bz2
gentoo-5905b7a2cc391dc2da6f180e48321746ecbe77b9.zip
net-libs/libquotient: Wire up testing
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'net-libs/libquotient')
-rw-r--r--net-libs/libquotient/libquotient-0.7.2-r1.ebuild27
1 files changed, 23 insertions, 4 deletions
diff --git a/net-libs/libquotient/libquotient-0.7.2-r1.ebuild b/net-libs/libquotient/libquotient-0.7.2-r1.ebuild
index 30724041779e..a83821446a80 100644
--- a/net-libs/libquotient/libquotient-0.7.2-r1.ebuild
+++ b/net-libs/libquotient/libquotient-0.7.2-r1.ebuild
@@ -13,9 +13,10 @@ S="${WORKDIR}/libQuotient-${PV}"
LICENSE="LGPL-2+"
SLOT="0/$(ver_cut 1-2)"
KEYWORDS="~amd64"
-IUSE=""
+IUSE="test"
+RESTRICT="!test? ( test )"
-DEPEND="
+RDEPEND="
dev-libs/libqtolm
dev-libs/olm
dev-libs/qtkeychain:=[qt5(+)]
@@ -24,7 +25,12 @@ DEPEND="
dev-qt/qtmultimedia:5
dev-qt/qtnetwork:5[ssl]
"
-RDEPEND="${DEPEND}"
+DEPEND="${RDEPEND}
+ test? (
+ dev-qt/qtconcurrent:5
+ dev-qt/qttest:5
+ )
+"
PATCHES=(
# downstream patches
@@ -35,8 +41,21 @@ PATCHES=(
src_configure() {
local mycmakeargs=(
-DBUILD_WITH_QT6=OFF
- -DBUILD_TESTING=OFF
+ -DBUILD_TESTING=$(usex test)
-DQuotient_ENABLE_E2EE=ON
)
+ use test && mycmakeargs+=(
+ -DQuotient_INSTALL_TESTS=OFF
+ )
cmake_src_configure
}
+
+src_test() {
+ # https://github.com/quotient-im/libQuotient/issues/435
+ # testolmaccount requires network connection/server set up
+ local myctestargs=(
+ -j1
+ -E "(testolmaccount)"
+ )
+ cmake_src_test
+}