summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-libs/nfqueue-bindings
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-libs/nfqueue-bindings')
-rw-r--r--net-libs/nfqueue-bindings/Manifest1
-rw-r--r--net-libs/nfqueue-bindings/metadata.xml10
-rw-r--r--net-libs/nfqueue-bindings/nfqueue-bindings-0.5.ebuild58
3 files changed, 69 insertions, 0 deletions
diff --git a/net-libs/nfqueue-bindings/Manifest b/net-libs/nfqueue-bindings/Manifest
new file mode 100644
index 000000000000..622138a0c42d
--- /dev/null
+++ b/net-libs/nfqueue-bindings/Manifest
@@ -0,0 +1 @@
+DIST nfqueue-bindings-0.5.tar.xz 20496 SHA256 ebb1ef46681a79d346b6df51bec902316d09ad057abf4a719d276fb694b7ac9b SHA512 52a2cc1a764e3bdc5e97e35a67e4207e5ce3d6a70e336b0d319d1a99581502f955080688c8835b7748fdadadf315fedf5f098ea1832b57f3808e9f563db2f842 WHIRLPOOL 609b0433cbee437664b26a9b3e4550800e2f094a4e6f13fd478a67ad8e67767f742ca336e685345c21096ba61eb15f423f523b3ddd9e87a9924ef61b3fbf57b0
diff --git a/net-libs/nfqueue-bindings/metadata.xml b/net-libs/nfqueue-bindings/metadata.xml
new file mode 100644
index 000000000000..bb8980358b1a
--- /dev/null
+++ b/net-libs/nfqueue-bindings/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>zmedico@gentoo.org</email>
+ </maintainer>
+ <maintainer>
+ <email>chutzpah@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>
diff --git a/net-libs/nfqueue-bindings/nfqueue-bindings-0.5.ebuild b/net-libs/nfqueue-bindings/nfqueue-bindings-0.5.ebuild
new file mode 100644
index 000000000000..35b0d5976eef
--- /dev/null
+++ b/net-libs/nfqueue-bindings/nfqueue-bindings-0.5.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+inherit cmake-utils perl-module linux-info python-single-r1
+
+DESCRIPTION="High-level language bindings for libnetfilter_queue"
+HOMEPAGE="https://www.wzdftpd.net/redmine/projects/nfqueue-bindings/wiki/"
+SRC_URI="https://www.wzdftpd.net/redmine/attachments/download/68/nfqueue-bindings-0.5.tar.xz"
+
+KEYWORDS="~x86 ~amd64"
+SLOT="0"
+LICENSE="GPL-3"
+IUSE="perl python examples"
+REQUIRED_USE="|| ( perl python )"
+
+DEPEND="python? (
+ dev-python/dpkt[${PYTHON_USEDEP}]
+ ${PYTHON_DEPS}
+ )
+ perl? ( dev-lang/perl )
+ net-libs/libnetfilter_queue
+ dev-lang/swig"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+ # At least one of Python or Perl must be selected
+ use python || useq perl || die "At least one supported language must be selected."
+ # Check kernel configuration for NFQUEUE
+ if linux_config_exists; then
+ ebegin "Checking NETFILTER_NETLINK_QUEUE support"
+ linux_chkconfig_present NETFILTER_NETLINK_QUEUE
+ eend $? || \
+ eerror 'Netfilter NFQUEUE over NFNETLINK interface support not found!'
+ ebegin "Checking NETFILTER_XT_TARGET_NFQUEUE support"
+ linux_chkconfig_present NETFILTER_XT_TARGET_NFQUEUE
+ eend $? || \
+ eerror '"NFQUEUE" target Support not found!'
+ fi
+}
+
+src_prepare() {
+ # Fix Perl destination directory
+ perl_set_version
+ sed -i "s|\${LIB_INSTALL_DIR}/perl\${PERL_VERSION}/|${VENDOR_ARCH}|" perl/CMakeLists.txt || die
+ sed -i "s|\${LIB_INSTALL_DIR}/python\${PYTHON_VERSION}/dist-packages/|$(python_get_sitedir)|" python/CMakeLists.txt || die
+ # Disable Perl/Python from USE flags
+ use perl || sed -i 's|ADD_SUBDIRECTORY(perl)||' CMakeLists.txt || die
+ use python || sed -i 's|ADD_SUBDIRECTORY(python)||' CMakeLists.txt || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install PREFIX=/usr || die
+ docinto examples
+ use examples && dodoc examples/*
+}