summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-libs/openmq-cclient/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-libs/openmq-cclient/files')
-rw-r--r--net-libs/openmq-cclient/files/Makefile.in-469
-rw-r--r--net-libs/openmq-cclient/files/openmq-cclient-4.4.1-aix-gcc.patch13
2 files changed, 82 insertions, 0 deletions
diff --git a/net-libs/openmq-cclient/files/Makefile.in-4 b/net-libs/openmq-cclient/files/Makefile.in-4
new file mode 100644
index 000000000000..8d536b927566
--- /dev/null
+++ b/net-libs/openmq-cclient/files/Makefile.in-4
@@ -0,0 +1,69 @@
+prefix=@prefix@
+exec_prefix=@exec_prefix@
+libdir=@libdir@
+includedir=@includedir@
+
+top_srcdir=@top_srcdir@
+top_builddir=@top_builddir@
+
+CC = @CC@
+CXX = @CXX@
+LIBTOOL = @LIBTOOL@
+
+CFLAGS = @CFLAGS@
+CXXFLAGS = @CXXFLAGS@
+LDFLAGS = @LDFLAGS@
+
+LTCC = $(LIBTOOL) --mode=compile --tag=CC $(CC)
+LTCXX = $(LIBTOOL) --mode=compile --tag=CXX $(CXX)
+LTLD = $(LIBTOOL) --mode=link --tag=CXX $(CXX)
+
+NS_S_PR_CFLAGS = $(shell pkg-config --cflags nss nspr)
+NS_S_PR_LIBS = $(shell pkg-config --libs nss nspr)
+
+SRCS = $(shell find "$(top_srcdir)" -name examples -prune -o -type f '(' -name '*.cpp' -o -name '*.c' -not -name '*Test*' ')')
+LTOBJS = $(subst .c,.lo,$(subst .cpp,.lo,$(SRCS)))
+
+HDRS = $(top_srcdir)/cshim/mq/xa.h $(shell find "$(top_srcdir)"/cshim -type f -name 'mq*.h')
+INSTHDRS = $(subst $(top_srcdir)/cshim,$(DESTDIR)$(includedir),$(HDRS))
+
+LTLIBRARY = libmqcrt.la
+INSTLTLIBRARY = $(DESTDIR)$(libdir)/$(LTLIBRARY)
+
+.SUFFIXES:
+.SUFFIXES: .cpp .c .lo
+
+default: all
+
+all: $(LTLIBRARY)
+
+Makefile: Makefile.in
+ $(top_builddir)/config.status $@
+
+.cpp.lo:
+ $(LTCXX) -o $@ $(NS_S_PR_CFLAGS) $(CXXFLAGS) -c $<
+
+.c.lo:
+ $(LTCC) -o $@ $(NS_S_PR_CFLAGS) $(CFLAGS) -c $<
+
+VERSIONNUMBER = $(shell { echo '#include "cshim/mqversion.h"'; echo '-version-number MQ_VMAJOR:MQ_VMINOR:MQ_VMICRO'; } | ${CC} -E - | grep version-number)
+
+$(LTLIBRARY): $(LTOBJS)
+ version=` \
+ { echo '#include "cshim/mqversion.h"' \
+ ; echo '-version-number MQ_VMAJOR:MQ_VMINOR:MQ_VMICRO' \
+ ; } \
+ | ${CC} -E - \
+ | grep version-number \
+ ` \
+ && $(LTLD) -o $@ --no-undefined $${version} $(CXXFLAGS) $(NS_S_PR_LIBS) $(LDFLAGS) -rpath $(libdir) $?
+
+$(INSTLTLIBRARY): $(LTLIBRARY)
+ $(top_srcdir)/install-sh -d "$(dir $@)"
+ $(LIBTOOL) --mode=install cp $(LTLIBRARY) $@
+
+$(DESTDIR)$(includedir)/%: $(top_srcdir)/cshim/%
+ $(top_srcdir)/install-sh -d "$(dir $@)"
+ cp -f "$<" "$@"
+
+install: $(INSTLTLIBRARY) $(INSTHDRS)
diff --git a/net-libs/openmq-cclient/files/openmq-cclient-4.4.1-aix-gcc.patch b/net-libs/openmq-cclient/files/openmq-cclient-4.4.1-aix-gcc.patch
new file mode 100644
index 000000000000..e9a9d7281738
--- /dev/null
+++ b/net-libs/openmq-cclient/files/openmq-cclient-4.4.1-aix-gcc.patch
@@ -0,0 +1,13 @@
+Seems they've never seen gcc on AIX.
+
+--- cshim/mqbasictypes.h.orig 2010-03-01 18:00:38 +0100
++++ cshim/mqbasictypes.h 2010-03-01 18:00:58 +0100
+@@ -64,7 +64,7 @@
+ #endif
+ #endif
+
+-#if (defined(__IBMC__) || defined (__IBMCPP__)) && defined(__unix__)
++#if ((defined(__IBMC__) || defined (__IBMCPP__)) && defined(__unix__)) || defined(_AIX)
+ #ifndef AIX
+ #define AIX
+ #endif