summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-10-18 17:00:40 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-10-18 17:01:28 +0200
commit9805bb723391d4741041e8f32faffc60289d7a4a (patch)
tree1f848a1cbfec8a2be412e5853c59c1685c10ed99 /net-libs/xrootd
parentdev-lang/zig: fix building with Clang 16, fix searching LLD (diff)
downloadgentoo-9805bb723391d4741041e8f32faffc60289d7a4a.tar.gz
gentoo-9805bb723391d4741041e8f32faffc60289d7a4a.tar.bz2
gentoo-9805bb723391d4741041e8f32faffc60289d7a4a.zip
net-libs/xrootd: add 5.5.0
Closes: https://bugs.gentoo.org/877555 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'net-libs/xrootd')
-rw-r--r--net-libs/xrootd/Manifest1
-rw-r--r--net-libs/xrootd/xrootd-5.5.0.ebuild134
2 files changed, 135 insertions, 0 deletions
diff --git a/net-libs/xrootd/Manifest b/net-libs/xrootd/Manifest
index 82d24fcfcf67..1515cb9abb1e 100644
--- a/net-libs/xrootd/Manifest
+++ b/net-libs/xrootd/Manifest
@@ -1 +1,2 @@
DIST xrootd-5.4.3.tar.gz 3182127 BLAKE2B ed3f6a943167eafb5f6d7f78ca34f44c9a18b5ed672a4e622acb1e6e6997bd21756a30bf24f0b799ab4f16e7e1fb3f61a042f4e5e00f965b898fc5a287bf995a SHA512 189ec8e20901fd07093494187502e031a60d4ade22af33067313fad7a1bf6a6feb5c5d9d59d3a86d13a6a767e5a93cf4836da02e9cae11c81ccac07199898d72
+DIST xrootd-5.5.0.tar.gz 3227490 BLAKE2B 3d9c0ab859f95d6e651ae98dc132ade389f9981a20c738798bc2079a5470d766cd882df326359ccd4777389e15bf064537e6d4f7f653fbb5fe251b019b4ca5fd SHA512 d13d76be54eacc097363cd1c06448f87bffdd32c81eaad12b4c3321be31c7b221ef34b1bf5da50ee5128d9682e13dc670554317c29c13607c246c781a1fefffe
diff --git a/net-libs/xrootd/xrootd-5.5.0.ebuild b/net-libs/xrootd/xrootd-5.5.0.ebuild
new file mode 100644
index 000000000000..53f8a65ef85d
--- /dev/null
+++ b/net-libs/xrootd/xrootd-5.5.0.ebuild
@@ -0,0 +1,134 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# Upstream does not support the building of Python bindings
+# via CMake for more than one implementation at a time.
+PYTHON_COMPAT=( python3_{8..11} )
+DOCS_BUILDER="doxygen"
+DOCS_DEPEND="
+ media-gfx/graphviz
+ virtual/latex-base
+ python? ( dev-python/sphinx )
+"
+
+inherit cmake docs python-single-r1
+
+DESCRIPTION="Extended ROOT remote file server"
+HOMEPAGE="https://xrootd.slac.stanford.edu/"
+SRC_URI="https://xrootd.slac.stanford.edu/download/v${PV}/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="examples fuse http kerberos +libxml2 python readline +server systemd test"
+RESTRICT="!test? ( test )"
+
+CDEPEND="acct-group/xrootd
+ acct-user/xrootd
+ dev-libs/openssl:0=
+ net-libs/davix
+ sys-libs/zlib
+ virtual/libcrypt:=
+ fuse? ( sys-fs/fuse:0= )
+ http? ( net-misc/curl:= )
+ kerberos? ( virtual/krb5 )
+ libxml2? ( dev-libs/libxml2:2= )
+ python? ( ${PYTHON_DEPS} )
+ readline? ( sys-libs/readline:0= )
+ systemd? ( sys-apps/systemd:= )
+"
+DEPEND="${CDEPEND}"
+BDEPEND="
+ python? ( $(python_gen_cond_dep 'dev-python/pip[${PYTHON_USEDEP}]') )
+ test? ( dev-util/cppunit )
+"
+RDEPEND="${CDEPEND}
+ dev-lang/perl
+"
+REQUIRED_USE="
+ http? ( kerberos )
+ python? ( ${PYTHON_REQUIRED_USE} )
+ test? ( server )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-4.8.3-crc32.patch
+ "${FILESDIR}"/${PN}-5.4.3-no_automagic.patch
+)
+
+# xrootd plugins are not intended to be linked with,
+# they are to be loaded at runtime by xrootd,
+# see https://github.com/xrootd/xrootd/issues/447
+QA_SONAME="/usr/lib.*/libXrd.*-$(ver_cut 1)\.so
+ /usr/lib.*/libXrdClTests\.so"
+
+pkg_setup() {
+ use python && python_setup
+}
+
+# FIXME: support xrdec - currently only builds against bundled isa-l
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_FUSE=$(usex fuse)
+ -DENABLE_HTTP=$(usex http)
+ -DENABLE_KRB5=$(usex kerberos)
+ -DENABLE_LIBXML2=$(usex libxml2)
+ -DENABLE_PYTHON=$(usex python)
+ -DENABLE_READLINE=$(usex readline)
+ -DENABLE_TESTS=$(usex test)
+ -DENABLE_VOMS=no
+ -DFORCE_ENABLED=yes
+ -DPIP_OPTIONS="--ignore-installed" # bug 861452
+ -DXRDCL_ONLY=$(usex server "no" "yes")
+ )
+ cmake_src_configure
+}
+
+src_compile() {
+ cmake_src_compile
+ docs_compile
+
+ # secondary documentation for python bindings
+ if use python && use doc; then
+ emake -C bindings/python/docs html
+ fi
+}
+
+src_install() {
+ dodoc docs/ReleaseNotes.txt
+ cmake_src_install
+ find "${ED}" \( -iname '*.md5' -o -iname '*.map' \) -delete || die
+
+ # base configs
+ insinto /etc/xrootd
+ doins packaging/common/*.cfg
+
+ fowners root:xrootd /etc/xrootd
+ keepdir /var/log/xrootd
+ fowners xrootd:xrootd /var/log/xrootd
+
+ if use server; then
+ local i
+ for i in cmsd frm_purged frm_xfrd xrootd; do
+ newinitd "${FILESDIR}"/${i}.initd ${i}
+ done
+ # all daemons MUST use single master config file
+ newconfd "${FILESDIR}"/xrootd.confd xrootd
+ fi
+
+ if use python; then
+ python_optimize "${D}/$(python_get_sitedir)"
+
+ if use doc; then
+ docinto python
+ docompress -x "/usr/share/doc/${PF}/python/html"
+ dodoc -r bindings/python/docs/build/html
+ fi
+ if use examples; then
+ docinto python
+ dodoc -r bindings/python/examples
+ fi
+ fi
+}