summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuilherme Amadio <amadio@gentoo.org>2024-09-27 16:31:31 +0200
committerGuilherme Amadio <amadio@gentoo.org>2024-09-30 16:19:06 +0200
commitd705a8e199046c2b0dc54b569f91594b72cd9039 (patch)
tree51c106a4e713c6f31e46253fbb67bbd64e654fd2 /net-libs/xrootd
parentsys-boot/refind: Stabilize 0.14.2-r2 amd64, #940522 (diff)
downloadgentoo-d705a8e199046c2b0dc54b569f91594b72cd9039.tar.gz
gentoo-d705a8e199046c2b0dc54b569f91594b72cd9039.tar.bz2
gentoo-d705a8e199046c2b0dc54b569f91594b72cd9039.zip
net-libs/xrootd: add 5.7.1
Signed-off-by: Guilherme Amadio <amadio@gentoo.org>
Diffstat (limited to 'net-libs/xrootd')
-rw-r--r--net-libs/xrootd/Manifest1
-rw-r--r--net-libs/xrootd/xrootd-5.7.1.ebuild200
2 files changed, 201 insertions, 0 deletions
diff --git a/net-libs/xrootd/Manifest b/net-libs/xrootd/Manifest
index f9c6d0e80d00..4fa93475f77c 100644
--- a/net-libs/xrootd/Manifest
+++ b/net-libs/xrootd/Manifest
@@ -1,3 +1,4 @@
DIST xrootd-5.6.7.tar.gz 6698751 BLAKE2B cb702a450b81665b53cf15d5c8df239826148c3cd746db7778b48ae01244257ce4877402c3e07ef6aa5228f9ae97f1b39210ed46ea2c802c35b7c4d8ad6a7fcf SHA512 e7ec8b6eae684f27b5044890c45492f7d9b2b8812a9131ff45db63984869aa62cd85836d71b4100e89a6bb98ee3864062940d4dec0fdb340472df126d6de4d41
DIST xrootd-5.6.9.tar.gz 6701277 BLAKE2B 0086455f251879acf2d635ed0ae533dfa2c3e006798df27111d35599f1833ce1342c9eec1f540f3a165376c91233181420635bae5e1cb4d552681d8cfe36d902 SHA512 9ba15524451ebe7ee12d689f9c56d85508996285d01885236d396b7742ff6cc03036a6b4bd1424b0e1553cbf382c0954c10cec76fa1a99a7dfff330686bad0cd
DIST xrootd-5.7.0.tar.gz 6807467 BLAKE2B c309bf363baddeecd2e6fa0b33f16154a6297a779d2b08bf2a92e44765f92c32917568c2f3aa8961a24f1e6598e521112daba68ec303d01cb1d6e40fc2b31d2a SHA512 2103d453e8d655a19c58beb050158b08f6e36ce5d1a6cc9181881af3cae06938222a00af5cad102d1e2df4408d61ea364e54a0d2d41c71f1f2e07641a618effe
+DIST xrootd-5.7.1.tar.gz 6819353 BLAKE2B 097b2f0cf15aa2e1dfd5fe6923b9197be54d208b992a958620f278dfe4de3ea9b84e77751382f5a55b40a46716ac21ebb17bb555f674691ec4f070c59ba7e8b8 SHA512 7b6e802d808950332dd2f99c45f6befbf557a33962e97f6e0846c657fd7ef20001b2b116bd7e235d542cbc7433e6afbe2d4006c92c12e370a7dd4389600e3a27
diff --git a/net-libs/xrootd/xrootd-5.7.1.ebuild b/net-libs/xrootd/xrootd-5.7.1.ebuild
new file mode 100644
index 000000000000..8145aad04995
--- /dev/null
+++ b/net-libs/xrootd/xrootd-5.7.1.ebuild
@@ -0,0 +1,200 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..13} )
+DISTUTILS_EXT=1
+DISTUTILS_OPTIONAL=1
+DISTUTILS_USE_PEP517="setuptools"
+DOCS_BUILDER="doxygen"
+DOCS_DEPEND="
+ media-gfx/graphviz
+ virtual/latex-base
+ python? ( dev-python/sphinx )
+"
+
+inherit cmake docs distutils-r1 systemd
+
+DESCRIPTION="Extended ROOT remote file server"
+HOMEPAGE="https://xrootd.slac.stanford.edu/"
+SRC_URI="https://xrootd.web.cern.ch/download/v${PV}/${P}.tar.gz"
+LICENSE="LGPL-3+"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="ceph examples fuse http kerberos +libxml2 macaroons python readline scitokens +server systemd test xrdec"
+
+RESTRICT="!test? ( test )"
+
+REQUIRED_USE="
+ http? ( kerberos )
+ macaroons? ( server http )
+ python? ( ${PYTHON_REQUIRED_USE} )
+ scitokens? ( server )
+ test? ( server )
+"
+
+CDEPEND="acct-group/xrootd
+ acct-user/xrootd
+ dev-libs/openssl:0=
+ sys-libs/zlib
+ virtual/libcrypt:=
+ ceph? ( sys-cluster/ceph )
+ fuse? ( sys-fs/fuse:0= )
+ http? (
+ net-misc/curl:=
+ net-libs/davix
+ )
+ kerberos? ( virtual/krb5 )
+ libxml2? ( dev-libs/libxml2:2= )
+ macaroons? ( dev-libs/libmacaroons )
+ python? ( ${PYTHON_DEPS} )
+ readline? ( sys-libs/readline:0= )
+ scitokens? ( dev-cpp/scitokens-cpp )
+ systemd? ( sys-apps/systemd:= )
+ xrdec? ( dev-libs/isa-l )
+"
+DEPEND="${CDEPEND}"
+BDEPEND="
+ python? (
+ ${PYTHON_DEPS}
+ ${DISTUTILS_DEPS}
+ test? ( >=dev-python/pytest-7.1.2[${PYTHON_USEDEP}] )
+ )
+ test? (
+ dev-cpp/gtest
+ dev-util/cppunit
+ )
+"
+RDEPEND="${CDEPEND}
+ dev-lang/perl
+"
+
+# xrootd plugins are not intended to be linked with,
+# they are to be loaded at runtime by xrootd,
+# see https://github.com/xrootd/xrootd/issues/447
+QA_SONAME="/usr/lib.*/libXrd.*-$(ver_cut 1)\.so
+ /usr/lib.*/libXrd.*Tests\.so"
+
+pkg_setup() {
+ use python && python_setup
+}
+
+src_prepare() {
+ cmake_src_prepare
+
+ if use python; then
+ pushd "${S}"/bindings/python > /dev/null || die
+ distutils-r1_src_prepare
+ popd > /dev/null || die
+ fi
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DUSE_SYSTEM_ISAL=TRUE
+ $(usex python "-DINSTALL_PYTHON_BINDINGS=FALSE" "")
+ -DXRDCEPH_SUBMODULE=$(usex ceph)
+ -DCMAKE_DISABLE_FIND_PACKAGE_LibXml2=$(usex libxml2 "no" "yes")
+ -DCMAKE_DISABLE_FIND_PACKAGE_systemd=$(usex systemd "no" "yes")
+ -DENABLE_FUSE=$(usex fuse)
+ -DENABLE_HTTP=$(usex http)
+ -DENABLE_KRB5=$(usex kerberos)
+ -DENABLE_MACAROONS=$(usex macaroons)
+ -DENABLE_PYTHON=$(usex python)
+ -DENABLE_READLINE=$(usex readline)
+ -DENABLE_SCITOKENS=$(usex scitokens)
+ -DENABLE_TESTS=$(usex test)
+ -DENABLE_VOMS=no
+ -DENABLE_XRDCL=yes
+ -DENABLE_XRDCLHTTP=$(usex http)
+ -DENABLE_XRDEC=$(usex xrdec)
+ -DFORCE_ENABLED=yes
+ -DXRDCL_ONLY=$(usex server "no" "yes")
+ )
+ cmake_src_configure
+
+ if use python; then
+ pushd "${BUILD_DIR}"/bindings/python > /dev/null || die
+ distutils-r1_src_configure
+ popd > /dev/null || die
+ fi
+}
+
+src_compile() {
+ cmake_src_compile
+ if use python; then
+ pushd "${BUILD_DIR}"/bindings/python > /dev/null || die
+ distutils-r1_src_compile
+ popd > /dev/null || die
+ fi
+
+ docs_compile
+ # secondary documentation for python bindings
+ if use python && use doc; then
+ emake -C bindings/python/docs html
+ fi
+}
+
+python_test() {
+ epytest
+}
+
+src_test() {
+ cmake_src_test
+ # Python tests currently require manual configuration and start-up of an xrootd server.
+ # TODO: get this to run properly.
+ #use python && distutils-r1_src_test
+}
+
+src_install() {
+ dodoc docs/ReleaseNotes.txt
+ cmake_src_install
+ find "${ED}" \( -iname '*.md5' -o -iname '*.map' \) -delete || die
+
+ if use server; then
+ local i
+ for i in cmsd frm_purged frm_xfrd xrootd; do
+ newinitd "${FILESDIR}"/${i}.initd ${i}
+ done
+ # all daemons MUST use single master config file
+ newconfd "${FILESDIR}"/xrootd.confd xrootd
+
+ if use systemd; then
+ systemd_dounit packaging/common/*.{service,socket}
+ fi
+ fi
+
+ # base configs
+ insinto /etc/xrootd
+ doins packaging/common/*.cfg
+
+ keepdir /etc/xrootd/config.d
+ keepdir /var/log/xrootd
+
+ fowners -R xrootd:xrootd /etc/xrootd
+ fowners -R xrootd:xrootd /var/log/xrootd
+
+ if use python; then
+ pushd "${BUILD_DIR}"/bindings/python > /dev/null || die
+ distutils-r1_src_install
+ popd > /dev/null || die
+
+ if use doc; then
+ docinto python
+ docompress -x "/usr/share/doc/${PF}/python/html"
+ dodoc -r bindings/python/docs/build/html
+ fi
+ if use examples; then
+ docinto python
+ dodoc -r bindings/python/examples
+ fi
+ fi
+
+ if use test; then
+ for f in xrdshmap; do
+ rm "${ED}"/usr/bin/${f} || die "Failed to remove test helper ${f} from installed tree"
+ done
+ fi
+}