summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2018-03-25 20:19:24 +0200
committerGilles Dartiguelongue <eva@gentoo.org>2018-03-25 22:40:28 +0200
commit347ce2c59f01431a937f8a56c2a6277a85597287 (patch)
tree54e0942eade340ef5a3a0c4c69b1d9fa469c8bd1 /net-libs
parentsys-apps/usb_modeswitch: version bump to 2.5.2, bug #622656 (diff)
downloadgentoo-347ce2c59f01431a937f8a56c2a6277a85597287.tar.gz
gentoo-347ce2c59f01431a937f8a56c2a6277a85597287.tar.bz2
gentoo-347ce2c59f01431a937f8a56c2a6277a85597287.zip
net-libs/libproxy: fix configure warnings
Explicitely disable NATUS support, bug #624274. Do not pass unneeded variables if corresponding support is not enabled (perl, mono), bug #649454. Closes: https://bugs.gentoo.org/649454 Closes: https://bugs.gentoo.org/624274 Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/libproxy/libproxy-0.4.13-r2.ebuild7
1 files changed, 4 insertions, 3 deletions
diff --git a/net-libs/libproxy/libproxy-0.4.13-r2.ebuild b/net-libs/libproxy/libproxy-0.4.13-r2.ebuild
index d212bc6f1b13..d5e475e1e5ce 100644
--- a/net-libs/libproxy/libproxy-0.4.13-r2.ebuild
+++ b/net-libs/libproxy/libproxy-0.4.13-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -61,13 +61,13 @@ PATCHES=(
multilib_src_configure() {
local mycmakeargs=(
- '-DPERL_VENDORINSTALL=ON'
+ "$(multilib_is_native_abi && usex perl -DPERL_VENDORINSTALL=ON)"
# WITH_VALA just copies the .vapi file over and needs no deps,
# hence always enable it unconditionally
'-DWITH_VALA=ON'
"-DCMAKE_C_FLAGS=${CFLAGS}"
"-DCMAKE_CXX_FLAGS=${CXXFLAGS}"
- "-DGMCS_EXECUTABLE='${EPREFIX}/usr/bin/mcs'"
+ "$(multilib_is_native_abi && usex mono -DGMCS_EXECUTABLE="${EPREFIX}/usr/bin/mcs")"
"-DWITH_GNOME3=$(usex gnome)"
"-DWITH_KDE=$(usex kde)"
"-DWITH_DOTNET=$(multilib_is_native_abi && usex mono || echo 'OFF')"
@@ -75,6 +75,7 @@ multilib_src_configure() {
"-DWITH_PERL=$(multilib_is_native_abi && usex perl || echo 'OFF')"
"-DWITH_PYTHON=$(multilib_is_native_abi && usex python || echo 'OFF')"
"-DWITH_MOZJS=$(multilib_is_native_abi && usex spidermonkey || echo 'OFF')"
+ "-DWITH_NATUS=OFF"
"-DWITH_WEBKIT=OFF"
"-DWITH_WEBKIT3=$(multilib_is_native_abi && usex webkit || echo 'OFF')"
"-DBUILD_TESTING=$(usex test)"