summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarlson2k (Evgeny Grin) <k2k@narod.ru>2024-05-22 13:51:56 +0200
committerSam James <sam@gentoo.org>2024-05-22 18:02:45 +0100
commit9165284da18643f84258374610687a347937face (patch)
treee873b8b54ba771de9b17ea9559bf67965dcef37d /net-libs
parentdev-db/kdb: Fix build w/ ICU-75 (diff)
downloadgentoo-9165284da18643f84258374610687a347937face.tar.gz
gentoo-9165284da18643f84258374610687a347937face.tar.bz2
gentoo-9165284da18643f84258374610687a347937face.zip
net-libs/libmicrohttpd: mute QA warning with clang
This is actually a workaround for clang bug. Closes: https://bugs.gentoo.org/923760 Signed-off-by: Karlson2k (Evgeny Grin) <k2k@narod.ru> Closes: https://github.com/gentoo/gentoo/pull/36774 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/libmicrohttpd/libmicrohttpd-0.9.76.ebuild2
-rw-r--r--net-libs/libmicrohttpd/libmicrohttpd-0.9.77.ebuild6
-rw-r--r--net-libs/libmicrohttpd/libmicrohttpd-1.0.1.ebuild6
3 files changed, 14 insertions, 0 deletions
diff --git a/net-libs/libmicrohttpd/libmicrohttpd-0.9.76.ebuild b/net-libs/libmicrohttpd/libmicrohttpd-0.9.76.ebuild
index 03bfe985f82f..23248a0a4ddd 100644
--- a/net-libs/libmicrohttpd/libmicrohttpd-0.9.76.ebuild
+++ b/net-libs/libmicrohttpd/libmicrohttpd-0.9.76.ebuild
@@ -30,6 +30,7 @@ PATCHES=( "${FILESDIR}"/${PN}-0.9.75-fix-testsuite-with-lto.patch )
# All checks in libmicrohttpd's configure are correct
# Gentoo Bug #898662
+# Gentoo Bug #923760
QA_CONFIG_IMPL_DECL_SKIP=(
'pthread_sigmask'
'CreateThread'
@@ -64,6 +65,7 @@ QA_CONFIG_IMPL_DECL_SKIP=(
'sysctlbyname'
'usleep'
'nanosleep'
+ 'stpncpy'
)
multilib_src_configure() {
diff --git a/net-libs/libmicrohttpd/libmicrohttpd-0.9.77.ebuild b/net-libs/libmicrohttpd/libmicrohttpd-0.9.77.ebuild
index d0eed498d5a5..4e246d236516 100644
--- a/net-libs/libmicrohttpd/libmicrohttpd-0.9.77.ebuild
+++ b/net-libs/libmicrohttpd/libmicrohttpd-0.9.77.ebuild
@@ -27,6 +27,12 @@ BDEPEND="ssl? ( virtual/pkgconfig )"
DOCS=( AUTHORS NEWS COPYING README ChangeLog )
+# All checks in libmicrohttpd's configure are correct
+# Gentoo Bug #923760
+QA_CONFIG_IMPL_DECL_SKIP=(
+ 'stpncpy'
+)
+
pkg_pretend() {
if use kernel_linux ; then
CONFIG_CHECK=""
diff --git a/net-libs/libmicrohttpd/libmicrohttpd-1.0.1.ebuild b/net-libs/libmicrohttpd/libmicrohttpd-1.0.1.ebuild
index bf51ab887652..149b791325ff 100644
--- a/net-libs/libmicrohttpd/libmicrohttpd-1.0.1.ebuild
+++ b/net-libs/libmicrohttpd/libmicrohttpd-1.0.1.ebuild
@@ -27,6 +27,12 @@ BDEPEND="ssl? ( virtual/pkgconfig )"
DOCS=( AUTHORS NEWS COPYING README ChangeLog )
+# All checks in libmicrohttpd's configure are correct
+# Gentoo Bug #923760
+QA_CONFIG_IMPL_DECL_SKIP=(
+ 'stpncpy'
+)
+
pkg_pretend() {
if use kernel_linux ; then
CONFIG_CHECK=""