summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2024-07-16 11:48:15 -0400
committerMike Gilbert <floppym@gentoo.org>2024-07-16 11:48:15 -0400
commitfb59620a0c0efd81f2ed54cae688ba9c2e48005b (patch)
treec1dc9ea0d0a8c78e52fcb63450e331c73b3d0685 /net-misc/freerdp
parentnet-misc/freerdp: update smartcard deps (diff)
downloadgentoo-fb59620a0c0efd81f2ed54cae688ba9c2e48005b.tar.gz
gentoo-fb59620a0c0efd81f2ed54cae688ba9c2e48005b.tar.bz2
gentoo-fb59620a0c0efd81f2ed54cae688ba9c2e48005b.zip
net-misc/freerdp: add 3.6.3
Bug: https://bugs.gentoo.org/935874 Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'net-misc/freerdp')
-rw-r--r--net-misc/freerdp/Manifest2
-rw-r--r--net-misc/freerdp/freerdp-3.6.3.ebuild182
2 files changed, 184 insertions, 0 deletions
diff --git a/net-misc/freerdp/Manifest b/net-misc/freerdp/Manifest
index d396c7727108..214b2574f9f3 100644
--- a/net-misc/freerdp/Manifest
+++ b/net-misc/freerdp/Manifest
@@ -9,3 +9,5 @@ DIST freerdp-3.5.1.tar.gz 9338947 BLAKE2B dd004333a52046300a5f319346da46ddb460e8
DIST freerdp-3.5.1.tar.gz.asc 228 BLAKE2B ae5826e539f0078d3adf7a4886f0b0c249c73fd2fc7ae21dcf815d876ec26f4482c242c076dbd9dcadd18927f4f97199f16fac3b40c0c04b1e43482865af15dc SHA512 ba52d6a5aa3d91fdab988d91b8591ccb075ce3d52bbee0596ffdb50902b54e650b397995f273463296a484199b969bab47708b5dbfc76c4128aa54ec5afcfdf2
DIST freerdp-3.6.2.tar.gz 10195789 BLAKE2B 42e8337f8be0345bd182e46354b9ccd4b1a241679834d82e567e80576f69c7b09e5e4c548ff4e4386bdba3a8d44fd1b5c63932d720f7ed22ab70f6f2e0f254a4 SHA512 c0f4d85c3e90158dbd966363d4e78a32c56c8cbedd1520dd1a517cd392a811644073760dcaeb2668f00a92febd3c74fd8e2f26447bbe76069e6a6fdba9a67d2c
DIST freerdp-3.6.2.tar.gz.asc 228 BLAKE2B fbf27c8804329abaf9eb844caac8ef69c48cf6982ac92cd5a0f8191347439aae69d4ad9e5d014f6ab0ba5521d103fdcdfe00de5ff603e632a5518b4e29cca3dd SHA512 4e0c86355112c603627edb802e61444d9c35b4b12a89300073a4e46c093a3fe2011a9e0774c4b493b8289f9e06c46d8bca381bdcd80c9c40d1bbe5e2516fbdfc
+DIST freerdp-3.6.3.tar.gz 10199503 BLAKE2B ff4c76a7f2d808db09d22b6cf79caaa1f1aff58c25d37d853d4244cf4b8d0f522cb3ad384c6284544a08e2092277e7b4ee8a6f9fa61bb24319d7c5d08aebfdc7 SHA512 e92b839bdaaed99f05c3ab883a864fb3a18a01b5e173317b1cf8210ad16cbf25f2133b8893dec9f9d3a92b0a2fbcb0230f549e1632ade0394b5c8ea0f7331e1e
+DIST freerdp-3.6.3.tar.gz.asc 228 BLAKE2B 4ea04f0d662afef34d61f06d36f3bd6f872f2a7cd8095df581f489306d88a761921a0a93325bdd4c5a627a1c47c612652697b9dc3338ebe0ea952a65b0783cc7 SHA512 6568362c2ad1032925e7dfcd04977c56a58e661b8eacc79d6d2ad77bb9e56d3dff3f13d004d50a88827aa9ccbd2f56c1019a53e18bf35856dbec81acba1dc142
diff --git a/net-misc/freerdp/freerdp-3.6.3.ebuild b/net-misc/freerdp/freerdp-3.6.3.ebuild
new file mode 100644
index 000000000000..51aab209a2db
--- /dev/null
+++ b/net-misc/freerdp/freerdp-3.6.3.ebuild
@@ -0,0 +1,182 @@
+# Copyright 2011-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake flag-o-matic
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/FreeRDP/FreeRDP.git"
+ case ${PV} in
+ 2.*) EGIT_BRANCH="stable-2.0";;
+ esac
+else
+ inherit verify-sig
+ MY_P=${P/_/-}
+ S="${WORKDIR}/${MY_P}"
+ SRC_URI="https://pub.freerdp.com/releases/${MY_P}.tar.gz
+ verify-sig? ( https://pub.freerdp.com/releases/${MY_P}.tar.gz.asc )"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~x86"
+ BDEPEND="verify-sig? ( sec-keys/openpgp-keys-akallabeth )"
+ VERIFY_SIG_OPENPGP_KEY_PATH="/usr/share/openpgp-keys/akallabeth.asc"
+fi
+
+DESCRIPTION="Free implementation of the Remote Desktop Protocol"
+HOMEPAGE="https://www.freerdp.com/"
+
+LICENSE="Apache-2.0"
+SLOT="3"
+IUSE="aad alsa cpu_flags_arm_neon +client cups debug +ffmpeg +fuse gstreamer +icu jpeg kerberos openh264 pulseaudio sdl server smartcard systemd test usb valgrind wayland X xinerama xv"
+RESTRICT="!test? ( test )"
+
+BDEPEND+="
+ virtual/pkgconfig
+ app-text/docbook-xsl-stylesheets
+ dev-libs/libxslt
+"
+COMMON_DEPEND="
+ dev-libs/openssl:0=
+ sys-libs/zlib:0
+ aad? ( dev-libs/cJSON )
+ alsa? ( media-libs/alsa-lib )
+ cups? ( net-print/cups )
+ usb? (
+ virtual/libudev:0=
+ sys-apps/util-linux:0=
+ dev-libs/dbus-glib:0=
+ virtual/libusb:1=
+ )
+ X? (
+ x11-libs/libXcursor
+ x11-libs/libXext
+ x11-libs/libXi
+ x11-libs/libXrender
+ xinerama? ( x11-libs/libXinerama )
+ xv? ( x11-libs/libXv )
+ )
+ ffmpeg? ( media-video/ffmpeg:0= )
+ !ffmpeg? (
+ x11-libs/cairo:0=
+ )
+ fuse? ( sys-fs/fuse:3 )
+ gstreamer? (
+ media-libs/gstreamer:1.0
+ media-libs/gst-plugins-base:1.0
+ X? ( x11-libs/libXrandr )
+ )
+ icu? ( dev-libs/icu:0= )
+ jpeg? ( media-libs/libjpeg-turbo:0= )
+ kerberos? ( virtual/krb5 )
+ openh264? ( media-libs/openh264:0= )
+ pulseaudio? ( media-libs/libpulse )
+ sdl? (
+ media-libs/libsdl2[haptic(+),joystick(+),sound(+),video(+)]
+ media-libs/sdl2-ttf
+ )
+ server? (
+ X? (
+ x11-libs/libXcursor
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXrandr
+ x11-libs/libXtst
+ xinerama? ( x11-libs/libXinerama )
+ )
+ )
+ smartcard? ( sys-apps/pcsc-lite )
+ systemd? ( sys-apps/systemd:0= )
+ client? (
+ wayland? (
+ dev-libs/wayland
+ x11-libs/libxkbcommon
+ )
+ )
+ X? (
+ x11-libs/libX11
+ x11-libs/libxkbfile
+ )
+"
+DEPEND="${COMMON_DEPEND}
+ valgrind? ( dev-debug/valgrind )
+"
+RDEPEND="${COMMON_DEPEND}
+ !net-misc/freerdp:0
+ client? ( !net-misc/freerdp:2[client] )
+ server? ( !net-misc/freerdp:2[server] )
+ smartcard? ( app-crypt/p11-kit )
+"
+
+option() {
+ usex "$1" ON OFF
+}
+
+option_client() {
+ if use client; then
+ option "$1"
+ else
+ echo OFF
+ fi
+}
+
+src_configure() {
+ # bug #881695
+ filter-lto
+
+ local mycmakeargs=(
+ -Wno-dev
+
+ # https://bugs.gentoo.org/927037
+ -DCMAKE_INTERPROCEDURAL_OPTIMIZATION=OFF
+
+ -DBUILD_TESTING=$(option test)
+ -DCHANNEL_URBDRC=$(option usb)
+ -DWITH_AAD=$(option aad)
+ -DWITH_ALSA=$(option alsa)
+ -DWITH_CCACHE=OFF
+ -DWITH_CLIENT=$(option client)
+ -DWITH_CLIENT_SDL=$(option sdl)
+ -DWITH_SAMPLE=OFF
+ -DWITH_CUPS=$(option cups)
+ -DWITH_DEBUG_ALL=$(option debug)
+ -DWITH_MANPAGES=ON
+ -DWITH_FFMPEG=$(option ffmpeg)
+ -DWITH_FREERDP_DEPRECATED_COMMANDLINE=ON
+ -DWITH_SWSCALE=$(option ffmpeg)
+ -DWITH_CAIRO=$(option !ffmpeg)
+ -DWITH_DSP_FFMPEG=$(option ffmpeg)
+ -DWITH_FUSE=$(option fuse)
+ -DWITH_GSTREAMER_1_0=$(option gstreamer)
+ -DWITH_JPEG=$(option jpeg)
+ -DWITH_KRB5=$(option kerberos)
+ -DWITH_NEON=$(option cpu_flags_arm_neon)
+ -DWITH_OPENH264=$(option openh264)
+ -DWITH_OSS=OFF
+ -DWITH_PCSC=$(option smartcard)
+ -DWITH_PKCS11=$(option smartcard)
+ -DWITH_PULSE=$(option pulseaudio)
+ -DWITH_SERVER=$(option server)
+ -DWITH_LIBSYSTEMD=$(option systemd)
+ -DWITH_UNICODE_BUILTIN=$(option !icu)
+ -DWITH_VALGRIND_MEMCHECK=$(option valgrind)
+ -DWITH_X11=$(option X)
+ -DWITH_XINERAMA=$(option xinerama)
+ -DWITH_XV=$(option xv)
+ -DWITH_WAYLAND=$(option_client wayland)
+ -DWITH_WEBVIEW=OFF
+ -DWITH_WINPR_TOOLS=$(option server)
+ )
+ cmake_src_configure
+}
+
+src_test() {
+ local myctestargs=( -E TestBacktrace )
+ has network-sandbox ${FEATURES} && myctestargs+=( -E TestConnect )
+ cmake_src_test
+}
+
+src_install() {
+ cmake_src_install
+ mv "${ED}"/usr/share/man/man7/wlog{,3}.7 || die
+}