summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <mmk@levelnine.at>2023-10-28 14:22:19 +0200
committerConrad Kostecki <conikost@gentoo.org>2024-01-07 01:19:34 +0100
commit0e30c4b4b41b351362633e56c440f9328db006b7 (patch)
tree538ed25a8a93f56ef8a89ca4b024bd2be5bfc40b /net-misc/jwhois/jwhois-4.0-r2.ebuild
parentsys-apps/input-utils: EAPI8 bump (diff)
downloadgentoo-0e30c4b4b41b351362633e56c440f9328db006b7.tar.gz
gentoo-0e30c4b4b41b351362633e56c440f9328db006b7.tar.bz2
gentoo-0e30c4b4b41b351362633e56c440f9328db006b7.zip
net-misc/jwhois: EAPI8, fix #446472
Signed-off-by: Michael Mair-Keimberger <mmk@levelnine.at> Closes: https://bugs.gentoo.org/446472 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'net-misc/jwhois/jwhois-4.0-r2.ebuild')
-rw-r--r--net-misc/jwhois/jwhois-4.0-r2.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/net-misc/jwhois/jwhois-4.0-r2.ebuild b/net-misc/jwhois/jwhois-4.0-r2.ebuild
new file mode 100644
index 000000000000..3b4a4a95dcbe
--- /dev/null
+++ b/net-misc/jwhois/jwhois-4.0-r2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools toolchain-funcs
+
+DESCRIPTION="Advanced Internet Whois client capable of recursive queries"
+HOMEPAGE="https://github.com/jonasob/jwhois/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="idn nls"
+
+RDEPEND="idn? ( net-dns/libidn )"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ # bug 208875
+ "${FILESDIR}"/${P}-connect-logic.patch
+ "${FILESDIR}"/${P}-avoid-implicit-declarations.patch
+ "${FILESDIR}"/${P}-add-timeout_init-prototype.patch
+)
+
+src_configure() {
+ econf \
+ --localstatedir="${EPREFIX}"/var/cache \
+ --without-cache \
+ $(use_enable nls) \
+ $(use_with idn libidn)
+ eautoreconf
+}
+
+src_compile(){
+ emake AR="$(tc-getAR)"
+}