summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2022-12-09 23:23:55 +0000
committerJames Le Cuirot <chewi@gentoo.org>2022-12-09 23:23:55 +0000
commit11cd25124f9cbaa14f59254ddb846e4969f2c271 (patch)
tree68eb9d319a26c8593836932e303ad0f7699cdb22 /net-misc/netevent/netevent-2.2.1.ebuild
parentx11-drivers/nvidia-drivers: add 525.60.13 (diff)
downloadgentoo-11cd25124f9cbaa14f59254ddb846e4969f2c271.tar.gz
gentoo-11cd25124f9cbaa14f59254ddb846e4969f2c271.tar.bz2
gentoo-11cd25124f9cbaa14f59254ddb846e4969f2c271.zip
net-misc/netevent: Version bump to 2.2.1
Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'net-misc/netevent/netevent-2.2.1.ebuild')
-rw-r--r--net-misc/netevent/netevent-2.2.1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/net-misc/netevent/netevent-2.2.1.ebuild b/net-misc/netevent/netevent-2.2.1.ebuild
new file mode 100644
index 000000000000..af01c9e1c64e
--- /dev/null
+++ b/net-misc/netevent/netevent-2.2.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Tool to share Linux event devices with other machines"
+HOMEPAGE="https://github.com/Blub/netevent"
+SRC_URI="https://github.com/Blub/netevent/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm"
+IUSE="doc"
+
+BDEPEND="
+ doc? ( dev-python/docutils )
+"
+
+src_configure() {
+ tc-export CXX
+
+ # Not Autoconf.
+ RST2MAN=rst2man.py \
+ ./configure \
+ --prefix="${EPREFIX}"/usr \
+ $(use_enable doc) \
+ || die
+}
+
+src_compile() {
+ emake CPPFLAGS="-Wall -Wno-unknown-pragmas"
+}