summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-misc/streamtuner/streamtuner-0.99.99-r5.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-misc/streamtuner/streamtuner-0.99.99-r5.ebuild')
-rw-r--r--net-misc/streamtuner/streamtuner-0.99.99-r5.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/net-misc/streamtuner/streamtuner-0.99.99-r5.ebuild b/net-misc/streamtuner/streamtuner-0.99.99-r5.ebuild
new file mode 100644
index 000000000000..3ea7e4a828a9
--- /dev/null
+++ b/net-misc/streamtuner/streamtuner-0.99.99-r5.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+GCONF_DEBUG=no
+inherit eutils gnome2
+
+DESCRIPTION="Stream directory browser for browsing internet radio streams"
+HOMEPAGE="http://www.nongnu.org/streamtuner"
+SRC_URI="http://savannah.nongnu.org/download/${PN}/${P}.tar.gz
+ http://savannah.nongnu.org/download/${PN}/${P}-pygtk-2.6.diff"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ~ppc ~sparc x86"
+IUSE="python +shout +xiph"
+
+RDEPEND="
+ >=x11-libs/gtk+-2.4:2
+ net-misc/curl
+ app-text/scrollkeeper
+ xiph? ( dev-libs/libxml2:2 )
+ >=media-libs/taglib-1.2
+ python? ( dev-python/pygtk:2 )
+ x11-misc/xdg-utils
+"
+DEPEND="${RDEPEND}
+ dev-util/gtk-doc-am
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gentoo.patch \
+ "${FILESDIR}"/${P}-shoutcast.patch \
+ "${FILESDIR}"/${P}-shoutcast-2.patch \
+ "${FILESDIR}"/${P}-audacious.patch \
+ "${DISTDIR}"/${P}-pygtk-2.6.diff \
+ "${FILESDIR}"/${P}-stack_increase.patch
+
+ # Fix .desktop file
+ sed -i \
+ -e 's/streamtuner.png/streamtuner/' \
+ -e 's/Categories=Application;/Categories=/' \
+ data/streamtuner.desktop.in || die
+
+ gnome2_src_prepare
+}
+
+src_configure() {
+ # live365 causes parse errors at connect time
+ # The right value for compile-warning for this is 'yes' (#481124)
+ gnome2_src_configure \
+ --enable-compile-warnings=yes \
+ --disable-live365 \
+ $(use_enable python) \
+ $(use_enable shout shoutcast) \
+ $(use_enable xiph)
+}