summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2020-04-20 12:05:18 +0200
committerLars Wendler <polynomial-c@gentoo.org>2020-04-20 12:19:38 +0200
commitd13e8c2a91c13a6e1c95cf727e78fef2aa2bb2ec (patch)
treea3ab1a8732c6055e3becd6df6093dabec2560e0e /net-misc/whois/whois-9999.ebuild
parentdev-python/packaging: s390 stable wrt bug #716404 (diff)
downloadgentoo-d13e8c2a91c13a6e1c95cf727e78fef2aa2bb2ec.tar.gz
gentoo-d13e8c2a91c13a6e1c95cf727e78fef2aa2bb2ec.tar.bz2
gentoo-d13e8c2a91c13a6e1c95cf727e78fef2aa2bb2ec.zip
net-misc/whois: Revbump to fix automagic dep on sys-libs/libxcrypt
Thanks-to: Eugene Shalygin <eugene.shalygin@gmail.com> Closes: https://bugs.gentoo.org/718104 Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'net-misc/whois/whois-9999.ebuild')
-rw-r--r--net-misc/whois/whois-9999.ebuild11
1 files changed, 8 insertions, 3 deletions
diff --git a/net-misc/whois/whois-9999.ebuild b/net-misc/whois/whois-9999.ebuild
index 84b8abe1134b..8aecce2f7642 100644
--- a/net-misc/whois/whois-9999.ebuild
+++ b/net-misc/whois/whois-9999.ebuild
@@ -18,12 +18,15 @@ else
fi
LICENSE="GPL-2"
SLOT="0"
-IUSE="iconv idn nls"
+IUSE="iconv idn nls xcrypt"
RESTRICT="test" #59327
-RDEPEND="iconv? ( virtual/libiconv )
+RDEPEND="
+ iconv? ( virtual/libiconv )
idn? ( net-dns/libidn2:= )
- nls? ( virtual/libintl )"
+ nls? ( virtual/libintl )
+ xcrypt? ( >=sys-libs/libxcrypt-4.1 )
+"
DEPEND="${RDEPEND}"
BDEPEND="
app-arch/xz-utils
@@ -34,6 +37,7 @@ BDEPEND="
PATCHES=(
"${FILESDIR}"/${PN}-4.7.2-config-file.patch
"${FILESDIR}"/${PN}-5.3.0-libidn_automagic.patch
+ "${FILESDIR}"/${PN}-5.5.6-libxcrypt_automagic.patch
)
src_prepare() {
@@ -55,6 +59,7 @@ src_compile() {
unset HAVE_ICONV HAVE_LIBIDN
use iconv && export HAVE_ICONV=1
use idn && export HAVE_LIBIDN=1
+ use xcrypt && export HAVE_XCRYPT=1
tc-export CC
emake CFLAGS="${CFLAGS} ${CPPFLAGS}"
}