summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-misc/youtube-viewer/youtube-viewer-9999.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-misc/youtube-viewer/youtube-viewer-9999.ebuild')
-rw-r--r--net-misc/youtube-viewer/youtube-viewer-9999.ebuild74
1 files changed, 74 insertions, 0 deletions
diff --git a/net-misc/youtube-viewer/youtube-viewer-9999.ebuild b/net-misc/youtube-viewer/youtube-viewer-9999.ebuild
new file mode 100644
index 000000000000..d95aa2258bce
--- /dev/null
+++ b/net-misc/youtube-viewer/youtube-viewer-9999.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit perl-module git-2
+
+DESCRIPTION="A command line utility for viewing youtube-videos in Mplayer"
+HOMEPAGE="http://trizen.googlecode.com"
+SRC_URI=""
+EGIT_REPO_URI="git://github.com/trizen/${PN}.git"
+
+LICENSE="|| ( Artistic GPL-1+ )"
+SLOT="0"
+KEYWORDS=""
+IUSE="gtk"
+
+RDEPEND="
+ >=dev-lang/perl-5.16.0
+ dev-perl/Data-Dump
+ dev-perl/libwww-perl
+ || ( media-video/mplayer[X,network]
+ media-video/mplayer2[X,network]
+ media-video/mpv[X] )
+ virtual/perl-File-Spec
+ virtual/perl-Getopt-Long
+ virtual/perl-Term-ANSIColor
+ virtual/perl-Text-ParseWords
+ virtual/perl-Text-Tabs+Wrap
+ gtk? (
+ dev-perl/File-ShareDir
+ >=dev-perl/gtk2-perl-1.244.0
+ virtual/freedesktop-icon-theme
+ x11-libs/gdk-pixbuf:2[X,jpeg]
+ )"
+DEPEND="dev-perl/Module-Build"
+
+EGIT_SOURCEDIR="${WORKDIR}"
+S=${WORKDIR}/WWW-YoutubeViewer
+
+SRC_TEST="do"
+
+# build system installs files on "perl Build.PL" too
+# do all the work in src_install
+src_configure() { :; }
+src_compile() { :; }
+
+src_install() {
+ local myconf
+ if use gtk ; then
+ myconf="--gtk-youtube-viewer"
+ fi
+ perl-module_src_configure
+ perl-module_src_install
+}
+
+pkg_postinst() {
+ einfo
+ elog "optional dependencies:"
+ elog " dev-perl/LWP-Protocol-https or dev-perl/libwww-perl[ssl]"
+ elog " and virtual/perl-MIME-Base64"
+ elog " (for HTTPS protocol and login support)"
+ elog " dev-perl/Term-ReadLine-Gnu (for a better STDIN support)"
+ elog " dev-perl/Text-CharWidth (print the results in a fixed-width"
+ elog " format (--fixed-width, -W))"
+ elog " dev-perl/XML-Fast (faster XML to HASH conversion)"
+ elog " net-misc/gcap (for retrieving Youtube closed captions)"
+ elog " virtual/perl-File-Temp (for posting comments)"
+ elog " virtual/perl-Scalar-List-Utils (to shuffle the playlists"
+ elog " (--shuffle, -s))"
+ elog " virtual/perl-threads (threads support)"
+ einfo
+}