summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-06-11 06:38:33 +0000
committerSam James <sam@gentoo.org>2021-06-11 06:38:33 +0000
commit540ea2504d870d6ff28f61b3b399d178c7ae4df8 (patch)
tree89ef5dde9f213c49b2dd8131ba15fa9ca7551e19 /net-misc
parentapp-misc/detox: drop 1.2.0-r3 (diff)
downloadgentoo-540ea2504d870d6ff28f61b3b399d178c7ae4df8.tar.gz
gentoo-540ea2504d870d6ff28f61b3b399d178c7ae4df8.tar.bz2
gentoo-540ea2504d870d6ff28f61b3b399d178c7ae4df8.zip
net-misc/ntpsec: add additional pread64 syscall patch
Closes: https://bugs.gentoo.org/786228 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/ntpsec/files/ntpsec-1.2.0-seccomp.patch11
-rw-r--r--net-misc/ntpsec/ntpsec-1.2.0-r3.ebuild (renamed from net-misc/ntpsec/ntpsec-1.2.0-r2.ebuild)1
2 files changed, 12 insertions, 0 deletions
diff --git a/net-misc/ntpsec/files/ntpsec-1.2.0-seccomp.patch b/net-misc/ntpsec/files/ntpsec-1.2.0-seccomp.patch
index e4dc47f19cc6..65c13189e9da 100644
--- a/net-misc/ntpsec/files/ntpsec-1.2.0-seccomp.patch
+++ b/net-misc/ntpsec/files/ntpsec-1.2.0-seccomp.patch
@@ -1,4 +1,5 @@
https://bugs.gentoo.org/705128
+https://bugs.gentoo.org/786228
--- a/ntpd/ntp_sandbox.c
+++ b/ntpd/ntp_sandbox.c
@@ -463,6 +463,15 @@ int scmp_sc[] = {
@@ -17,3 +18,13 @@ https://bugs.gentoo.org/705128
};
{
for (unsigned int i = 0; i < COUNTOF(scmp_sc); i++) {
+--- a/ntpd/ntp_sandbox.c
++++ b/ntpd/ntp_sandbox.c
+@@ -355,6 +355,7 @@ int scmp_sc[] = {
+ SCMP_SYS(openat), /* SUSE */
+ #endif
+ SCMP_SYS(poll),
++ SCMP_SYS(pread64),
+ SCMP_SYS(pselect6),
+ SCMP_SYS(read),
+ SCMP_SYS(recvfrom), /* Comment this out for testing.
diff --git a/net-misc/ntpsec/ntpsec-1.2.0-r2.ebuild b/net-misc/ntpsec/ntpsec-1.2.0-r3.ebuild
index 4a5784ca79ed..9d2d01df34ea 100644
--- a/net-misc/ntpsec/ntpsec-1.2.0-r2.ebuild
+++ b/net-misc/ntpsec/ntpsec-1.2.0-r3.ebuild
@@ -68,6 +68,7 @@ WAF_BINARY="${S}/waf"
src_prepare() {
default
+
# Remove autostripping of binaries
sed -i -e '/Strip binaries/d' wscript || die
if ! use libbsd ; then