summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2017-08-30 12:54:43 +0200
committerBernard Cafarelli <voyageur@gentoo.org>2017-08-30 12:56:01 +0200
commit7f3e561cd3d3fa91c81244f42769a0bcf40115ca (patch)
tree066f56a25ac99ddb02e7ed957b28a5b14b5c51e5 /net-misc
parentsys-kernel/vanilla-sources: Linux version bumps 4.4.85, 4.9.46 and 4.12.10 (diff)
downloadgentoo-7f3e561cd3d3fa91c81244f42769a0bcf40115ca.tar.gz
gentoo-7f3e561cd3d3fa91c81244f42769a0bcf40115ca.tar.bz2
gentoo-7f3e561cd3d3fa91c81244f42769a0bcf40115ca.zip
net-misc/plowshare: 2.1.7 bump
Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/plowshare/Manifest1
-rw-r--r--net-misc/plowshare/plowshare-2.1.7.ebuild67
2 files changed, 68 insertions, 0 deletions
diff --git a/net-misc/plowshare/Manifest b/net-misc/plowshare/Manifest
index 91d35994b08d..4f28b651200d 100644
--- a/net-misc/plowshare/Manifest
+++ b/net-misc/plowshare/Manifest
@@ -1,2 +1,3 @@
DIST plowshare-2.1.5.tar.gz 94268 SHA256 31a1d379b738b007ff000107b03562bf73ed5f05d7fa1ebef50082f0799a59ce SHA512 1724580dd9fa818821e9686b758f904aad408c409e23e68444dbf6fc80cae81b03159fcfc816e7273777b02b1dbcc3ab93e13cc2b05f20145850a1c931da4342 WHIRLPOOL 853255b2a3abbe40349112e322e4e1bd9ca9261fe714e2d7f3802398b318a96e346238bc888eefeb78edd5050b19850b82c72050da59772ca1db0af41c14d3cb
DIST plowshare-2.1.6.tar.gz 95946 SHA256 2823f4bc82ad9b30c0c122a312125cb923acc55ce448c56a503e03fe0a4d97c4 SHA512 bccc72f1add6389fd7fc41a27f9e169c622e3a4e7c9c1040c01a8a4569accc9b0b6910815a013d5e8aff7103ee26d943665ffeccc02db1879eca580b3892190d WHIRLPOOL 4d4204199b6dc505a2ce231c95c41f5da1e93806fc04f875844566b54da31c41baa0657f6e65fa416baf68aebbaec02a2ead0ed1baf1ac3aa314ccfb7e502226
+DIST plowshare-2.1.7.tar.gz 96282 SHA256 c17d0cc1b3323f72b2c1a5b183a9fcef04e8bfc53c9679a4e1523642310d22ad SHA512 7fe91d3756c55ffc1daf9275bfd2413f2644accd8fa69f2b1064696e1435f9b8be9515907c8249ffde85436dc6966f1d42bad94ccfbde93ae584dcc0d642c215 WHIRLPOOL eea0b0e1298a168677a5431ad84ddd87d45e9d771ddeac968f7a12cd1abd16af1c1b8492b5d92b3bd8558cf1223d5bd3701af14742eea4f0b114156a9a10964c
diff --git a/net-misc/plowshare/plowshare-2.1.7.ebuild b/net-misc/plowshare/plowshare-2.1.7.ebuild
new file mode 100644
index 000000000000..52227ef820ef
--- /dev/null
+++ b/net-misc/plowshare/plowshare-2.1.7.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit bash-completion-r1
+
+DESCRIPTION="Command-line downloader and uploader for file-sharing websites"
+HOMEPAGE="https://github.com/mcrapet/plowshare"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86"
+IUSE="bash-completion +javascript view-captcha"
+
+SRC_URI="https://github.com/mcrapet/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+RDEPEND="
+ >=app-shells/bash-4
+ || ( app-text/recode ( dev-lang/perl dev-perl/HTML-Parser ) )
+ dev-vcs/git
+ net-misc/curl
+ sys-apps/util-linux
+ virtual/imagemagick-tools[tiff]
+ javascript? ( || ( dev-lang/spidermonkey:0 dev-java/rhino ) )
+ view-captcha? ( || ( media-gfx/aview media-libs/libcaca ) )"
+DEPEND=""
+
+# NOTES:
+# javascript dep should be any javascript interpreter using /usr/bin/js
+
+src_prepare() {
+ # Fix doc install path
+ sed -i -e "/^DOCDIR/s|plowshare|${PF}|" Makefile || die "sed failed"
+
+ if ! use bash-completion
+ then
+ sed -i -e \ "/^install:/s/install_bash_completion//" \
+ Makefile || die "sed failed"
+ fi
+
+ default
+}
+
+src_compile() {
+ # There is a Makefile but it's not compiling anything, let's not try.
+ :
+}
+
+src_test() {
+ # Disable tests because all of them need a working Internet connection.
+ :
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="/usr" \
+ PLOWSHARE_FORCE_VERSION="${PV}" install
+}
+
+pkg_postinst() {
+ elog "plowshare is not delivered with modules by default anymore"
+ elog "Per-user modules can be installed/updated with the plowmod command"
+ if ! use javascript; then
+ ewarn "Without javascript you will not be able to use modules"
+ ewarn "requering a Javascript shell (/usr/bin/js)"
+ fi
+}