summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2024-05-27 21:57:47 -0400
committerIonen Wolkens <ionen@gentoo.org>2024-05-27 22:11:29 -0400
commit8b41d73c1788fe85aaaaf95472f7d2a4eff634ca (patch)
tree6113987bad4921a67a1a6c370e3f2c155cb993eb /net-misc
parentgui-libs/wlroots: add slot for live package (diff)
downloadgentoo-8b41d73c1788fe85aaaaf95472f7d2a4eff634ca.tar.gz
gentoo-8b41d73c1788fe85aaaaf95472f7d2a4eff634ca.tar.bz2
gentoo-8b41d73c1788fe85aaaaf95472f7d2a4eff634ca.zip
net-misc/yt-dlp: add 2024.05.27
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/yt-dlp/Manifest1
-rw-r--r--net-misc/yt-dlp/yt-dlp-2024.05.27.ebuild77
2 files changed, 78 insertions, 0 deletions
diff --git a/net-misc/yt-dlp/Manifest b/net-misc/yt-dlp/Manifest
index 097697f752fb..99b82cb37b28 100644
--- a/net-misc/yt-dlp/Manifest
+++ b/net-misc/yt-dlp/Manifest
@@ -1,2 +1,3 @@
DIST yt-dlp-2024.04.09.tar.gz 5589808 BLAKE2B ada1c3be28c4615a96b4fef9d39144b49548e97be6fab003596f11db905efa2607ea3d62ba529aee8391320bf4e3cd3c9367a5eab0439822fd98407fde2807fb SHA512 5eada1c6a3d656c4f70552824a59ed677ecc102e1a2c3475a12fccff78ea267d7391e778060d708bf0aca1bdf92f4bf413785e0cd65b43259535577e92755556
DIST yt-dlp-2024.05.26.tar.gz 5638226 BLAKE2B 277353a6751b9f20ef4ad9dfc8aa318be665e5620d365d0a6e54b01455471bdc7a7e169c00df22061660c9ea427702343ae77757575694e7cecac2a4e043219e SHA512 7cf17e566ccbdaa9a0e6303de2fe2cf91a1829321b0a323e638d27a9fc143949bc5b3b82a8764c9fa673a864b76930b53da7c9de2ecc0bfc07d6bade4238161f
+DIST yt-dlp-2024.05.27.tar.gz 5638920 BLAKE2B 467c6fb9e4c53e97d72338293e46983e471ca69e4fae97d23423d0aa003c98e91676f6c5e1af53d92b6c8f534cacc3d1d897161b043e52614324a0eb21b0e96b SHA512 ca2ddd04abb9ca3861584f6cbf827e21cbf9771394f059f2d8a0fc8874036dc9ae2bd0ad8a7bb350d1a042c1988aaeb3fef476f76ecc61710351c6a428aa95bc
diff --git a/net-misc/yt-dlp/yt-dlp-2024.05.27.ebuild b/net-misc/yt-dlp/yt-dlp-2024.05.27.ebuild
new file mode 100644
index 000000000000..4ab548574b58
--- /dev/null
+++ b/net-misc/yt-dlp/yt-dlp-2024.05.27.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..13} )
+inherit bash-completion-r1 distutils-r1 optfeature wrapper
+
+DESCRIPTION="youtube-dl fork with additional features and fixes"
+HOMEPAGE="https://github.com/yt-dlp/yt-dlp/"
+SRC_URI="
+ https://github.com/yt-dlp/yt-dlp/releases/download/${PV}/${PN}.tar.gz
+ -> ${P}.tar.gz
+"
+S="${WORKDIR}/${PN}"
+
+LICENSE="Unlicense"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~x86 ~arm64-macos ~x64-macos"
+
+RDEPEND="
+ dev-python/pycryptodome[${PYTHON_USEDEP}]
+ !net-misc/youtube-dl[-yt-dlp(-)]
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ distutils-r1_src_prepare
+
+ # adjust pycryptodome and drop optional dependencies (bug #828466)
+ sed -Ei pyproject.toml \
+ -e 's/("pycryptodome)x/\1/' \
+ -e '/"(brotli.*|certifi|mutagen|requests|urllib3|websockets)/d' || die
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # fails with FEATURES=network-sandbox
+ test/test_networking.py::TestHTTPRequestHandler::test_connect_timeout
+ # fails with FEATURES=distcc, bug #915614
+ test/test_networking.py::TestYoutubeDLNetworking::test_proxy\[None-expected2\]
+ )
+
+ epytest -m 'not download'
+}
+
+python_install_all() {
+ dodoc README.md Changelog.md supportedsites.md
+ doman yt-dlp.1
+
+ dobashcomp completions/bash/yt-dlp
+
+ insinto /usr/share/fish/vendor_completions.d
+ doins completions/fish/yt-dlp.fish
+
+ insinto /usr/share/zsh/site-functions
+ doins completions/zsh/_yt-dlp
+
+ rm -r "${ED}"/usr/share/doc/yt_dlp || die
+
+ make_wrapper youtube-dl "yt-dlp --compat-options youtube-dl"
+}
+
+pkg_postinst() {
+ optfeature "various features (merging tracks, streamed content)" media-video/ffmpeg
+ has_version media-video/atomicparsley || # allow fallback but don't advertise
+ optfeature "embedding metadata thumbnails in MP4/M4A files" media-libs/mutagen
+ optfeature "decrypting cookies from Chromium-based browsers" dev-python/secretstorage
+
+ if [[ ! ${REPLACING_VERSIONS} ]]; then
+ elog 'A wrapper using "yt-dlp --compat-options youtube-dl" was installed'
+ elog 'as "youtube-dl". This is strictly for compatibility and it is'
+ elog 'recommended to use "yt-dlp" directly, it may be removed in the future.'
+ fi
+}