summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Kohler <bkohler@gentoo.org>2024-10-16 07:18:51 -0500
committerBen Kohler <bkohler@gentoo.org>2024-10-16 07:20:06 -0500
commitf4cc40a1a73018457b642e43cecc19d180085c5d (patch)
tree5eaec717663ade1b34fc10113de595939db406fb /net-misc
parentnet-libs/libssh2: Bump to 1.11.1 (diff)
downloadgentoo-f4cc40a1a73018457b642e43cecc19d180085c5d.tar.gz
gentoo-f4cc40a1a73018457b642e43cecc19d180085c5d.tar.bz2
gentoo-f4cc40a1a73018457b642e43cecc19d180085c5d.zip
net-misc/dropbox: restore 205.4.5765
This is the last x86 version, we should probably look to remove it soon, but we will need to unkeyword some rdeps. Signed-off-by: Ben Kohler <bkohler@gentoo.org>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/dropbox/Manifest2
-rw-r--r--net-misc/dropbox/dropbox-205.4.5765.ebuild110
2 files changed, 112 insertions, 0 deletions
diff --git a/net-misc/dropbox/Manifest b/net-misc/dropbox/Manifest
index 7b158a7dd1f8..208925269d01 100644
--- a/net-misc/dropbox/Manifest
+++ b/net-misc/dropbox/Manifest
@@ -1,2 +1,4 @@
DIST dropbox-icon.svg 574 BLAKE2B a73a0906b5b03dc3214010736164fcdbceb6d91463ed95133b5117277cd635c8a77ec3e7ca8338538e5a6a2c4a23f3ef0186184bc1dc770b3c7f3a219f00faa6 SHA512 cd7ad8fea652f0713a00e7fbd88d6c22949dde216040f2ba7c903db70cb6c5c9ec85202831c0863c3bb2cf339b4ea0c6731d7b2d56750b63a4f36160815e4346
+DIST dropbox-lnx.x86-205.4.5765.tar.gz 114089572 BLAKE2B 503650c9fe49c1142872b829892c3759924af57c0327d49b3891f78cbad9b8aa4964861b719023ce5dc837fac98937559635a3e9c16da5b352b104c3cba792c3 SHA512 35715777719c10f38b54e92e24af5d6af85e4caedb7b45bef0693f93d7b0faa0da81b772f821ff4c4a60065e68ac98769cdf0655cce557550d1040f1c765598e
+DIST dropbox-lnx.x86_64-205.4.5765.tar.gz 116601880 BLAKE2B 40fbef3634736e4350d7b5e3bcf70d9daf1524d06b7707a7abeeff53020e2e51e3816a42903fc172ea9b8c721b769450d56cdb3f2fd562e114ce377b8cca4465 SHA512 9b9246ad573f0b04a9a403e6c71e2924da453f448a69bf8e24b1d662a80461b19a8fb75d29411006cf6b38b2227f4e5e94c57f481612d89621fc2ce985d8d450
DIST dropbox-lnx.x86_64-209.4.3661.tar.gz 117384855 BLAKE2B 509c1e3b8eab3e44b6b713988b7bebc83f9ee62c94100fceb163496d5b419c4caaf933f9646e21ad996a303140639b7de44b2a52fac942adc23a1973a86149ab SHA512 769c3063f87732ecc82e44e1de7ffa581d313fbdecf2230304730ab58da0e4a0bf284e3188897d066c961a5e25316c481b47d46e6dc015a5b974ade7074a4b54
diff --git a/net-misc/dropbox/dropbox-205.4.5765.ebuild b/net-misc/dropbox/dropbox-205.4.5765.ebuild
new file mode 100644
index 000000000000..fe0165167a45
--- /dev/null
+++ b/net-misc/dropbox/dropbox-205.4.5765.ebuild
@@ -0,0 +1,110 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop pax-utils systemd xdg
+
+DESCRIPTION="Dropbox daemon (pretends to be GUI-less)"
+HOMEPAGE="https://www.dropbox.com/"
+SRC_URI="
+ amd64? ( https://clientupdates.dropboxstatic.com/dbx-releng/client/dropbox-lnx.x86_64-${PV}.tar.gz )
+ x86? ( https://clientupdates.dropboxstatic.com/dbx-releng/client/dropbox-lnx.x86-${PV}.tar.gz )
+ https://uxwing.com/wp-content/themes/uxwing/download/brands-and-social-media/dropbox-icon.svg
+"
+
+LICENSE="BSD-2 CC-BY-ND-3.0 FTL MIT LGPL-2 openssl dropbox"
+SLOT="0"
+KEYWORDS="-* amd64 x86"
+IUSE="selinux X"
+
+RESTRICT="mirror strip"
+
+QA_PREBUILT="opt/.*"
+QA_EXECSTACK="opt/dropbox/dropbox"
+
+BDEPEND="dev-util/patchelf"
+
+# Be sure to have GLIBCXX_3.4.9, #393125
+RDEPEND="
+ X? (
+ x11-themes/hicolor-icon-theme
+ )
+ selinux? ( sec-policy/selinux-dropbox )
+ app-arch/bzip2
+ dev-libs/glib:2
+ dev-libs/libffi-compat:6
+ media-libs/fontconfig
+ media-libs/freetype
+ net-misc/wget
+ sys-libs/zlib
+ sys-libs/ncurses-compat:5
+ virtual/opengl
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXrender
+ x11-libs/libxcb
+"
+
+src_unpack() {
+ unpack ${A}
+ mkdir -p "${S}" || die
+ mv "${WORKDIR}"/.dropbox-dist/* "${S}" || die
+ mv "${S}"/dropbox-lnx.*-${PV}/* "${S}" || die
+ rmdir "${S}"/dropbox-lnx.*-${PV}/ || die
+ rmdir .dropbox-dist || die
+}
+
+src_prepare() {
+ default
+ # we supply all of these in RDEPEND
+ rm -vf libGL.so.1 libX11* libffi.so.6 || die
+ # some of these do not appear to be used
+ rm -vf libQt5{OpenGL,PrintSupport,Qml,Quick,Sql,WebKit,WebKitWidgets}.so.5 \
+ PyQt5.QtPrintSupport.* PyQt5.QtQml.* PyQt5.QtQuick.* \
+ wmctrl libdrm.so.2 libpopt.so.0 || die
+ if use X ; then
+ mv images/hicolor/16x16/status "${T}" || die
+ else
+ rm -vrf images || die
+ fi
+ patchelf --set-rpath '$ORIGIN' \
+ apex._apex.*.so \
+ nucleus_python.*.so \
+ tprt.*.so \
+ || die
+ pax-mark cm dropbox
+ mv README ACKNOWLEDGEMENTS "${T}" || die
+}
+
+src_install() {
+ local targetdir="/opt/dropbox"
+
+ insinto "${targetdir}"
+ doins -r *
+ fperms a+x "${targetdir}"/{dropbox,dropboxd}
+ dosym "${targetdir}/dropboxd" "/opt/bin/dropbox"
+
+ if use X; then
+ doicon -s 16 -c status "${T}"/status
+ newicon -s scalable "${DISTDIR}/dropbox-icon.svg" dropbox.svg
+ fi
+
+ make_desktop_entry "${PN}" "Dropbox" "dropbox"
+
+ newinitd "${FILESDIR}"/dropbox.initd dropbox
+ newconfd "${FILESDIR}"/dropbox.conf dropbox
+ systemd_newunit "${FILESDIR}"/dropbox_at.service-r2 "dropbox@.service"
+
+ dodoc "${T}"/{README,ACKNOWLEDGEMENTS}
+}
+
+pkg_postinst() {
+ einfo "Warning: while running, dropbox may attempt to autoupdate itself in"
+ einfo " your user's home directory. To prevent this, run the following as"
+ einfo " each user who will run dropbox:"
+ einfo ""
+ einfo "install -dm0 ~/.dropbox-dist"
+}