summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrahmajit Das <brahmajit.xyz@gmail.com>2023-09-30 17:31:21 +0000
committerSam James <sam@gentoo.org>2023-10-01 08:45:18 +0100
commit00a1ff40983440d2d0f7ea744b64a98e2e500d38 (patch)
treea2cafaa5246b5134a3bb80f82451a5b0b0b3b5c8 /net-nds
parentnet-im/element-desktop-bin: add 1.11.45 (diff)
downloadgentoo-00a1ff40983440d2d0f7ea744b64a98e2e500d38.tar.gz
gentoo-00a1ff40983440d2d0f7ea744b64a98e2e500d38.tar.bz2
gentoo-00a1ff40983440d2d0f7ea744b64a98e2e500d38.zip
net-nds/ldapvi: Fix call to undeclared function on_exit
Closes: https://bugs.gentoo.org/898066 Signed-off-by: Brahmajit Das <brahmajit.xyz@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/31513 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-nds')
-rw-r--r--net-nds/ldapvi/files/ldapvi-1.7-fix-missing-on_exit-musl.patch61
-rw-r--r--net-nds/ldapvi/ldapvi-1.7_p20101214-r6.ebuild62
2 files changed, 123 insertions, 0 deletions
diff --git a/net-nds/ldapvi/files/ldapvi-1.7-fix-missing-on_exit-musl.patch b/net-nds/ldapvi/files/ldapvi-1.7-fix-missing-on_exit-musl.patch
new file mode 100644
index 000000000000..b883e412d327
--- /dev/null
+++ b/net-nds/ldapvi/files/ldapvi-1.7-fix-missing-on_exit-musl.patch
@@ -0,0 +1,61 @@
+Use internal on_exit function as on_exit is not available on musl libc Bug: https://bugs.gentoo.org/898066
+--- a/common.h
++++ b/common.h
+@@ -372,3 +372,7 @@ void sasl_defaults_free(tsasl_defaults *sd);
+ int ldapvi_sasl_interact(LDAP *ld, unsigned flags, void *defaults, void *p);
+
+ void fdcp(int fdsrc, int fddst);
++
++#ifndef HAVE_ON_EXIT
++int on_exit(void (*function)(int, void *), void *arg);
++#endif
+--- a/ldapvi.c
++++ b/ldapvi.c
+@@ -17,6 +17,7 @@
+ * along with this program; if not, write to the Free Software
+ * Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
+ */
++#include <stdio.h>
+ #include <curses.h>
+ #include <signal.h>
+ #include <term.h>
+--- a/misc.c
++++ b/misc.c
+@@ -15,6 +15,7 @@
+ * along with this program; if not, write to the Free Software
+ * Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
+ */
++#include <stdio.h>
+ #include <curses.h>
+ #include <term.h>
+ #include "common.h"
+--- a/parse.c
++++ b/parse.c
+@@ -18,6 +18,7 @@
+ #define _XOPEN_SOURCE
+ #include <unistd.h>
+ #include <crypt.h>
++#include <stdio.h>
+ #include "common.h"
+
+ #define fast_g_string_append_c(gstring, c) \
+--- a/parseldif.c
++++ b/parseldif.c
+@@ -17,6 +17,7 @@
+ */
+ #define _XOPEN_SOURCE
+ #include <unistd.h>
++#include <stdio.h>
+ #include "common.h"
+
+ #define fast_g_string_append_c(gstring, c) \
+--- a/port.c
++++ b/port.c
+@@ -31,6 +31,7 @@
+ #include <unistd.h>
+
+ #include "config.h"
++#include "common.h"
+
+ #if defined(HAVE_OPENSSL)
+ #include <openssl/sha.h>
diff --git a/net-nds/ldapvi/ldapvi-1.7_p20101214-r6.ebuild b/net-nds/ldapvi/ldapvi-1.7_p20101214-r6.ebuild
new file mode 100644
index 000000000000..13736b4b86ef
--- /dev/null
+++ b/net-nds/ldapvi/ldapvi-1.7_p20101214-r6.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Manage LDAP entries with a text editor"
+HOMEPAGE="http://www.lichteblau.com/ldapvi/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+S="${WORKDIR}"/${P}/${PN}
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~sparc ~x86"
+IUSE="gnutls sasl"
+
+RDEPEND="
+ dev-libs/popt
+ dev-libs/glib:2
+ sys-libs/readline:=
+ sys-libs/ncurses:=
+ virtual/libcrypt:=
+ gnutls? (
+ net-libs/gnutls:=
+ net-nds/openldap[gnutls]
+ )
+ !gnutls? (
+ dev-libs/openssl:=
+ net-nds/openldap[ssl]
+ )
+ sasl? ( dev-libs/cyrus-sasl:2[ssl] )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.7-fix-implicit-function-declarations.patch"
+ "${FILESDIR}/${PN}-1.7-fix-missing-on_exit-musl.patch"
+)
+
+src_prepare() {
+ default
+
+ # bug #459478
+ sed -i \
+ -e '/^AC_SEARCH_LIBS/s:curses ncurses:curses ncurses tinfo:' \
+ configure.in || die
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --with-libcrypto=$(usex gnutls gnutls openssl)
+}
+
+src_install() {
+ dobin ldapvi
+ doman ldapvi.1
+ dodoc NEWS manual/{bg.png,html.xsl,manual.{css,xml}}
+}