summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Ruppert <idl0r@gentoo.org>2016-03-16 21:04:32 +0100
committerChristian Ruppert <idl0r@gentoo.org>2016-03-16 21:04:32 +0100
commit0d3bd0973c2c1b84f46a1110c1ae1aee1aaedb9d (patch)
tree5bcda5bee0af99181308a7e46a35ce36bd615e1c /net-proxy
parentnet-proxy/haproxy: Remove old versions (diff)
downloadgentoo-0d3bd0973c2c1b84f46a1110c1ae1aee1aaedb9d.tar.gz
gentoo-0d3bd0973c2c1b84f46a1110c1ae1aee1aaedb9d.tar.bz2
gentoo-0d3bd0973c2c1b84f46a1110c1ae1aee1aaedb9d.zip
net-proxy/haproxy: Version bump to 1.5.16 and 1.6.3. Also fixes bug 576580
Package-Manager: portage-2.2.27
Diffstat (limited to 'net-proxy')
-rw-r--r--net-proxy/haproxy/Manifest2
-rw-r--r--net-proxy/haproxy/haproxy-1.5.16.ebuild135
-rw-r--r--net-proxy/haproxy/haproxy-1.6.3-r1.ebuild (renamed from net-proxy/haproxy/haproxy-1.6.3.ebuild)5
-rw-r--r--net-proxy/haproxy/haproxy-1.6.4.ebuild160
4 files changed, 299 insertions, 3 deletions
diff --git a/net-proxy/haproxy/Manifest b/net-proxy/haproxy/Manifest
index 48814e7b8867..5dabce249c5a 100644
--- a/net-proxy/haproxy/Manifest
+++ b/net-proxy/haproxy/Manifest
@@ -1,3 +1,5 @@
DIST haproxy-1.5.14.tar.gz 1345345 SHA256 9565dd38649064d0350a2883fa81ccfe92eb17dcda457ebdc01535e1ab0c8f99 SHA512 83d6101fd402f37845ab3febc914335e4c6d9bdebbb0ff81c8e048d5252ffa5a1b77c4250a434fed5dd541ef1f1f2c47d969b59f7a51d6ab9aea38a8646a9798 WHIRLPOOL 7d2c580589b9b31e1eba169e4bf930ac42d2564e21eb1c25adbdd39b701abd221fd671ebc227167ab956a48b2c30eeb740a6394355a8fa748c408ee42fdff6fc
DIST haproxy-1.5.15.tar.gz 1356790 SHA256 5af46e1438601d0919f5628081f660f9533087d88af3d9274f245395475663e1 SHA512 9c4f1b5ebd2401e5a13f5929b3d8fc7f93fde694971a8f0cead8ad3d166779b1dd0e3da9c872f4681d7fc55d87ff4cb4396024eea34e1482d400707d275d4715 WHIRLPOOL d37d4f9d8dccd24d2955eda9ff16a114d5d005f3589713c9607aec2f83dc24fc7f8f0c47b1067547e3fb84acaae6f68a7432c7fb3120ccb16c874bceb0e80792
+DIST haproxy-1.5.16.tar.gz 1359008 SHA256 3bc6bf5c84c488f97f9270c0d2a557adb2521ae03a9db488202ac3434a3433af SHA512 8f3f6e5ece8c9fe16e5b99477028287c2b504077284048051b27755167f1394134d49fc20de0656e41013c9d7e8c6425440c8c72d68fd45c718f64c9a3bec7ca WHIRLPOOL c722790ac8ef178fb99fa404804e0ed8b8cd09f0f8a479ebcbbc996a5f5ad0b43c95eadf9ce46c669e4d402e9396f6149dab7dcbe2cf197505d62a9a62989599
DIST haproxy-1.6.3.tar.gz 1555861 SHA256 fd06b45054cde2c69cb3322dfdd8a4bcfc46eb9d0c4b36d20d3ea19d84e338a7 SHA512 79ed526cd857dcd68d9b8289df4d4a2d87594e8d0d119f4d7c618597db7563a0cedc8417ddcfefb464a322d1fb50cb044656a2fbe78867f58052e0ddaa894bb9 WHIRLPOOL 37c6e1b0b063d8956d69039b55583320f4e191c1f9212b86ff1e8aef7b51f7e1228ad5923b86db893e25fb0ebb9d0570e88930cf45bc88a4a328e9576d982d30
+DIST haproxy-1.6.4.tar.gz 1559276 SHA256 e5fa3c604f1fe9ecb6974ccda6705c105ebee14b3a913069fb08f00e860cd230 SHA512 9f0fc316100e312a0c35c0706895b0e57634ad6ef353c33e958bbebce445855a057a0d7dabd67f3c15126843f40ab13d436ab9544b9793de4623b59d1bc91c52 WHIRLPOOL ddaf8b197013649d4011340ecdfc459abef98c0969b09bdc5ca6e0f41b7d10068da4c82f74b764e0107494ee1b6946a2d4acc31273c69e48c4a9103f5c7c6e0c
diff --git a/net-proxy/haproxy/haproxy-1.5.16.ebuild b/net-proxy/haproxy/haproxy-1.5.16.ebuild
new file mode 100644
index 000000000000..5225980feb81
--- /dev/null
+++ b/net-proxy/haproxy/haproxy-1.5.16.ebuild
@@ -0,0 +1,135 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit user versionator toolchain-funcs flag-o-matic systemd
+
+MY_P="${PN}-${PV/_beta/-dev}"
+
+DESCRIPTION="A TCP/HTTP reverse proxy for high availability environments"
+HOMEPAGE="http://haproxy.1wt.eu"
+SRC_URI="http://haproxy.1wt.eu/download/$(get_version_component_range 1-2)/src/${MY_P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86"
+IUSE="+crypt examples +pcre pcre-jit ssl tools vim-syntax +zlib"
+
+DEPEND="pcre? ( dev-libs/libpcre
+ pcre-jit? ( dev-libs/libpcre[jit] )
+ )
+ ssl? ( dev-libs/openssl:0[zlib?] )
+ zlib? ( sys-libs/zlib )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ enewgroup haproxy
+ enewuser haproxy -1 -1 -1 haproxy
+}
+
+src_prepare() {
+ sed -e 's:@SBINDIR@:'/usr/bin':' contrib/systemd/haproxy.service.in \
+ > contrib/systemd/haproxy.service || die
+
+ sed -ie 's:/usr/sbin/haproxy:/usr/bin/haproxy:' src/haproxy-systemd-wrapper.c || die
+}
+
+src_compile() {
+ local args="TARGET=linux2628 USE_GETADDRINFO=1"
+
+ if use pcre ; then
+ args="${args} USE_PCRE=1"
+ if use pcre-jit; then
+ args="${args} USE_PCRE_JIT=1"
+ else
+ args="${args} USE_PCRE_JIT="
+ fi
+ else
+ args="${args} USE_PCRE= USE_PCRE_JIT="
+ fi
+
+# if use kernel_linux; then
+# args="${args} USE_LINUX_SPLICE=1 USE_LINUX_TPROXY=1"
+# else
+# args="${args} USE_LINUX_SPLICE= USE_LINUX_TPROXY="
+# fi
+
+ if use crypt ; then
+ args="${args} USE_LIBCRYPT=1"
+ else
+ args="${args} USE_LIBCRYPT="
+ fi
+
+ if use ssl ; then
+ args="${args} USE_OPENSSL=1"
+ else
+ args="${args} USE_OPENSSL="
+ fi
+
+ if use zlib ; then
+ args="${args} USE_ZLIB=1"
+ else
+ args="${args} USE_ZLIB="
+ fi
+
+ # For now, until the strict-aliasing breakage will be fixed
+ append-cflags -fno-strict-aliasing
+
+ emake CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" CC=$(tc-getCC) ${args}
+
+ if use tools ; then
+ for contrib in halog iprange ; do
+ emake -C contrib/${contrib} \
+ CFLAGS="${CFLAGS}" OPTIMIZE="${CFLAGS}" LDFLAGS="${LDFLAGS}" CC=$(tc-getCC) ${args}
+ done
+ fi
+}
+
+src_install() {
+ dobin haproxy
+
+ newinitd "${FILESDIR}/haproxy.initd-r2" haproxy
+
+ # Don't install useless files
+# rm examples/build.cfg doc/*gpl.txt
+
+ dodoc CHANGELOG ROADMAP doc/{configuration,haproxy-en}.txt
+ doman doc/haproxy.1
+
+ dobin haproxy-systemd-wrapper
+ systemd_dounit contrib/systemd/haproxy.service
+
+ if use tools ; then
+ for contrib in halog iprange ; do
+ dobin contrib/${contrib}/${contrib}
+ done
+ fi
+
+ if use examples ; then
+ docinto examples
+ dodoc examples/*.cfg
+ fi
+
+ if use vim-syntax ; then
+ insinto /usr/share/vim/vimfiles/syntax
+ doins examples/haproxy.vim
+ fi
+}
+
+pkg_postinst() {
+ if [[ ! -f "${ROOT}/etc/haproxy.cfg" ]] ; then
+ ewarn "You need to create /etc/haproxy.cfg before you start the haproxy service."
+ ewarn "It's best practice to not run haproxy as root, user and group haproxy was therefore created."
+ ewarn "Make use of them with the \"user\" and \"group\" directives."
+
+ if [[ -d "${ROOT}/usr/share/doc/${PF}" ]]; then
+ einfo "Please consult the installed documentation for learning the configuration file's syntax."
+ einfo "The documentation and sample configuration files are installed here:"
+ einfo " ${ROOT}usr/share/doc/${PF}"
+ fi
+ fi
+}
diff --git a/net-proxy/haproxy/haproxy-1.6.3.ebuild b/net-proxy/haproxy/haproxy-1.6.3-r1.ebuild
index 5bf06c314d9f..cd98d1ecfa4c 100644
--- a/net-proxy/haproxy/haproxy-1.6.3.ebuild
+++ b/net-proxy/haproxy/haproxy-1.6.3-r1.ebuild
@@ -125,9 +125,8 @@ src_install() {
fi
if use tools ; then
- for contrib in halog iprange ; do
- dobin contrib/${contrib}/${contrib}
- done
+ dobin contrib/halog/halog
+ newbin contrib/iprange/iprange haproxy_iprange
fi
if use net_ns && use doc; then
diff --git a/net-proxy/haproxy/haproxy-1.6.4.ebuild b/net-proxy/haproxy/haproxy-1.6.4.ebuild
new file mode 100644
index 000000000000..cd98d1ecfa4c
--- /dev/null
+++ b/net-proxy/haproxy/haproxy-1.6.4.ebuild
@@ -0,0 +1,160 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit user versionator toolchain-funcs flag-o-matic systemd linux-info
+
+MY_P="${PN}-${PV/_beta/-dev}"
+
+DESCRIPTION="A TCP/HTTP reverse proxy for high availability environments"
+HOMEPAGE="http://haproxy.1wt.eu"
+SRC_URI="http://haproxy.1wt.eu/download/$(get_version_component_range 1-2)/src/${MY_P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86"
+IUSE="+crypt doc examples net_ns +pcre pcre-jit ssl tools vim-syntax +zlib" # lua
+
+DEPEND="pcre? ( dev-libs/libpcre
+ pcre-jit? ( dev-libs/libpcre[jit] )
+ )
+ ssl? ( dev-libs/openssl:0[zlib?] )
+ zlib? ( sys-libs/zlib )"
+# lua? ( dev-lang/lua:5.3 )
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ enewgroup haproxy
+ enewuser haproxy -1 -1 -1 haproxy
+
+ if use net_ns; then
+ CONFIG_CHECK="~NET_NS"
+ linux-info_pkg_setup
+ fi
+}
+
+src_prepare() {
+ sed -e 's:@SBINDIR@:'/usr/bin':' contrib/systemd/haproxy.service.in \
+ > contrib/systemd/haproxy.service || die
+
+ sed -ie 's:/usr/sbin/haproxy:/usr/bin/haproxy:' src/haproxy-systemd-wrapper.c || die
+}
+
+src_compile() {
+ local args="TARGET=linux2628 USE_GETADDRINFO=1"
+
+ if use crypt ; then
+ args="${args} USE_LIBCRYPT=1"
+ else
+ args="${args} USE_LIBCRYPT="
+ fi
+
+# bug 541042
+# if use lua; then
+# args="${args} USE_LUA=1"
+# else
+ args="${args} USE_LUA="
+# fi
+
+ if use net_ns; then
+ args="${args} USE_NS=1"
+ else
+ args="${args} USE_NS="
+ fi
+
+ if use pcre ; then
+ args="${args} USE_PCRE=1"
+ if use pcre-jit; then
+ args="${args} USE_PCRE_JIT=1"
+ else
+ args="${args} USE_PCRE_JIT="
+ fi
+ else
+ args="${args} USE_PCRE= USE_PCRE_JIT="
+ fi
+
+# if use kernel_linux; then
+# args="${args} USE_LINUX_SPLICE=1 USE_LINUX_TPROXY=1"
+# else
+# args="${args} USE_LINUX_SPLICE= USE_LINUX_TPROXY="
+# fi
+
+ if use ssl ; then
+ args="${args} USE_OPENSSL=1"
+ else
+ args="${args} USE_OPENSSL="
+ fi
+
+ if use zlib ; then
+ args="${args} USE_ZLIB=1"
+ else
+ args="${args} USE_ZLIB="
+ fi
+
+ # For now, until the strict-aliasing breakage will be fixed
+ append-cflags -fno-strict-aliasing
+
+ emake CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" CC=$(tc-getCC) ${args}
+
+ if use tools ; then
+ for contrib in halog iprange ; do
+ emake -C contrib/${contrib} \
+ CFLAGS="${CFLAGS}" OPTIMIZE="${CFLAGS}" LDFLAGS="${LDFLAGS}" CC=$(tc-getCC) ${args}
+ done
+ fi
+}
+
+src_install() {
+ dobin haproxy
+
+ newconfd "${FILESDIR}/${PN}.confd" $PN
+ newinitd "${FILESDIR}/${PN}.initd-r3" $PN
+
+ dodoc CHANGELOG CONTRIBUTING MAINTAINERS
+ doman doc/haproxy.1
+
+ dobin haproxy-systemd-wrapper
+ systemd_dounit contrib/systemd/haproxy.service
+
+ if use doc; then
+ dodoc ROADMAP doc/{close-options,configuration,cookie-options,intro,linux-syn-cookies,management,proxy-protocol}.txt
+ fi
+
+ if use tools ; then
+ dobin contrib/halog/halog
+ newbin contrib/iprange/iprange haproxy_iprange
+ fi
+
+ if use net_ns && use doc; then
+ dodoc doc/network-namespaces.txt
+ fi
+
+ if use examples ; then
+ docinto examples
+ dodoc examples/*.cfg
+ dodoc examples/seamless_reload.txt
+ fi
+
+ if use vim-syntax ; then
+ insinto /usr/share/vim/vimfiles/syntax
+ doins examples/haproxy.vim
+ fi
+}
+
+pkg_postinst() {
+ if [[ ! -f "${ROOT}/etc/haproxy/haproxy.cfg" ]] ; then
+ ewarn "You need to create /etc/haproxy/haproxy.cfg before you start the haproxy service."
+ ewarn "It's best practice to not run haproxy as root, user and group haproxy was therefore created."
+ ewarn "Make use of them with the \"user\" and \"group\" directives."
+
+ if [[ -d "${ROOT}/usr/share/doc/${PF}" ]]; then
+ einfo "Please consult the installed documentation for learning the configuration file's syntax."
+ einfo "The documentation and sample configuration files are installed here:"
+ einfo " ${ROOT}usr/share/doc/${PF}"
+ fi
+ fi
+}