summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBertrand Jacquin <bertrand@jacquin.bzh>2016-09-18 00:51:56 +0100
committerChristian Ruppert <idl0r@gentoo.org>2016-09-28 21:53:50 +0200
commit4a0bcfa4da2f591eb0cadc883faafaa41ff9aa4a (patch)
tree4fc070c4bd766a79dcdcbdc8f8c571636b4d563c /net-proxy
parentdev-libs/libslz: stateless, zlib-compatible, and very fast compression library (diff)
downloadgentoo-4a0bcfa4da2f591eb0cadc883faafaa41ff9aa4a.tar.gz
gentoo-4a0bcfa4da2f591eb0cadc883faafaa41ff9aa4a.tar.bz2
gentoo-4a0bcfa4da2f591eb0cadc883faafaa41ff9aa4a.zip
net-proxy/haproxy: Introduce USE=slz
USE=zlib stay the default one in order to avoid users to have to manually satisfy USE flag constraints since USE=zlib and USE=slz are mutually exclusive. Package-Manager: portage-2.2.28 Closes: https://github.com/gentoo/gentoo/pull/2293 Signed-off-by: Christian Ruppert <idl0r@gentoo.org>
Diffstat (limited to 'net-proxy')
-rw-r--r--net-proxy/haproxy/haproxy-1.6.9.ebuild7
-rw-r--r--net-proxy/haproxy/haproxy-9999.ebuild7
-rw-r--r--net-proxy/haproxy/metadata.xml1
3 files changed, 11 insertions, 4 deletions
diff --git a/net-proxy/haproxy/haproxy-1.6.9.ebuild b/net-proxy/haproxy/haproxy-1.6.9.ebuild
index a0703717fcd7..c9a98ed4d849 100644
--- a/net-proxy/haproxy/haproxy-1.6.9.ebuild
+++ b/net-proxy/haproxy/haproxy-1.6.9.ebuild
@@ -15,8 +15,9 @@ SRC_URI="http://haproxy.1wt.eu/download/$(get_version_component_range 1-2)/src/$
LICENSE="GPL-2 LGPL-2.1"
SLOT="0"
KEYWORDS="~amd64 ~arm ~ppc ~x86"
-IUSE="+crypt doc examples libressl net_ns +pcre pcre-jit ssl tools vim-syntax +zlib" # lua
-REQUIRED_USE="pcre-jit? ( pcre )"
+IUSE="+crypt doc examples libressl slz net_ns +pcre pcre-jit ssl tools vim-syntax +zlib" # lua
+REQUIRED_USE="pcre-jit? ( pcre )
+ ?? ( slz zlib )"
DEPEND="
pcre? (
@@ -27,6 +28,7 @@ DEPEND="
!libressl? ( dev-libs/openssl:0=[zlib?] )
libressl? ( dev-libs/libressl:0= )
)
+ slz? ( dev-libs/libslz:= )
zlib? ( sys-libs/zlib )"
# lua? ( dev-lang/lua:5.3 )
RDEPEND="${DEPEND}"
@@ -79,6 +81,7 @@ src_compile() {
# args+=( $(haproxy_use kernel_linux LINUX_TPROXY) )
args+=( $(haproxy_use ssl OPENSSL) )
+ args+=( $(haproxy_use slz SLZ) )
args+=( $(haproxy_use zlib ZLIB) )
# For now, until the strict-aliasing breakage will be fixed
diff --git a/net-proxy/haproxy/haproxy-9999.ebuild b/net-proxy/haproxy/haproxy-9999.ebuild
index 9499a5117790..4100bfa77387 100644
--- a/net-proxy/haproxy/haproxy-9999.ebuild
+++ b/net-proxy/haproxy/haproxy-9999.ebuild
@@ -15,8 +15,9 @@ EGIT_REPO_URI="http://master.formilux.org/git/people/willy/haproxy.git"
LICENSE="GPL-2 LGPL-2.1"
SLOT="0"
KEYWORDS=""
-IUSE="+crypt doc examples libressl net_ns +pcre pcre-jit ssl tools vim-syntax +zlib" # lua
-REQUIRED_USE="pcre-jit? ( pcre )"
+IUSE="+crypt doc examples libressl slz net_ns +pcre pcre-jit ssl tools vim-syntax +zlib" # lua
+REQUIRED_USE="pcre-jit? ( pcre )
+ ?? ( slz zlib )"
DEPEND="
pcre? (
@@ -27,6 +28,7 @@ DEPEND="
!libressl? ( dev-libs/openssl:0=[zlib?] )
libressl? ( dev-libs/libressl:0= )
)
+ slz? ( dev-libs/libslz:= )
zlib? ( sys-libs/zlib )"
# lua? ( dev-lang/lua:5.3 )
RDEPEND="${DEPEND}"
@@ -79,6 +81,7 @@ src_compile() {
# args+=( $(haproxy_use kernel_linux LINUX_TPROXY) )
args+=( $(haproxy_use ssl OPENSSL) )
+ args+=( $(haproxy_use slz SLZ) )
args+=( $(haproxy_use zlib ZLIB) )
# For now, until the strict-aliasing breakage will be fixed
diff --git a/net-proxy/haproxy/metadata.xml b/net-proxy/haproxy/metadata.xml
index 56529589cf4c..2aaccf14afe7 100644
--- a/net-proxy/haproxy/metadata.xml
+++ b/net-proxy/haproxy/metadata.xml
@@ -21,6 +21,7 @@ Its event-driven architecture allows it to easily handle thousands of simultaneo
<use>
<flag name="net_ns">Enable network namespace support (CONFIG_NET_NS)</flag>
<flag name="pcre-jit">Use JIT support for PCRE</flag>
+ <flag name="slz">Use <pkg>dev-libs/libslz</pkg> compression library</flag>
<flag name="tools">Install additional tools (halog, iprange)</flag>
</use>
</pkgmetadata>