summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-06-12 16:17:29 +0100
committerSam James <sam@gentoo.org>2022-06-12 16:19:26 +0100
commit36694733018225c7518e5dee07e037f55aaf2df5 (patch)
tree5ef2cbdf529524144857cf65ac6aa7e29e91659c /sci-astronomy
parentnet-misc/ntpsec: fix distutils-r1 usage (diff)
downloadgentoo-36694733018225c7518e5dee07e037f55aaf2df5.tar.gz
gentoo-36694733018225c7518e5dee07e037f55aaf2df5.tar.bz2
gentoo-36694733018225c7518e5dee07e037f55aaf2df5.zip
sci-astronomy/pyephem: add 4.1.1
Closes: https://bugs.gentoo.org/846212 Closes: https://bugs.gentoo.org/809659 Closes: https://bugs.gentoo.org/733282 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-astronomy')
-rw-r--r--sci-astronomy/pyephem/Manifest1
-rw-r--r--sci-astronomy/pyephem/pyephem-4.1.1.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/sci-astronomy/pyephem/Manifest b/sci-astronomy/pyephem/Manifest
index 9329cd696462..c975c283041f 100644
--- a/sci-astronomy/pyephem/Manifest
+++ b/sci-astronomy/pyephem/Manifest
@@ -1 +1,2 @@
DIST pyephem-3.7.7.1.tar.gz 1622306 BLAKE2B aefdd7b7e4471140f1c2b5c065f663dfb1095d8d8325e23d4b5b9c683ff7a91020151429a992ad78be897ab738d9bc207afa337b7806fb244d6d6c8a1c680b7f SHA512 ae0d9562f33ee25065b33ea3d4b24a74e32259bebb07edf37deacaa77e6d24b3a7a49e4602393b45a3c7cfc7d8088f038e68e96ec3576a796b5486fc2946ac5a
+DIST pyephem-4.1.1.gh.tar.gz 2659977 BLAKE2B e373857d3fb66e742f9db992165dbd1d50afbb6b91588f2cfcd299409d491ef1174c54a182dd59b5a8e298a07312899c8f8b5a8aaa63e6b31deb5f8b1cd3131e SHA512 2539f36b7110cacd6cf95e9ba0be26ca837a66ba81f092d4be01405029adf22478184861f46ecf09d6cd35927140874e0f0d228b06537d05f3e2eddbcb35da85
diff --git a/sci-astronomy/pyephem/pyephem-4.1.1.ebuild b/sci-astronomy/pyephem/pyephem-4.1.1.ebuild
new file mode 100644
index 000000000000..2e6565b7f7e9
--- /dev/null
+++ b/sci-astronomy/pyephem/pyephem-4.1.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Astronomical routines for the Python programming language"
+HOMEPAGE="https://rhodesmill.org/pyephem/"
+SRC_URI="https://github.com/brandon-rhodes/pyephem/archive/refs/tags/${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc"
+
+BDEPEND="doc? ( dev-python/sphinx )"
+
+distutils_enable_tests unittest
+
+src_prepare() {
+ # Don't install rst files by default
+ sed -i -e "s:'doc/\*\.rst',::" setup.py || die
+ distutils-r1_src_prepare
+}
+
+src_compile() {
+ distutils-r1_src_compile
+ if use doc; then
+ PYTHONPATH=. emake -C ephem/doc html
+ fi
+}
+
+python_test() {
+ cd "${T}" || die
+ epytest --pyargs ephem
+}
+
+src_install() {
+ use doc && HTML_DOCS=( ephem/doc/_build/html/. )
+ distutils-r1_src_install
+}
+
+python_install() {
+ distutils-r1_python_install
+
+ rm -r "${D}$(python_get_sitedir)/ephem/tests" || die
+}