summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVolkmar W. Pogatzki <gentoo@pogatzki.net>2023-09-15 14:11:11 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2023-09-17 17:51:16 +0300
commitdfb8fc1ab575e04ca6d8f6e8b4a11e4e1a4b4364 (patch)
tree02a35aa72a3ddb8fdff42ec1de5519426533f1dc /sci-astronomy
parentdev-util/shtool: EAPI8 bump, fixes #880289, #724276 (diff)
downloadgentoo-dfb8fc1ab575e04ca6d8f6e8b4a11e4e1a4b4364.tar.gz
gentoo-dfb8fc1ab575e04ca6d8f6e8b4a11e4e1a4b4364.tar.bz2
gentoo-dfb8fc1ab575e04ca6d8f6e8b4a11e4e1a4b4364.zip
sci-astronomy/cpl: add 7.3.2, update EAPI 6 -> 8
Bug: https://bugs.gentoo.org/834577 Bug: https://bugs.gentoo.org/905683 Signed-off-by: Volkmar W. Pogatzki <gentoo@pogatzki.net> Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'sci-astronomy')
-rw-r--r--sci-astronomy/cpl/Manifest1
-rw-r--r--sci-astronomy/cpl/cpl-7.3.2.ebuild70
2 files changed, 71 insertions, 0 deletions
diff --git a/sci-astronomy/cpl/Manifest b/sci-astronomy/cpl/Manifest
index 6390d6e12c57..da45f158ecbf 100644
--- a/sci-astronomy/cpl/Manifest
+++ b/sci-astronomy/cpl/Manifest
@@ -1 +1,2 @@
DIST cpl-7.0.tar.gz 3090767 BLAKE2B bb1f6dcc35c1e2f574a6e008af2461a3832cfbd742bcef7ce9ff151d7fd7157ecc34b6efb75dcf3fc77e41ae20d7d14f229da05351712c3214f9da4814e0f5e5 SHA512 d79eb37a5f29740edc1736815bde6ec31bc4e1f648552cad48ab70626170ff6195d226de0c198e0287dee3bfe815ee7302b6882395d710c534fabe0c5353aaa6
+DIST cpl-7.3.2.tar.gz 3442591 BLAKE2B 286b2a0f6b9af92395a3247b176bf9ab28a126008f3c68b790515dd6d13cf5bf02982382fe3c3ea3067020ff84c3e525326d3f6cb9110d8b1eded485f7d95da9 SHA512 fa0877346967581992ddd8e0e64c6b280b3bac7d086c071d6428d1ee3afa8030e1e6beb5e1b23d23447c7669b86e5264cd4fe6f9fd330ab15ed883aec4ea2ab6
diff --git a/sci-astronomy/cpl/cpl-7.3.2.ebuild b/sci-astronomy/cpl/cpl-7.3.2.ebuild
new file mode 100644
index 000000000000..14ed1365f279
--- /dev/null
+++ b/sci-astronomy/cpl/cpl-7.3.2.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+JAVA_PKG_OPT_USE=gasgano
+
+inherit autotools java-pkg-opt-2
+
+DESCRIPTION="ESO common pipeline library for astronomical data reduction"
+HOMEPAGE="https://www.eso.org/sci/software/cpl/"
+SRC_URI="https://ftp.eso.org/pub/dfs/pipelines/libraries/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0/26"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+IUSE="doc gasgano static-libs threads"
+
+RDEPEND="
+ dev-libs/libltdl
+ sci-astronomy/wcslib:0=
+ sci-libs/cfitsio:0=
+ sci-libs/fftw:3.0=
+ gasgano? ( sci-astronomy/gasgano )"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )"
+
+src_prepare() {
+ default
+ # remove cpu chcking
+ sed -e '/CPL_CHECK_CPU/d' \
+ -i configure.ac libcext/configure.ac || die
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --disable-ltdl-install
+ --without-included-ltdl
+ --with-cfitsio="${EPREFIX}/usr"
+ --with-wcs="${EPREFIX}/usr"
+ --with-fftw="${EPREFIX}/usr"
+ $(use_enable doc maintainer-mode)
+ $(use_enable static-libs static)
+ $(use_enable threads)
+ )
+ if use gasgano; then
+ myeconfargs+=(
+ --enable-gasgano
+ --with-gasgano="${EPREFIX}/usr"
+ --with-gasgano-classpath="${EPREFIX}/usr/share/gasgano/lib"
+ --with-java="$(java-config -O)"
+ )
+ else
+ myeconfargs+=( --disable-gasgano )
+ fi
+ econf ${myeconfargs[@]}
+}
+
+src_compile() {
+ default
+ use doc && emake html
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+ use doc && emake install-html
+}