summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2016-09-20 20:52:11 +0200
committerDavid Seifert <soap@gentoo.org>2016-09-20 23:05:59 +0200
commit25e5a98a39581c4c7c2b5c9f29b429baee0462b5 (patch)
tree752452e385ea423c560a7ad703f6fd39235ba674 /sci-biology/prank
parentapp-i18n/enca: install missing pkgconfig file in 1.19 (diff)
downloadgentoo-25e5a98a39581c4c7c2b5c9f29b429baee0462b5.tar.gz
gentoo-25e5a98a39581c4c7c2b5c9f29b429baee0462b5.tar.bz2
gentoo-25e5a98a39581c4c7c2b5c9f29b429baee0462b5.zip
sci-biology/prank: Allow for compiling with GCC 6
Gentoo-bug: 594060 * EAPI=6 Package-Manager: portage-2.3.1
Diffstat (limited to 'sci-biology/prank')
-rw-r--r--sci-biology/prank/files/prank-140603-fix-c++14.patch14
-rw-r--r--sci-biology/prank/prank-140603.ebuild8
2 files changed, 19 insertions, 3 deletions
diff --git a/sci-biology/prank/files/prank-140603-fix-c++14.patch b/sci-biology/prank/files/prank-140603-fix-c++14.patch
new file mode 100644
index 000000000000..5779207e294f
--- /dev/null
+++ b/sci-biology/prank/files/prank-140603-fix-c++14.patch
@@ -0,0 +1,14 @@
+Fix building with C++14, which errors out due to changing operator void* -> operator bool.
+See also: https://bugs.gentoo.org/show_bug.cgi?id=594060
+
+--- a/hmmodel.cpp
++++ b/hmmodel.cpp
+@@ -1499,7 +1499,7 @@
+ }
+ else
+ {
+- cout<<"HMModel::alignmentModel: impossible 'as'"<<cout;
++ cout<<"HMModel::alignmentModel: impossible 'as'"<<bool(cout);
+ exit(-1);
+ }
+
diff --git a/sci-biology/prank/prank-140603.ebuild b/sci-biology/prank/prank-140603.ebuild
index a18b7ab9d553..ca22fff7e491 100644
--- a/sci-biology/prank/prank-140603.ebuild
+++ b/sci-biology/prank/prank-140603.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=4
+EAPI=6
-inherit eutils multilib toolchain-funcs
+inherit toolchain-funcs
DESCRIPTION="Probabilistic Alignment Kit"
HOMEPAGE="http://wasabiapp.org/software/prank/"
@@ -16,12 +16,14 @@ IUSE=""
KEYWORDS="~amd64 ~x86"
S="${WORKDIR}/${PN}-msa/src"
+PATCHES=( "${FILESDIR}/${PN}-140603-fix-c++14.patch" )
src_prepare() {
sed \
-e "s/\$(LINK)/& \$(LDFLAGS)/" \
-e "s:/usr/lib:${EPREFIX}/usr/$(get_libdir):g" \
-i Makefile || die
+ default
}
src_compile() {