summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGerhard Bräunlich <wippbox@gmx.net>2016-10-21 10:21:12 +0200
committerDavid Seifert <soap@gentoo.org>2016-10-21 20:49:15 +0200
commitd7e369070301bb74a82847ab545a52287e69a9c1 (patch)
tree5053978529114c676102d989709d38b395ae574a /sci-calculators/pcalc
parentsci-calculators/hexcalc: EAPI bump 4 -> 6 (diff)
downloadgentoo-d7e369070301bb74a82847ab545a52287e69a9c1.tar.gz
gentoo-d7e369070301bb74a82847ab545a52287e69a9c1.tar.bz2
gentoo-d7e369070301bb74a82847ab545a52287e69a9c1.zip
sci-calculators/pcalc: EAPI bump 4 -> 6
Package-Manager: portage-2.3.0 Closes: https://github.com/gentoo/gentoo/pull/2615 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sci-calculators/pcalc')
-rw-r--r--sci-calculators/pcalc/pcalc-3-r1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/sci-calculators/pcalc/pcalc-3-r1.ebuild b/sci-calculators/pcalc/pcalc-3-r1.ebuild
new file mode 100644
index 000000000000..cb90924fec6a
--- /dev/null
+++ b/sci-calculators/pcalc/pcalc-3-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="the programmers calculator"
+HOMEPAGE="https://github.com/vapier/pcalc"
+SRC_URI="mirror://sourceforge/pcalc/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND="sys-devel/flex"
+RDEPEND=""
+
+src_prepare() {
+ default
+ sed -i -e "s:/usr:${EPREFIX}/usr:g" Makefile || die
+}
+
+src_configure() {
+ tc-export CC
+}