summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-chemistry/pdb2pqr
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-chemistry/pdb2pqr')
-rw-r--r--sci-chemistry/pdb2pqr/Manifest1
-rw-r--r--sci-chemistry/pdb2pqr/files/pdb2pka13
-rw-r--r--sci-chemistry/pdb2pqr/files/pdb2pqr13
-rw-r--r--sci-chemistry/pdb2pqr/files/pdb2pqr-1.9.0-flags.patch45
-rw-r--r--sci-chemistry/pdb2pqr/files/pdb2pqr-1.9.0-install-py.patch15
-rw-r--r--sci-chemistry/pdb2pqr/metadata.xml12
-rw-r--r--sci-chemistry/pdb2pqr/pdb2pqr-1.9.0-r1.ebuild130
7 files changed, 229 insertions, 0 deletions
diff --git a/sci-chemistry/pdb2pqr/Manifest b/sci-chemistry/pdb2pqr/Manifest
new file mode 100644
index 000000000000..a34457524075
--- /dev/null
+++ b/sci-chemistry/pdb2pqr/Manifest
@@ -0,0 +1 @@
+DIST pdb2pqr-src-1.9.0.tar.gz 9051969 SHA256 d9d91bf27a023732be33d1d780ef283ae28d3b0e256c53e86c37ac001dd7ef53 SHA512 7f3f191cca9879a0e166e82700c706f8c99bb66558a218e54845f10c3324b6c45d413da80b0782d96a8d56df1463262609db075aba3768db3942cb928ee7b98f WHIRLPOOL 4a4b883200dad3e7467392e508c2372ad6876e78005da14e5747f3b7b12d0e3d5695e3cc590812b835ae67703819b201620809dff05af0a7c363c23d22046bae
diff --git a/sci-chemistry/pdb2pqr/files/pdb2pka b/sci-chemistry/pdb2pqr/files/pdb2pka
new file mode 100644
index 000000000000..2406b0c4773f
--- /dev/null
+++ b/sci-chemistry/pdb2pqr/files/pdb2pka
@@ -0,0 +1,13 @@
+#!/usr/bin/env python
+
+import subprocess
+import site
+import sys
+import os
+
+sitepackages = site.getsitepackages()[0]
+
+_cmd=[os.path.join(sitepackages, "pdb2pqr", "pdb2pka", "pka.py")]
+_cmd.extend(sys.argv[1:])
+
+subprocess.call(_cmd, stdout=sys.stdout, stderr=sys.stderr)
diff --git a/sci-chemistry/pdb2pqr/files/pdb2pqr b/sci-chemistry/pdb2pqr/files/pdb2pqr
new file mode 100644
index 000000000000..8c0635aea94e
--- /dev/null
+++ b/sci-chemistry/pdb2pqr/files/pdb2pqr
@@ -0,0 +1,13 @@
+#!/usr/bin/env python
+
+import subprocess
+import site
+import sys
+import os
+
+sitepackages = site.getsitepackages()[0]
+
+_cmd=[os.path.join(sitepackages, "pdb2pqr", "pdb2pqr.py")]
+_cmd.extend(sys.argv[1:])
+
+subprocess.call(_cmd, stdout=sys.stdout, stderr=sys.stderr)
diff --git a/sci-chemistry/pdb2pqr/files/pdb2pqr-1.9.0-flags.patch b/sci-chemistry/pdb2pqr/files/pdb2pqr-1.9.0-flags.patch
new file mode 100644
index 000000000000..fac32b233e6b
--- /dev/null
+++ b/sci-chemistry/pdb2pqr/files/pdb2pqr-1.9.0-flags.patch
@@ -0,0 +1,45 @@
+ pdb2pka/SConscript | 9 ++++++++-
+ pdb2pka/substruct/SConscript | 6 ++++++
+ 2 files changed, 14 insertions(+), 1 deletion(-)
+
+diff --git a/pdb2pka/SConscript b/pdb2pka/SConscript
+index 583cdc5..6c30011 100644
+--- a/pdb2pka/SConscript
++++ b/pdb2pka/SConscript
+@@ -1,4 +1,11 @@
+ Import('env')
++import os
++
++env['CCFLAGS'].extend(os.environ['CXXFLAGS'].split())
++env['LINKFLAGS'].extend(os.environ['LDFLAGS'].split())
++env['CXX'] = os.environ['CXX']
++env['LINK'] = os.environ['CXX']
++
+
+ if env['REBUILD_SWIG']:
+ pyc = env.LoadableModule('_pMC_mult', ['pMC_mult.cpp', 'pMC_mult.i'])
+@@ -9,4 +16,4 @@ Default(pyc)
+
+ algorithms_module = SConscript('substruct/SConscript')
+
+-Return('pyc algorithms_module')
+\ No newline at end of file
++Return('pyc algorithms_module')
+diff --git a/pdb2pka/substruct/SConscript b/pdb2pka/substruct/SConscript
+index 7dbcdb0..56fb577 100644
+--- a/pdb2pka/substruct/SConscript
++++ b/pdb2pka/substruct/SConscript
+@@ -1,7 +1,13 @@
+ import distutils
+ import numpy
++import os
+ Import('env')
+
++env['CCFLAGS'].extend(os.environ['CXXFLAGS'].split())
++env['LINKFLAGS'].extend(os.environ['LDFLAGS'].split())
++env['CXX'] = os.environ['CXX']
++env['LINK'] = os.environ['CXX']
++
+ env.Append(CPPPATH=[distutils.sysconfig.get_python_inc(), numpy.get_include()])
+
+ algorithms_pyc = env.LoadableModule('Algorithms', ['Algorithms.cpp'])
diff --git a/sci-chemistry/pdb2pqr/files/pdb2pqr-1.9.0-install-py.patch b/sci-chemistry/pdb2pqr/files/pdb2pqr-1.9.0-install-py.patch
new file mode 100644
index 000000000000..2695b013c66a
--- /dev/null
+++ b/sci-chemistry/pdb2pqr/files/pdb2pqr-1.9.0-install-py.patch
@@ -0,0 +1,15 @@
+ SConscript-install.py | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/SConscript-install.py b/SConscript-install.py
+index e2f9f09..1fdf1a8 100644
+--- a/SConscript-install.py
++++ b/SConscript-install.py
+@@ -41,6 +41,7 @@ def installFile(file_name, build_target='install'):
+ if GetOption("clean"):
+ env.Default(result)
+ Alias(build_target, env.Install(env['PREFIX']+dirname(file_name), result))
++ Alias(build_target, env.Install(env['PREFIX']+dirname(file_name), target))
+ else:
+ Alias(build_target, env.Install(env['PREFIX']+dirname(file_name), target))
+
diff --git a/sci-chemistry/pdb2pqr/metadata.xml b/sci-chemistry/pdb2pqr/metadata.xml
new file mode 100644
index 000000000000..81003ba2152a
--- /dev/null
+++ b/sci-chemistry/pdb2pqr/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-chemistry</herd>
+ <use>
+ <flag name="opal">Add web interface via opal</flag>
+ <flag name="pdb2pka">Install experimental pdb2pka interface</flag>
+ </use>
+ <upstream>
+ <remote-id type="github">Electrostatics/apbs-pdb2pqr</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/sci-chemistry/pdb2pqr/pdb2pqr-1.9.0-r1.ebuild b/sci-chemistry/pdb2pqr/pdb2pqr-1.9.0-r1.ebuild
new file mode 100644
index 000000000000..7359b9094128
--- /dev/null
+++ b/sci-chemistry/pdb2pqr/pdb2pqr-1.9.0-r1.ebuild
@@ -0,0 +1,130 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit scons-utils fortran-2 flag-o-matic python-r1 toolchain-funcs
+
+DESCRIPTION="An automated pipeline for performing Poisson-Boltzmann electrostatics calculations"
+HOMEPAGE="http://www.poissonboltzmann.org/"
+SRC_URI="https://github.com/Electrostatics/apbs-${PN}/releases/download/${P}/${PN}-src-${PV}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+IUSE="doc examples opal +pdb2pka"
+KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ dev-python/numpy[${PYTHON_USEDEP}]
+ sci-chemistry/openbabel-python[${PYTHON_USEDEP}]
+ opal? ( dev-python/zsi[${PYTHON_USEDEP}] )
+ pdb2pka? ( sci-chemistry/apbs[${PYTHON_USEDEP},-mpi] )"
+DEPEND="${RDEPEND}
+ dev-lang/swig:0"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-flags.patch
+ "${FILESDIR}"/${P}-install-py.patch
+)
+
+pkg_setup() {
+ if [[ -z ${MAXATOMS} ]]; then
+ einfo "If you like to have support for more then 10000 atoms,"
+ einfo "export MAXATOMS=\"your value\""
+ export MAXATOMS=10000
+ else
+ einfo "Allow usage of ${MAXATOMS} during calculations"
+ fi
+ fortran-2_pkg_setup
+}
+
+src_prepare() {
+ find -type f \( -name "*\.pyc" -o -name "*\.pyo" \) -delete || die
+
+ export CXXFLAGS="${CXXFLAGS}"
+ export LDFLAGS="${LDFLAGS}"
+
+ epatch ${PATCHES[@]}
+ tc-export CXX
+ rm -rf scons || die
+
+ python_copy_sources
+}
+
+src_configure() {
+ python_configure() {
+ cd "${BUILD_DIR}" || die
+
+ cat > build_config.py <<- EOF
+ PREFIX="${D}/$(python_get_sitedir)/${PN}"
+ #URL="http://<COMPUTER NAME>/pdb2pqr/"
+ APBS="${EPREFIX}/usr/bin/apbs"
+ #OPAL="http://nbcr-222.ucsd.edu/opal2/services/pdb2pqr_1.8"
+ #APBS_OPAL="http://nbcr-222.ucsd.edu/opal2/services/apbs_1.3"
+ MAX_ATOMS=${MAXATOMS}
+ BUILD_PDB2PKA=$(usex pdb2pka True False)
+ REBUILD_SWIG=True
+ EOF
+ }
+
+ python_foreach_impl python_configure
+}
+
+src_compile() {
+ python_compile() {
+ cd "${BUILD_DIR}" || die
+ escons
+ }
+ python_foreach_impl python_compile
+}
+
+src_test() {
+ python_test() {
+ local myesconsargs=( -j1 )
+ cd "${BUILD_DIR}" || die
+ escons test
+ escons advtest
+ escons complete-test
+ }
+ python_foreach_impl python_test
+}
+
+src_install() {
+ dodir /usr/share/doc/${PF}/html
+ python_install() {
+ local lib
+
+ cd "${BUILD_DIR}" || die
+
+ escons install
+
+ find "${D}$(python_get_sitedir)"/${PN}/{jmol,examples,doc,contrib} -delete || die
+
+ python_doscript "${FILESDIR}"/{${PN},pdb2pka}
+
+ for lib in apbslib.py{,c,o}; do
+ dosym ../../apbs/${lib} $(python_get_sitedir)/${PN}/pdb2pka/${lib}
+ done
+ dosym ../../_apbslib.so $(python_get_sitedir)/${PN}/pdb2pka/_apbslib.so
+ python_optimize
+ }
+ python_foreach_impl python_install
+
+ if use doc; then
+ pushd doc > /dev/null
+ docinto html
+ dodoc -r *.html images pydoc
+ popd > /dev/null
+ fi
+
+ use examples && \
+ insinto /usr/share/${PN}/ && \
+ doins -r examples
+
+ dodoc *md NEWS
+}