summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-geosciences/gshhs
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-geosciences/gshhs')
-rw-r--r--sci-geosciences/gshhs/Manifest1
-rw-r--r--sci-geosciences/gshhs/gshhs-1.13.ebuild42
-rw-r--r--sci-geosciences/gshhs/metadata.xml14
3 files changed, 57 insertions, 0 deletions
diff --git a/sci-geosciences/gshhs/Manifest b/sci-geosciences/gshhs/Manifest
new file mode 100644
index 000000000000..02391cd1b18a
--- /dev/null
+++ b/sci-geosciences/gshhs/Manifest
@@ -0,0 +1 @@
+DIST gshhs_1.13_src.zip 19483 SHA256 2a5420ade8fd1e4987cc80715002cca65010605d9996b230d0fc9300743092d4 SHA512 c83574f2e2f3b795391d0016234974fb3f3956c8af568b78be07c58f4194ec2c8b34f2f91ab52f1b635f4e4870167d6ef357c4d362207521ed587d89c7d3738a WHIRLPOOL b1b1bf2d392ba43267582c2bc925fa737ba961a3799e42e8e051fd188ee61717e2bee1ef54c76cdb2f5929bbd14bfc4e21e44f42fb5620902baa665476c00712
diff --git a/sci-geosciences/gshhs/gshhs-1.13.ebuild b/sci-geosciences/gshhs/gshhs-1.13.ebuild
new file mode 100644
index 000000000000..3de7c1cf0465
--- /dev/null
+++ b/sci-geosciences/gshhs/gshhs-1.13.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit toolchain-funcs
+
+DESCRIPTION="Global Self-consistent, Hierarchical, High-resolution Shoreline programs"
+HOMEPAGE="http://www.ngdc.noaa.gov/mgg/shorelines/gshhs.html"
+SRC_URI="ftp://ftp.soest.hawaii.edu/pwessel/gshhs/gshhs_1.13_src.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="+data"
+
+RDEPEND="sci-libs/netcdf
+ sci-libs/gdal
+ data? ( sci-geosciences/gshhs-data )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ app-arch/unzip"
+
+S="${WORKDIR}/${PN}"
+
+src_compile() {
+ local p
+ for p in gshhs gshhs_dp gshhstograss; do
+ $(tc-getCC) ${CFLAGS} $($(tc-getPKG_CONFIG) --cflags netcdf) \
+ ${LDFLAGS} ${p}.c \
+ $($(tc-getPKG_CONFIG) --libs netcdf) -lgdal -lm -o ${p} \
+ || die
+ done
+}
+
+src_install() {
+ dobin gshhs gshhs_dp gshhstograss
+ insinto /usr/include
+ doins gshhs.h
+ dodoc README.gshhs
+}
diff --git a/sci-geosciences/gshhs/metadata.xml b/sci-geosciences/gshhs/metadata.xml
new file mode 100644
index 000000000000..64ad63711e6b
--- /dev/null
+++ b/sci-geosciences/gshhs/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci-geosciences</herd>
+<longdescription lang='en'>
+ GSHHS is a high-resolution shoreline data set amalgamated from two
+ databases in the public domain. This package contains access
+ software and routines to facilitate decimation based on a standard
+ line-reduction algorithm.
+</longdescription>
+<use>
+ <flag name="data">Add earth data with <pkg>sci-geosciences/gshhs-data</pkg> </flag>
+</use>
+</pkgmetadata>