summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHenning Schild <henning@hennsch.de>2024-02-11 09:53:08 +1300
committerFlorian Schmaus <flow@gentoo.org>2024-03-04 11:21:16 +0100
commit904952639d9be37b03d0b656a2744075390bc373 (patch)
tree949ce41842bbb03aa41775588c0b5ce51c8d68b7 /sci-geosciences/josm-bin
parentsci-geosciences/josm-bin: drop old (diff)
downloadgentoo-904952639d9be37b03d0b656a2744075390bc373.tar.gz
gentoo-904952639d9be37b03d0b656a2744075390bc373.tar.bz2
gentoo-904952639d9be37b03d0b656a2744075390bc373.zip
sci-geosciences/josm-bin: version bump to 18969
Signed-off-by: Henning Schild <henning@hennsch.de> Closes: https://github.com/gentoo/gentoo/pull/35269 Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'sci-geosciences/josm-bin')
-rw-r--r--sci-geosciences/josm-bin/Manifest1
-rw-r--r--sci-geosciences/josm-bin/josm-bin-18969.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/sci-geosciences/josm-bin/Manifest b/sci-geosciences/josm-bin/Manifest
index 9c1add2b1a0c..81eaa25eb80c 100644
--- a/sci-geosciences/josm-bin/Manifest
+++ b/sci-geosciences/josm-bin/Manifest
@@ -1 +1,2 @@
DIST josm-snapshot-18940.jar 16847223 BLAKE2B 5412fed01c5452440669f05169a2ee90796a549635a1cacbb5f859decebf3de6235dfd6c2624cb3cf5602fbb7e475703f13feb9b4edce07fa40bffddc8b73b3e SHA512 0d9f19a3d4cc2d944443973508464db48f02dad15a55277669c328c79187481c58d40b0bd2ff82328c983f235d211c2b08d39a6e7e98d9a0c30a68db9e03dfe1
+DIST josm-snapshot-18969.jar 16856669 BLAKE2B 9ef29900ff07fa150eb1d53e4884aae785328c904bf789dfd3b56903694f5fecd0a61c012db11903615b1a5f46bf82bfd3694e3bdf04a713b141cd2b9c2ea80c SHA512 495477d7a8162531557e20098862182ab9be765741ad05cc8d5ff9e101baa64d11783d4c7480bcafc3c3356c9e471ec6b2116a6a10fe76429f690135495db18c
diff --git a/sci-geosciences/josm-bin/josm-bin-18969.ebuild b/sci-geosciences/josm-bin/josm-bin-18969.ebuild
new file mode 100644
index 000000000000..8283ef7c22aa
--- /dev/null
+++ b/sci-geosciences/josm-bin/josm-bin-18969.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop java-utils-2 xdg
+
+DESCRIPTION="Java-based editor for the OpenStreetMap project"
+HOMEPAGE="https://josm.openstreetmap.de/"
+# PV should be stable here https://josm.openstreetmap.de/wiki/StartupPage
+SRC_URI="https://josm.openstreetmap.de/download/josm-snapshot-${PV}.jar"
+S="${WORKDIR}"
+
+LICENSE="Apache-2.0 GPL-2+ GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=">=virtual/jre-1.8"
+BDEPEND="app-arch/unzip"
+
+src_install() {
+ java-pkg_newjar "${DISTDIR}/${A}" ${PN}.jar
+ java-pkg_dolauncher ${PN} --jar ${PN}.jar
+
+ local icon_size
+ for icon_size in 16 32 48; do
+ newicon -s ${icon_size} -t hicolor \
+ images/logo_${icon_size}x${icon_size}x32.png ${PN}.png
+ newicon -s ${icon_size} -t locolor \
+ images/logo_${icon_size}x${icon_size}x8.png ${PN}.png
+ done
+ make_desktop_entry ${PN} "Java OpenStreetMap Editor" ${PN} "Utility;Science;Geoscience"
+}