summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2021-03-26 12:30:31 +0100
committerDavid Seifert <soap@gentoo.org>2021-03-26 12:30:31 +0100
commit0dbb223c286116aab94998a65cac14d5126f892f (patch)
tree1d4a33daa4435682e72786a7aba9bd41b59f3d65 /sci-libs/alglib/alglib-3.17.0.ebuild
parentsci-calculators/qalculate-gtk: Bump to 3.17.0 (diff)
downloadgentoo-0dbb223c286116aab94998a65cac14d5126f892f.tar.gz
gentoo-0dbb223c286116aab94998a65cac14d5126f892f.tar.bz2
gentoo-0dbb223c286116aab94998a65cac14d5126f892f.zip
sci-libs/alglib: Bump to 3.17.0
Closes: https://bugs.gentoo.org/774438 Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sci-libs/alglib/alglib-3.17.0.ebuild')
-rw-r--r--sci-libs/alglib/alglib-3.17.0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/sci-libs/alglib/alglib-3.17.0.ebuild b/sci-libs/alglib/alglib-3.17.0.ebuild
new file mode 100644
index 000000000000..6f520c619d21
--- /dev/null
+++ b/sci-libs/alglib/alglib-3.17.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake flag-o-matic
+
+DESCRIPTION="Numerical analysis and data processing library"
+HOMEPAGE="https://www.alglib.net/"
+SRC_URI="https://www.alglib.net/translator/re/${P}.cpp.gpl.tgz"
+S="${WORKDIR}"/cpp
+
+LICENSE="GPL-2+"
+SLOT="0/3.8"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+src_prepare() {
+ cp "${FILESDIR}"/CMakeLists.txt-3.8.2 CMakeLists.txt || die
+ cmake_src_prepare
+}
+
+src_configure() {
+ use x86 && append-cflags -ffloat-store
+ local mycmakeargs=(
+ -DBUILD_TEST=$(usex test)
+ )
+ cmake_src_configure
+}