summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFrançois Bissey <frp.bissey@gmail.com>2023-06-06 09:10:14 +1200
committerMichael Orlitzky <mjo@gentoo.org>2023-06-19 20:01:15 -0400
commitdddcc722fc0ccd972c56e68be58e19ccb36b31ec (patch)
tree8b8ffae8c69102c759924d592da081abae033be1 /sci-libs/btf
parentsci-libs/cxsparse: add 4.0.3 (diff)
downloadgentoo-dddcc722fc0ccd972c56e68be58e19ccb36b31ec.tar.gz
gentoo-dddcc722fc0ccd972c56e68be58e19ccb36b31ec.tar.bz2
gentoo-dddcc722fc0ccd972c56e68be58e19ccb36b31ec.zip
sci-libs/btf: add 2.0.3
Signed-off-by: François Bissey <frp.bissey@gmail.com> Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'sci-libs/btf')
-rw-r--r--sci-libs/btf/Manifest1
-rw-r--r--sci-libs/btf/btf-2.0.3.ebuild28
-rw-r--r--sci-libs/btf/metadata.xml3
3 files changed, 32 insertions, 0 deletions
diff --git a/sci-libs/btf/Manifest b/sci-libs/btf/Manifest
index 61f58e3f7bdf..7489d0d176c8 100644
--- a/sci-libs/btf/Manifest
+++ b/sci-libs/btf/Manifest
@@ -1 +1,2 @@
+DIST SuiteSparse-7.0.0.gh.tar.gz 64884962 BLAKE2B 06c6cf54ffae188f5179e0cd45523700448d8999b44d6b1aeb3dfb99ccf34a570f6aff600988a144c68a4a2d8f41e32f7145e09349aed3bd889501ea031c8340 SHA512 50b1cd7bab6e4c063984162ed803fd13b69df7f67efe8ce7af15eace6b0ccd1669b6e57daa59511fd9531a847433cda49c1f52bfff234031af0d79e7fbd6423e
DIST btf-1.2.6.tar.bz2 285699 BLAKE2B 4addeea7b9abe87281f826a67a8a372118579f498057c888008ac93da1cdbfcf8554af6e843d92a07989ff0b24f537588f933fcc33c97317f47536980e551531 SHA512 39c08ec9bf2a85915aeed040dc02c42c10adf5034c3797910dc7cb6942ac6e2ccea47cea4ab0c37e8ed3eb8eac8d2ce946d281c9ec643cccd282af7be5276960
diff --git a/sci-libs/btf/btf-2.0.3.ebuild b/sci-libs/btf/btf-2.0.3.ebuild
new file mode 100644
index 000000000000..f3d679bc9c50
--- /dev/null
+++ b/sci-libs/btf/btf-2.0.3.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake-multilib
+
+Sparse_PV="7.0.0"
+Sparse_P="SuiteSparse-${Sparse_PV}"
+DESCRIPTION="Algorithm for matrix permutation into block triangular form"
+HOMEPAGE="https://people.engr.tamu.edu/davis/suitesparse.html"
+SRC_URI="https://github.com/DrTimothyAldenDavis/SuiteSparse/archive/refs/tags/v${Sparse_PV}.tar.gz -> ${Sparse_P}.gh.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0/2"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+DEPEND=">=sci-libs/suitesparseconfig-${Sparse_PV}"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${Sparse_P}/${PN^^}"
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DNSTATIC=ON
+ )
+ cmake_src_configure
+}
diff --git a/sci-libs/btf/metadata.xml b/sci-libs/btf/metadata.xml
index f15848939958..9f70db2d6ffd 100644
--- a/sci-libs/btf/metadata.xml
+++ b/sci-libs/btf/metadata.xml
@@ -11,4 +11,7 @@
its block upper triangular form (more precisely, it computes a
Dulmage-Mendelsohn decomposition).
</longdescription>
+ <upstream>
+ <remote-id type="github">DrTimothyAldenDavis/SuiteSparse</remote-id>
+ </upstream>
</pkgmetadata>