summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-02-28 15:18:18 +0100
committerMichał Górny <mgorny@gentoo.org>2024-02-28 17:48:44 +0100
commit5648e4e5dbd9ebf5d74e7e4c8766dba800b42a68 (patch)
tree97f4fd9ba9ef4cba4d0b5bae1c9fbded0d2d9d36 /sci-libs/cantera
parentsys-apps/lshw: update Manifest (diff)
downloadgentoo-5648e4e5dbd9ebf5d74e7e4c8766dba800b42a68.tar.gz
gentoo-5648e4e5dbd9ebf5d74e7e4c8766dba800b42a68.tar.bz2
gentoo-5648e4e5dbd9ebf5d74e7e4c8766dba800b42a68.zip
sci-libs/cantera: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sci-libs/cantera')
-rw-r--r--sci-libs/cantera/Manifest1
-rw-r--r--sci-libs/cantera/cantera-2.6.0-r2.ebuild154
-rw-r--r--sci-libs/cantera/cantera-3.0.0.ebuild143
-rw-r--r--sci-libs/cantera/files/cantera-2.6.0_drop_deprecated_open_U_option.patch49
-rw-r--r--sci-libs/cantera/files/cantera-2.6.0_env.patch78
-rw-r--r--sci-libs/cantera/metadata.xml1
6 files changed, 0 insertions, 426 deletions
diff --git a/sci-libs/cantera/Manifest b/sci-libs/cantera/Manifest
index 782522d16b9c..fe074558539e 100644
--- a/sci-libs/cantera/Manifest
+++ b/sci-libs/cantera/Manifest
@@ -1,2 +1 @@
-DIST cantera-2.6.0.tar.gz 2586243 BLAKE2B 3562dc3641c70cdbd5e07062ecee56c0658b098c20bb477c3e741731db01e38fccf624e6769377420b01dd4bac72a0608cf226cce40ac12f13e71081090e06bc SHA512 74e12c89af38236bcc064034f74edcc690895151a9e453e728d130b83f5f527e675750c68a3fe36eea3c6aec6969685aa8828ae740a2e27b5df72a8ccc4d2856
DIST cantera-3.0.0.tar.gz 2451103 BLAKE2B 094d7a4f0b8fd0f1a45d9f8c13e1390cf7fc62110e424e1287030e97382c1cdc016a5119adc4d5c7bbc222420a3b447db93fee8350643cb3a0907a838fbc1ddf SHA512 dffd696628210ae5c7b08e394e9a97262cfa6aa07ac2e6faa48591ecfee5bb11e7c2b6928563007fd581a1fd9cae999f7c1414ab5d5a312a823e155573df7aca
diff --git a/sci-libs/cantera/cantera-2.6.0-r2.ebuild b/sci-libs/cantera/cantera-2.6.0-r2.ebuild
deleted file mode 100644
index d024ceeacfc7..000000000000
--- a/sci-libs/cantera/cantera-2.6.0-r2.ebuild
+++ /dev/null
@@ -1,154 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{9..11} )
-
-FORTRAN_NEEDED=fortran
-FORTRAN_STANDARD="77 90"
-
-inherit fortran-2 python-single-r1 scons-utils toolchain-funcs
-
-DESCRIPTION="Object-oriented tool suite for chemical kinetics, thermodynamics, and transport"
-HOMEPAGE="https://www.cantera.org"
-SRC_URI="https://github.com/Cantera/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~x86"
-IUSE="+cti fortran lapack +python test"
-RESTRICT="!test? ( test )"
-
-REQUIRED_USE="
- python? ( cti )
- ${PYTHON_REQUIRED_USE}
-"
-
-RDEPEND="
- ${PYTHON_DEPS}
- dev-cpp/yaml-cpp
- cti? (
- $(python_gen_cond_dep '
- dev-python/ruamel-yaml[${PYTHON_USEDEP}]
- ')
- )
- !lapack? ( sci-libs/sundials:0= )
- lapack? (
- >=sci-libs/sundials-6.5.0:0=[lapack?]
- virtual/lapack
- )
- python? (
- $(python_gen_cond_dep '
- dev-python/numpy[${PYTHON_USEDEP}]
- ')
- )
-"
-
-# <cython-3 for bug #913141
-DEPEND="
- ${RDEPEND}
- dev-cpp/eigen:3
- dev-libs/boost:=
- dev-libs/libfmt
- python? (
- $(python_gen_cond_dep '
- <dev-python/cython-3[${PYTHON_USEDEP}]
- dev-python/pip[${PYTHON_USEDEP}]
- ')
- )
- test? (
- >=dev-cpp/gtest-1.11.0
- python? (
- $(python_gen_cond_dep '
- dev-python/h5py[${PYTHON_USEDEP}]
- dev-python/pandas[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/scipy[${PYTHON_USEDEP}]
- ')
- )
- )
-"
-
-PATCHES=(
- "${FILESDIR}/${P}_env.patch"
- "${FILESDIR}/${P}_drop_deprecated_open_U_option.patch"
-)
-
-pkg_setup() {
- fortran-2_pkg_setup
- python-single-r1_pkg_setup
-}
-
-## Full list of configuration options of Cantera is presented here:
-## http://cantera.org/docs/sphinx/html/compiling/config-options.html
-src_configure() {
- scons_vars=(
- AR="$(tc-getAR)"
- CC="$(tc-getCC)"
- CXX="$(tc-getCXX)"
- cc_flags="${CXXFLAGS}"
- cxx_flags="-std=c++14"
- debug="no"
- FORTRAN="$(tc-getFC)"
- FORTRANFLAGS="${FCFLAGS}"
- optimize_flags="-Wno-inline"
- renamed_shared_libraries="no"
- use_pch="no"
- ## In some cases other order can break the detection of right location of Boost: ##
- system_fmt="y"
- system_sundials="y"
- system_eigen="y"
- system_yamlcpp="y"
- env_vars="all"
- extra_inc_dirs="/usr/include/eigen3"
- )
- use lapack && scons_vars+=( blas_lapack_libs="lapack,blas" )
- use test || scons_vars+=( googletest="none" )
-
- scons_targets=(
- f90_interface=$(usex fortran y n)
- )
-
- if use cti ; then
- local scons_python=$(usex python full minimal)
- scons_targets+=( python_package="${scons_python}" python_cmd="${EPYTHON}" )
- else
- scons_targets+=( python_package="none" )
- fi
-}
-
-src_compile() {
- escons build "${scons_vars[@]}" "${scons_targets[@]}" prefix="/usr"
-}
-
-src_test() {
- escons test
-}
-
-src_install() {
- escons install stage_dir="${D}" libdirname="$(get_libdir)"
- if ! use cti ; then
- rm -r "${D}/usr/share/man" || die "Can't remove man files."
- else
- # Run the byte-compile of modules
- python_optimize "${D}$(python_get_sitedir)/${PN}"
- fi
-
- # User could remove this line if require static libs for development purpose
- find "${ED}" -name '*.a' -delete || die
-}
-
-pkg_postinst() {
- if use cti && ! use python ; then
- elog "Cantera was build without 'python' use-flag therefore the CTI tools 'ck2cti' and 'ck2yaml"
- elog "will convert Chemkin files to Cantera format without verification of kinetic mechanism."
- fi
-
- local post_msg=$(usex fortran "and Fortran " "")
- elog "C++ ${post_msg}samples are installed to '/usr/share/${PN}/samples/' directory."
-
- if use python ; then
- elog "Python examples are installed to '$(python_get_sitedir)/${PN}/examples/' directories."
- fi
-}
diff --git a/sci-libs/cantera/cantera-3.0.0.ebuild b/sci-libs/cantera/cantera-3.0.0.ebuild
deleted file mode 100644
index d53ba2538180..000000000000
--- a/sci-libs/cantera/cantera-3.0.0.ebuild
+++ /dev/null
@@ -1,143 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{10..11} )
-
-FORTRAN_NEEDED=fortran
-FORTRAN_STANDARD="77 90"
-
-inherit fortran-2 python-single-r1 scons-utils toolchain-funcs
-
-DESCRIPTION="Object-oriented tool suite for chemical kinetics, thermodynamics, and transport"
-HOMEPAGE="https://www.cantera.org"
-SRC_URI="https://github.com/Cantera/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="fortran hdf5 lapack +python test"
-RESTRICT="!test? ( test )"
-
-REQUIRED_USE="
- ${PYTHON_REQUIRED_USE}
-"
-
-RDEPEND="
- ${PYTHON_DEPS}
- dev-cpp/yaml-cpp
- hdf5? ( sci-libs/HighFive )
- !lapack? ( sci-libs/sundials:0= )
- lapack? (
- >=sci-libs/sundials-6.5.0:0=[lapack?]
- virtual/lapack
- )
- python? (
- $(python_gen_cond_dep '
- dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/ruamel-yaml[${PYTHON_USEDEP}]
- ')
- )
-"
-
-DEPEND="
- ${RDEPEND}
- dev-cpp/eigen:3
- dev-libs/boost:=
- dev-libs/libfmt
- python? (
- $(python_gen_cond_dep '
- dev-python/cython[${PYTHON_USEDEP}]
- dev-python/pip[${PYTHON_USEDEP}]
- ')
- )
- test? (
- >=dev-cpp/gtest-1.11.0
- python? (
- $(python_gen_cond_dep '
- dev-python/h5py[${PYTHON_USEDEP}]
- dev-python/pandas[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/scipy[${PYTHON_USEDEP}]
- ')
- )
- )
-"
-
-PATCHES=(
- "${FILESDIR}/${P}_env.patch"
-)
-
-pkg_setup() {
- fortran-2_pkg_setup
- python-single-r1_pkg_setup
-}
-
-## Full list of configuration options of Cantera is presented here:
-## http://cantera.org/docs/sphinx/html/compiling/config-options.html
-src_configure() {
- scons_vars=(
- AR="$(tc-getAR)"
- CC="$(tc-getCC)"
- CXX="$(tc-getCXX)"
- cc_flags="${CXXFLAGS}"
- cxx_flags="-std=c++17"
- debug="no"
- FORTRAN="$(tc-getFC)"
- FORTRANFLAGS="${FCFLAGS}"
- optimize_flags="-Wno-inline"
- renamed_shared_libraries="no"
- use_pch="no"
- ## In some cases other order can break the detection of right location of Boost: ##
- system_fmt="y"
- system_sundials="y"
- system_eigen="y"
- system_yamlcpp="y"
- hdf_support=$(usex hdf5 y n)
- system_blas_lapack=$(usex lapack y n)
- env_vars="all"
- extra_inc_dirs="/usr/include/eigen3"
- use_rpath_linkage="yes"
- extra_lib_dirs="/usr/$(get_libdir)/${PN}"
- )
- use hdf5 && scons_vars+=( system_highfive="y" )
- use lapack && scons_vars+=( blas_lapack_libs="lapack,blas" )
- use test || scons_vars+=( googletest="none" )
-
- scons_targets=(
- f90_interface=$(usex fortran y n)
- )
-
- if use python ; then
- scons_targets+=( python_package="full" python_cmd="${EPYTHON}" )
- else
- scons_targets+=( python_package="none" )
- fi
-}
-
-src_compile() {
- escons build "${scons_vars[@]}" "${scons_targets[@]}" prefix="/usr"
-}
-
-src_test() {
- escons test
-}
-
-src_install() {
- escons install stage_dir="${D}" libdirname="$(get_libdir)"
- if ! use python ; then
- rm -r "${D}/usr/share/man" || die "Can't remove man files."
- else
- # Run the byte-compile of modules
- python_optimize "${D}$(python_get_sitedir)/${PN}"
- fi
-
- # User could remove this line if require static libs for development purpose
- find "${ED}" -name '*.a' -delete || die
-}
-
-pkg_postinst() {
- local post_msg=$(usex fortran "and Fortran " "")
- elog "C++ ${post_msg}samples are installed to '/usr/share/${PN}/samples/' directory."
-}
diff --git a/sci-libs/cantera/files/cantera-2.6.0_drop_deprecated_open_U_option.patch b/sci-libs/cantera/files/cantera-2.6.0_drop_deprecated_open_U_option.patch
deleted file mode 100644
index 41243da82f68..000000000000
--- a/sci-libs/cantera/files/cantera-2.6.0_drop_deprecated_open_U_option.patch
+++ /dev/null
@@ -1,49 +0,0 @@
-From 0b407e11fe0bae4707286ab3cbf6a7a72a906817 Mon Sep 17 00:00:00 2001
-From: "Mark E. Fuller" <mark.e.fuller@gmx.de>
-Date: Thu, 23 Jun 2022 00:04:22 +0300
-Subject: [PATCH] drop deprecated 'U' open option
-
----
- site_scons/site_tools/subst.py | 15 +++------------
- 1 file changed, 3 insertions(+), 12 deletions(-)
-
-diff --git a/site_scons/site_tools/subst.py b/site_scons/site_tools/subst.py
-index 3a1c4f6fb8..05d520491b 100644
---- a/site_scons/site_tools/subst.py
-+++ b/site_scons/site_tools/subst.py
-@@ -12,7 +12,7 @@
-
- from SCons.Script import *
- import SCons.Errors
--
-+from pathlib import Path
-
- # Helper/core functions
- ##############################################################################
-@@ -20,12 +20,7 @@
- # Do the substitution
- def _subst_file(target, source, env, pattern, replace):
- # Read file
-- #print 'CALLING SUBST_FILE'
-- f = open(source, "rU")
-- try:
-- contents = f.read()
-- finally:
-- f.close()
-+ contents = Path(source).read_text()
-
- # Substitute, make sure result is a string
- def subfn(mo):
-@@ -46,11 +41,7 @@ def subfn(mo):
- # Determine which keys are used
- def _subst_keys(source, pattern):
- # Read file
-- f = open(source, "rU")
-- try:
-- contents = f.read()
-- finally:
-- f.close()
-+ contents = Path(source).read_text()
-
- # Determine keys
- keys = []
diff --git a/sci-libs/cantera/files/cantera-2.6.0_env.patch b/sci-libs/cantera/files/cantera-2.6.0_env.patch
deleted file mode 100644
index 15a1e65857e4..000000000000
--- a/sci-libs/cantera/files/cantera-2.6.0_env.patch
+++ /dev/null
@@ -1,78 +0,0 @@
-diff -Naur old/SConstruct new/SConstruct
---- old/SConstruct
-+++ new/SConstruct
-@@ -178,6 +178,10 @@
-
- config_options = [
- Option(
-+ "AR",
-+ "The archiver to use.",
-+ "${AR}"),
-+ Option(
- "CXX",
- "The C++ compiler to use.",
- "${CXX}"),
-@@ -740,7 +744,7 @@
- toolchain = ["default"]
-
- env = Environment(tools=toolchain+["textfile", "subst", "recursiveInstall", "wix", "gch"],
-- ENV={"PATH": os.environ["PATH"]},
-+ ENV={'PATH': os.environ['PATH'], 'CCACHE_DIR': os.environ.get('CCACHE_DIR','')},
- toolchain=toolchain,
- **extraEnvArgs)
-
-@@ -775,7 +779,7 @@
-
- add_RegressionTest(env)
-
--opts.AddVariables(*config.to_scons(["CC", "CXX"], env=env))
-+opts.AddVariables(*config.to_scons(["AR", "CC", "CXX"], env=env))
- opts.Update(env)
-
- # Check if this is actually Apple's clang on macOS
-@@ -861,11 +865,7 @@
- env['cantera_pure_version'] = re.match(r'(\d+\.\d+\.\d+)', env['cantera_version']).group(0)
- env['cantera_short_version'] = re.match(r'(\d+\.\d+)', env['cantera_version']).group(0)
-
--try:
-- env["git_commit"] = get_command_output("git", "rev-parse", "--short", "HEAD")
-- logger.info(f"Building Cantera from git commit '{env['git_commit']}'")
--except (subprocess.CalledProcessError, FileNotFoundError):
-- env["git_commit"] = "unknown"
-+env["git_commit"] = "unknown"
-
- # Print values of all build options:
- # the (updated) "cantera.conf" combines all options that were specified by the user
-diff -Naur old/interfaces/cython/SConscript new/interfaces/cython/SConscript
---- old/interfaces/cython/SConscript
-+++ new/interfaces/cython/SConscript
-@@ -107,7 +107,7 @@
- obj, LIBPREFIX="", SHLIBSUFFIX=module_ext,
- SHLIBPREFIX="", LIBSUFFIXES=[module_ext])
-
--build_cmd = ("$python_cmd_esc -m pip wheel -v --no-build-isolation --use-feature=in-tree-build --no-deps "
-+build_cmd = ("$python_cmd_esc -m pip wheel -v --no-build-isolation --no-deps "
- "--wheel-dir=build/python/dist build/python")
- plat = info['plat'].replace('-', '_').replace('.', '_')
- wheel_name = (f"Cantera-{env['cantera_version']}-cp{py_version_nodot}"
-@@ -172,7 +172,7 @@
-
- install_cmd.append(f"--root={stage_dir.resolve()}")
-
--install_cmd.extend(("--no-build-isolation", "--use-feature=in-tree-build", "--no-deps", "-v", "--force-reinstall",
-+install_cmd.extend(("--no-build-isolation", "--no-deps", "-v", "--force-reinstall",
- "build/python"))
- if localenv['PYTHON_INSTALLER'] == 'direct':
- mod_inst = install(localenv.Command, 'dummy', mod,
-diff -Naur old/test_problems/SConscript new/test_problems/SConscript
---- old/test_problems/SConscript
-+++ new/test_problems/SConscript
-@@ -233,7 +233,7 @@
- artifacts=['vcs_equilibrate_res.csv'])
-
- CompileAndTest('clib', 'clib_test', 'clib_test',
-- extensions=['^clib_test.c'], libs=localenv['cantera_shared_libs'])
-+ extensions=['^clib_test.c'])
-
- # C++ Samples
- Test('cxx-bvp', 'cxx_samples', '#build/samples/cxx/bvp/blasius', None,
diff --git a/sci-libs/cantera/metadata.xml b/sci-libs/cantera/metadata.xml
index fbc827be0db4..d3c6628839c0 100644
--- a/sci-libs/cantera/metadata.xml
+++ b/sci-libs/cantera/metadata.xml
@@ -14,7 +14,6 @@
for problems involving chemical kinetics, thermodynamics, and/or transport processes.
</longdescription>
<use>
- <flag name="cti">Install conversion tools (ck2cti, ck2yaml, ctml_writer) from Chemkin to Cantera format</flag>
<flag name="python">Install Python bindings and conversion tools from Chemkin to Cantera format</flag>
<flag name="hdf5">Add HDF5 container files support</flag>
</use>