summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-libs/cholmod
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-libs/cholmod')
-rw-r--r--sci-libs/cholmod/Manifest1
-rw-r--r--sci-libs/cholmod/cholmod-2.1.2.ebuild64
-rw-r--r--sci-libs/cholmod/files/cholmod-1.7.4-parmetis32.patch20
-rw-r--r--sci-libs/cholmod/metadata.xml13
4 files changed, 98 insertions, 0 deletions
diff --git a/sci-libs/cholmod/Manifest b/sci-libs/cholmod/Manifest
new file mode 100644
index 000000000000..ced0618d04ec
--- /dev/null
+++ b/sci-libs/cholmod/Manifest
@@ -0,0 +1 @@
+DIST cholmod-2.1.2.tar.bz2 656458 SHA256 eea80ad7b797866df1505feafa8c33279f6bc7e7e5aec4f00a167a0a0e73675f SHA512 7aca97de4c60ff2d7a76a776be4c2d61243a159a51b9e147fa2480f2aaf61a5d966eb0f1cb57c0145510437f6c478fa30384b741709d0a02432b74ada3e78089 WHIRLPOOL 8f8f2c4f504f30905c442422042d0b3a203cb24ab289b51bdb4ee6606ca006eef3afb2611bcc6074c1532893caa5ec5a63e4c4d46d115e2528700d98b65dcb27
diff --git a/sci-libs/cholmod/cholmod-2.1.2.ebuild b/sci-libs/cholmod/cholmod-2.1.2.ebuild
new file mode 100644
index 000000000000..5c29e9933e85
--- /dev/null
+++ b/sci-libs/cholmod/cholmod-2.1.2.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools-utils multilib toolchain-funcs
+
+DESCRIPTION="Sparse Cholesky factorization and update/downdate library"
+HOMEPAGE="http://www.cise.ufl.edu/research/sparse/cholmod/"
+SRC_URI="http://dev.gentoo.org/~bicatali/distfiles/${P}.tar.bz2"
+
+LICENSE="minimal? ( LGPL-2.1 ) !minimal? ( GPL-2 )"
+SLOT="0"
+KEYWORDS="amd64 ~arm hppa ~mips ppc ppc64 sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~x86-macos"
+IUSE="cuda doc lapack metis minimal static-libs"
+
+RDEPEND="
+ >=sci-libs/amd-2.3
+ >=sci-libs/colamd-2.8
+ cuda? ( x11-drivers/nvidia-drivers dev-util/nvidia-cuda-toolkit )
+ lapack? ( virtual/lapack )
+ metis? (
+ >=sci-libs/camd-2.3
+ >=sci-libs/ccolamd-2.8
+ || ( sci-libs/metis sci-libs/parmetis ) )"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( virtual/latex-base )"
+
+src_prepare() {
+ # bug #399483 does not build with parmetis-3.2
+ has_version "=sci-libs/parmetis-3.2*" && \
+ epatch "${FILESDIR}"/${PN}-1.7.4-parmetis32.patch
+}
+
+src_configure() {
+ local lapack_libs=no
+ local blas_libs=no
+ if use lapack; then
+ blas_libs=$($(tc-getPKG_CONFIG) --libs blas)
+ lapack_libs=$($(tc-getPKG_CONFIG) --libs lapack)
+ fi
+ local myeconfargs=(
+ --with-blas="${blas_libs}"
+ --with-lapack="${lapack_libs}"
+ $(use_with doc)
+ $(use_with !minimal modify)
+ $(use_with !minimal matrixops)
+ $(use_with !minimal partition)
+ $(use_with metis camd)
+ $(use_with metis partition)
+ $(use_with lapack supernodal)
+ )
+ if use cuda; then
+ myeconfargs+=(
+ --with-cuda
+ --with-cublas-libs="-L${EPREFIX}/opt/cuda/$(get_libdir) -lcublas"
+ --with-cublas-cflags="-I${EPREFIX}/opt/cuda/include"
+ )
+ fi
+ autotools-utils_src_configure
+}
diff --git a/sci-libs/cholmod/files/cholmod-1.7.4-parmetis32.patch b/sci-libs/cholmod/files/cholmod-1.7.4-parmetis32.patch
new file mode 100644
index 000000000000..6b50ae8bcea7
--- /dev/null
+++ b/sci-libs/cholmod/files/cholmod-1.7.4-parmetis32.patch
@@ -0,0 +1,20 @@
+diff -Nur CHOLMOD.orig/Partition/cholmod_metis.c CHOLMOD/Partition/cholmod_metis.c
+--- CHOLMOD.orig/Partition/cholmod_metis.c 2012-03-13 03:57:37.000000000 +0000
++++ CHOLMOD/Partition/cholmod_metis.c 2012-03-13 04:02:22.000000000 +0000
+@@ -216,6 +216,7 @@
+ int Opt [8], nn, csp ;
+ size_t n1 ;
+ DEBUG (Int nsep) ;
++ float ubfactor = 1.05;
+
+ /* ---------------------------------------------------------------------- */
+ /* check inputs */
+@@ -370,7 +371,7 @@
+ #endif
+
+ nn = n ;
+- METIS_NodeComputeSeparator (&nn, Mp, Mi, Mnw, Mew, Opt, &csp, Mpart) ;
++ METIS_NodeComputeSeparator (&nn, Mp, Mi, Mnw, Mew, &ubfactor, Opt, &csp, Mpart) ;
+ n = nn ;
+ csep = csp ;
+
diff --git a/sci-libs/cholmod/metadata.xml b/sci-libs/cholmod/metadata.xml
new file mode 100644
index 000000000000..7590541d295d
--- /dev/null
+++ b/sci-libs/cholmod/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci</herd>
+ <longdescription lang="en">
+ CHOLMOD is a set of ANSI C routines for sparse Cholesky
+ factorization and update/downdate.
+</longdescription>
+ <use>
+ <flag name="cuda">Use nvidia cuda toolkit for speeding up computations</flag>
+ <flag name="metis">Enable the Partition module to cholmod using <pkg>sci-libs/metis</pkg></flag>
+ </use>
+</pkgmetadata>