summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFrançois Bissey <frp.bissey@gmail.com>2020-07-03 21:19:15 +1200
committerMichael Orlitzky <mjo@gentoo.org>2020-07-13 07:44:51 -0400
commit7311a1368de9aa10d9a92b0e23fc4bd74e0838ee (patch)
treee4babe407f654d26747d74f464ae467b21dc9111 /sci-libs/fplll/fplll-5.3.3.ebuild
parentpackage.mask: Last rite mid-profile <pillow-7 revdeps (diff)
downloadgentoo-7311a1368de9aa10d9a92b0e23fc4bd74e0838ee.tar.gz
gentoo-7311a1368de9aa10d9a92b0e23fc4bd74e0838ee.tar.bz2
gentoo-7311a1368de9aa10d9a92b0e23fc4bd74e0838ee.zip
sci-libs/fplll: upstream bump
Closes: https://github.com/gentoo/gentoo/pull/16565 Package-Manager: Portage-2.3.99, Repoman-2.3.23 Signed-off-by: François René Pierre Bissey <frp.bissey@gmail.com> Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'sci-libs/fplll/fplll-5.3.3.ebuild')
-rw-r--r--sci-libs/fplll/fplll-5.3.3.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/sci-libs/fplll/fplll-5.3.3.ebuild b/sci-libs/fplll/fplll-5.3.3.ebuild
new file mode 100644
index 000000000000..2757d1e1f4a1
--- /dev/null
+++ b/sci-libs/fplll/fplll-5.3.3.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Implementations of the floating-point LLL reduction algorithm"
+HOMEPAGE="https://github.com/fplll/fplll"
+SRC_URI="https://github.com/${PN}/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0/6"
+KEYWORDS="~amd64 ~x86"
+IUSE="static-libs"
+
+BDEPEND=""
+DEPEND="dev-libs/gmp:0
+ dev-libs/mpfr:0"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ # Support for --with-qd is problematic at the moment.
+ # https://github.com/fplll/fplll/issues/405
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}