summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz93@gmail.com>2024-02-28 01:28:08 -0500
committerSam James <sam@gentoo.org>2024-02-28 15:26:27 +0000
commit91b7a7537de9f4c49d9ef8abb6eaba2b0fbbe79b (patch)
tree62988d80006546d469701c32905bae3c6840c72a /sci-libs/lapack
parentnet-libs/miniupnpc: drop "ipv6" use flag that is not needed (diff)
downloadgentoo-91b7a7537de9f4c49d9ef8abb6eaba2b0fbbe79b.tar.gz
gentoo-91b7a7537de9f4c49d9ef8abb6eaba2b0fbbe79b.tar.bz2
gentoo-91b7a7537de9f4c49d9ef8abb6eaba2b0fbbe79b.zip
sci-libs/lapack: mark as LTO-unsafe
Bug: https://bugs.gentoo.org/878891 Signed-off-by: Eli Schwartz <eschwartz93@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-libs/lapack')
-rw-r--r--sci-libs/lapack/lapack-3.11.ebuild9
-rw-r--r--sci-libs/lapack/lapack-3.12.0.ebuild7
2 files changed, 13 insertions, 3 deletions
diff --git a/sci-libs/lapack/lapack-3.11.ebuild b/sci-libs/lapack/lapack-3.11.ebuild
index 7e2764d7f209..91d893cac281 100644
--- a/sci-libs/lapack/lapack-3.11.ebuild
+++ b/sci-libs/lapack/lapack-3.11.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
# Some additional tests are run if Python is found
PYTHON_COMPAT=( python3_{10..11} )
-inherit cmake fortran-2 python-any-r1
+inherit cmake flag-o-matic fortran-2 python-any-r1
DESCRIPTION="BLAS,CBLAS,LAPACK,LAPACKE reference implementations"
HOMEPAGE="https://www.netlib.org/lapack/"
@@ -39,6 +39,11 @@ pkg_setup() {
}
src_configure() {
+ # -Werror=lto-type-mismatch
+ # https://bugs.gentoo.org/878891
+ # https://github.com/Reference-LAPACK/lapack/issues/990
+ filter-lto
+
local mycmakeargs=(
-DCBLAS=ON
-DLAPACKE=$(usex lapacke)
diff --git a/sci-libs/lapack/lapack-3.12.0.ebuild b/sci-libs/lapack/lapack-3.12.0.ebuild
index 229d8a10774d..4cc2f91f5f67 100644
--- a/sci-libs/lapack/lapack-3.12.0.ebuild
+++ b/sci-libs/lapack/lapack-3.12.0.ebuild
@@ -5,7 +5,7 @@ EAPI=8
# Some additional tests are run if Python is found
PYTHON_COMPAT=( python3_{10..11} )
-inherit cmake fortran-2 python-any-r1
+inherit cmake flag-o-matic fortran-2 python-any-r1
DESCRIPTION="BLAS, CBLAS, LAPACK, LAPACKE reference implementations"
HOMEPAGE="https://www.netlib.org/lapack/"
@@ -39,6 +39,11 @@ pkg_setup() {
}
src_configure() {
+ # -Werror=lto-type-mismatch
+ # https://bugs.gentoo.org/878891
+ # https://github.com/Reference-LAPACK/lapack/issues/990
+ filter-lto
+
local mycmakeargs=(
-DCBLAS=ON
-DLAPACKE=$(usex lapacke)