summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-libs/metis/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-libs/metis/files')
-rw-r--r--sci-libs/metis/files/metis-4.0.1-autotools.patch85
-rw-r--r--sci-libs/metis/files/metis-5.1.0-datatype.patch12
-rw-r--r--sci-libs/metis/files/metis-5.1.0-multilib.patch20
-rw-r--r--sci-libs/metis/files/metis-5.1.0-shared-GKlib.patch21
4 files changed, 138 insertions, 0 deletions
diff --git a/sci-libs/metis/files/metis-4.0.1-autotools.patch b/sci-libs/metis/files/metis-4.0.1-autotools.patch
new file mode 100644
index 000000000000..b9623dd9ebf4
--- /dev/null
+++ b/sci-libs/metis/files/metis-4.0.1-autotools.patch
@@ -0,0 +1,85 @@
+--- configure.ac 1970-01-01 01:00:00.000000000 +0100
++++ configure.ac 2008-03-25 10:05:57.090715324 +0000
+@@ -0,0 +1,15 @@
++# -*- Autoconf -*-
++AC_PREREQ(2.59)
++AC_INIT(metis, 4.0.1, karypis@cs.umn.edu)
++AM_INIT_AUTOMAKE([foreign])
++AC_CONFIG_HEADER([config.h])
++AC_PROG_INSTALL
++AC_PROG_LIBTOOL
++AC_CHECK_LIB(m, sqrt)
++AC_CONFIG_FILES([
++ Makefile
++ metis.pc
++ Lib/Makefile
++ Programs/Makefile\
++ Test/Makefile])
++AC_OUTPUT
+--- metis.pc.in 1970-01-01 01:00:00.000000000 +0100
++++ metis.pc.in 2008-02-15 14:45:09.378997263 +0000
+@@ -0,0 +1,10 @@
++prefix=@prefix@
++exec_prefix=@exec_prefix@
++libdir=@libdir@
++includedir=@includedir@
++
++Name: METIS
++Description: Software for partioning unstructured graphes and meshes
++Version: @VERSION@
++Libs: -L${libdir} -lmetis
++Cflags: -I${includedir}/metis
+--- Makefile.am 1970-01-01 01:00:00.000000000 +0100
++++ Makefile.am 2008-02-15 14:46:16.578826763 +0000
+@@ -0,0 +1,5 @@
++SUBDIRS = Lib Programs Test
++EXTRA_DIST = CHANGES VERSION metis.pc.in
++
++pkgconfigdir = $(libdir)/pkgconfig
++pkgconfig_DATA = metis.pc
+--- Lib/Makefile.am 1970-01-01 01:00:00.000000000 +0100
++++ Lib/Makefile.am 2008-03-25 10:06:10.719491984 +0000
+@@ -0,0 +1,15 @@
++pkginclude_HEADERS = defs.h macros.h metis.h proto.h rename.h struct.h
++pkgincludedir = $(includedir)/metis
++lib_LTLIBRARIES = libmetis.la
++libmetis_la_SOURCES = \
++ coarsen.c fm.c initpart.c match.c ccgraph.c memory.c \
++ pmetis.c pqueue.c refine.c util.c timing.c debug.c \
++ bucketsort.c graph.c stat.c kmetis.c kwayrefine.c \
++ kwayfm.c balance.c ometis.c srefine.c sfm.c separator.c \
++ mincover.c mmd.c mesh.c meshpart.c frename.c fortran.c \
++ myqsort.c compress.c parmetis.c estmem.c \
++ mpmetis.c mcoarsen.c mmatch.c minitpart.c mbalance.c \
++ mrefine.c mutil.c mfm.c mkmetis.c mkwayrefine.c mkwayfmh.c \
++ mrefine2.c minitpart2.c mbalance2.c mfm2.c \
++ kvmetis.c kwayvolrefine.c kwayvolfm.c subdomains.c
++libmetis_la_LDFLAGS = -no-undefined -version-info 4:0:0
+--- Programs/Makefile.am 1970-01-01 01:00:00.000000000 +0100
++++ Programs/Makefile.am 2008-01-31 12:00:14.981124649 +0000
+@@ -0,0 +1,15 @@
++AM_CPPFLAGS = -I$(top_srcdir)/Lib
++LDADD = $(top_builddir)/Lib/libmetis.la -lm
++
++bin_PROGRAMS = pmetis kmetis oemetis onmetis mesh2dual mesh2nodal \
++ partdmesh partnmesh graphchk
++
++pmetis_SOURCES = pmetis.c io.c
++kmetis_SOURCES = kmetis.c io.c
++oemetis_SOURCES = oemetis.c io.c smbfactor.c
++onmetis_SOURCES = onmetis.c io.c smbfactor.c
++mesh2dual_SOURCES = mesh2dual.c io.c
++mesh2nodal_SOURCES = mesh2nodal.c io.c
++partdmesh_SOURCES = partdmesh.c io.c
++partnmesh_SOURCES = partnmesh.c io.c
++graphchk_SOURCES = graphchk.c io.c
+--- Test/Makefile.am 1970-01-01 01:00:00.000000000 +0100
++++ Test/Makefile.am 2008-01-31 12:37:59.532517099 +0000
+@@ -0,0 +1,7 @@
++AM_CPPFLAGS = -I$(top_srcdir)/Lib
++LDADD = $(top_builddir)/Lib/libmetis.la -lm
++check_PROGRAMS = mtest
++mtest_SOURCES = mtest.c ../Programs/io.c
++
++check-local: $(check_PROGRAMS)
++ - ./mtest ../Graphs/4elt.graph
diff --git a/sci-libs/metis/files/metis-5.1.0-datatype.patch b/sci-libs/metis/files/metis-5.1.0-datatype.patch
new file mode 100644
index 000000000000..f583d05f34d9
--- /dev/null
+++ b/sci-libs/metis/files/metis-5.1.0-datatype.patch
@@ -0,0 +1,12 @@
+--- include/metis.orig.h 2013-03-11 20:50:00.000000000 +0100
++++ include/metis.h 2013-03-16 12:14:59.117329640 +0100
+@@ -30,7 +30,7 @@
+ GCC does provides these definitions in stdint.h, but it may require some
+ modifications on other architectures.
+ --------------------------------------------------------------------------*/
+-#define IDXTYPEWIDTH 32
++#define IDXTYPEWIDTH 64
+
+
+ /*--------------------------------------------------------------------------
+
diff --git a/sci-libs/metis/files/metis-5.1.0-multilib.patch b/sci-libs/metis/files/metis-5.1.0-multilib.patch
new file mode 100644
index 000000000000..919812dc3093
--- /dev/null
+++ b/sci-libs/metis/files/metis-5.1.0-multilib.patch
@@ -0,0 +1,20 @@
+--- libmetis/CMakeLists.orig.txt 2011-06-22 19:47:13.000000000 +0200
++++ libmetis/CMakeLists.txt 2013-03-15 17:13:19.948911972 +0100
+@@ -4,13 +4,14 @@
+ file(GLOB metis_sources *.c)
+ # Build libmetis.
+ add_library(metis ${METIS_LIBRARY_TYPE} ${GKlib_sources} ${metis_sources})
++set_target_properties(metis PROPERTIES SOVERSION 0)
+ if(UNIX)
+ target_link_libraries(metis m)
+ endif()
+
+ if(METIS_INSTALL)
+ install(TARGETS metis
+- LIBRARY DESTINATION lib
+- RUNTIME DESTINATION lib
+- ARCHIVE DESTINATION lib)
++ LIBRARY DESTINATION lib${LIB_SUFFIX}
++ RUNTIME DESTINATION lib${LIB_SUFFIX}
++ ARCHIVE DESTINATION lib${LIB_SUFFIX})
+ endif()
diff --git a/sci-libs/metis/files/metis-5.1.0-shared-GKlib.patch b/sci-libs/metis/files/metis-5.1.0-shared-GKlib.patch
new file mode 100644
index 000000000000..acfa59e60bd3
--- /dev/null
+++ b/sci-libs/metis/files/metis-5.1.0-shared-GKlib.patch
@@ -0,0 +1,21 @@
+--- GKlib/CMakeLists.orig.txt 2013-03-11 20:50:14.000000000 +0100
++++ GKlib/CMakeLists.txt 2013-03-17 19:53:44.220827579 +0100
+@@ -7,7 +7,7 @@
+ include(GKlibSystem.cmake)
+
+ include_directories(".")
+-add_library(GKlib STATIC ${GKlib_sources})
++add_library(GKlib SHARED ${GKlib_sources})
+ if(UNIX)
+ target_link_libraries(GKlib m)
+ endif(UNIX)
+@@ -16,6 +16,6 @@
+ add_subdirectory("test")
+
+ install(TARGETS GKlib
+- ARCHIVE DESTINATION lib
+- LIBRARY DESTINATION lib)
+-install(FILES ${GKlib_includes} DESTINATION include)
++ ARCHIVE DESTINATION lib${LIB_SUFFIX}
++ LIBRARY DESTINATION lib${LIB_SUFFIX})
++install(FILES ${GKlib_includes} DESTINATION include/metis)