summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz@gentoo.org>2024-08-20 14:10:17 -0400
committerEli Schwartz <eschwartz@gentoo.org>2024-08-20 14:12:04 -0400
commit6a51311816af3082a8e5e2be8dc36b67cd7b25fa (patch)
treeac1ebe74a9bd0fd7605fe8900edbb03ee42e4f86 /sci-libs
parentdev-python/pythran: mark as incompatible with setuptools 73 (diff)
downloadgentoo-6a51311816af3082a8e5e2be8dc36b67cd7b25fa.tar.gz
gentoo-6a51311816af3082a8e5e2be8dc36b67cd7b25fa.tar.bz2
gentoo-6a51311816af3082a8e5e2be8dc36b67cd7b25fa.zip
sci-libs/cantera: mark as LTO-unsafe
Signed-off-by: Eli Schwartz <eschwartz@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/cantera/cantera-3.0.0-r1.ebuild6
-rw-r--r--sci-libs/cantera/cantera-3.0.1.ebuild6
2 files changed, 10 insertions, 2 deletions
diff --git a/sci-libs/cantera/cantera-3.0.0-r1.ebuild b/sci-libs/cantera/cantera-3.0.0-r1.ebuild
index 9f0de3263452..c6b3ec2711e1 100644
--- a/sci-libs/cantera/cantera-3.0.0-r1.ebuild
+++ b/sci-libs/cantera/cantera-3.0.0-r1.ebuild
@@ -8,7 +8,7 @@ PYTHON_COMPAT=( python3_{10..12} )
FORTRAN_NEEDED=fortran
FORTRAN_STANDARD="77 90"
-inherit fortran-2 python-single-r1 scons-utils toolchain-funcs
+inherit flag-o-matic fortran-2 python-single-r1 scons-utils toolchain-funcs
DESCRIPTION="Object-oriented tool suite for chemical kinetics, thermodynamics, and transport"
HOMEPAGE="https://www.cantera.org"
@@ -78,6 +78,10 @@ pkg_setup() {
## Full list of configuration options of Cantera is presented here:
## http://cantera.org/docs/sphinx/html/compiling/config-options.html
src_configure() {
+ # -Werror=odr, -Werror=lto-type-mismatch
+ # https://github.com/Cantera/cantera/issues/1783
+ filter-lto
+
scons_vars=(
AR="$(tc-getAR)"
CC="$(tc-getCC)"
diff --git a/sci-libs/cantera/cantera-3.0.1.ebuild b/sci-libs/cantera/cantera-3.0.1.ebuild
index 7de3d3bf06df..46a9c3b2f469 100644
--- a/sci-libs/cantera/cantera-3.0.1.ebuild
+++ b/sci-libs/cantera/cantera-3.0.1.ebuild
@@ -8,7 +8,7 @@ PYTHON_COMPAT=( python3_{10..12} )
FORTRAN_NEEDED=fortran
FORTRAN_STANDARD="77 90"
-inherit fortran-2 python-single-r1 scons-utils toolchain-funcs
+inherit flag-o-matic fortran-2 python-single-r1 scons-utils toolchain-funcs
DESCRIPTION="Object-oriented tool suite for chemical kinetics, thermodynamics, and transport"
HOMEPAGE="https://www.cantera.org"
@@ -77,6 +77,10 @@ pkg_setup() {
## Full list of configuration options of Cantera is presented here:
## http://cantera.org/docs/sphinx/html/compiling/config-options.html
src_configure() {
+ # -Werror=odr, -Werror=lto-type-mismatch
+ # https://github.com/Cantera/cantera/issues/1783
+ filter-lto
+
scons_vars=(
AR="$(tc-getAR)"
CC="$(tc-getCC)"