summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-04-24 17:41:34 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-04-24 17:41:40 +0200
commit7afec29ff20bdae5831a4ea0ac264a323114c221 (patch)
treeb83214a137e1d8356bd76f101a07d2dfe6c8d857 /sci-libs
parentdev-util/cookiecutter: relax dev-python/click dependency (diff)
downloadgentoo-7afec29ff20bdae5831a4ea0ac264a323114c221.tar.gz
gentoo-7afec29ff20bdae5831a4ea0ac264a323114c221.tar.bz2
gentoo-7afec29ff20bdae5831a4ea0ac264a323114c221.zip
sci-libs/linux-gpib-modules: update EAPI 6 -> 8
and fix build with kernel 5.17.X Bug: https://bugs.gentoo.org/836110 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/linux-gpib-modules/files/linux-gpib-modules-4.3.4-kernel-5.17.patch24
-rw-r--r--sci-libs/linux-gpib-modules/linux-gpib-modules-4.3.4-r1.ebuild69
2 files changed, 93 insertions, 0 deletions
diff --git a/sci-libs/linux-gpib-modules/files/linux-gpib-modules-4.3.4-kernel-5.17.patch b/sci-libs/linux-gpib-modules/files/linux-gpib-modules-4.3.4-kernel-5.17.patch
new file mode 100644
index 000000000000..894c33466627
--- /dev/null
+++ b/sci-libs/linux-gpib-modules/files/linux-gpib-modules-4.3.4-kernel-5.17.patch
@@ -0,0 +1,24 @@
+diff --git a/drivers/gpib/eastwood/fluke_gpib.c b/drivers/gpib/eastwood/fluke_gpib.c
+index daebaaa..7edece1 100644
+--- a/drivers/gpib/eastwood/fluke_gpib.c
++++ b/drivers/gpib/eastwood/fluke_gpib.c
+@@ -910,7 +910,6 @@ static int fluke_config_dma(gpib_board_t *board, int output)
+ config.src_maxburst = 1;
+ config.dst_maxburst = 1;
+ config.device_fc = true;
+- config.slave_id = 0;
+
+ if(output)
+ {
+diff --git a/drivers/gpib/fmh_gpib/fmh_gpib.c b/drivers/gpib/fmh_gpib/fmh_gpib.c
+index c4ef7d2..d245278 100644
+--- a/drivers/gpib/fmh_gpib/fmh_gpib.c
++++ b/drivers/gpib/fmh_gpib/fmh_gpib.c
+@@ -926,7 +926,6 @@ static int fmh_gpib_config_dma(gpib_board_t *board, int output)
+ fmh_gpib_private_t *e_priv = board->private_data;
+ struct dma_slave_config config;
+ config.device_fc = true;
+- config.slave_id = 0;
+
+ if(e_priv->dma_burst_length < 1)
+ {
diff --git a/sci-libs/linux-gpib-modules/linux-gpib-modules-4.3.4-r1.ebuild b/sci-libs/linux-gpib-modules/linux-gpib-modules-4.3.4-r1.ebuild
new file mode 100644
index 000000000000..3c48db034bcd
--- /dev/null
+++ b/sci-libs/linux-gpib-modules/linux-gpib-modules-4.3.4-r1.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit linux-info linux-mod
+
+DESCRIPTION="Kernel modules for GPIB (IEEE 488.2) hardware"
+HOMEPAGE="https://linux-gpib.sourceforge.io/"
+SRC_URI="mirror://sourceforge/linux-gpib/linux-gpib-${PV}.tar.gz"
+S="${WORKDIR}/linux-gpib-kernel-${PV}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="debug"
+
+COMMONDEPEND=""
+RDEPEND="${COMMONDEPEND}
+ acct-group/gpib
+"
+DEPEND="${COMMONDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ # https://sourceforge.net/p/linux-gpib/code/1998/
+ "${FILESDIR}/${P}-kernel-5.17.patch"
+)
+
+pkg_setup() {
+ linux-mod_pkg_setup
+
+ if kernel_is -lt 2 6 8; then
+ die "Kernel versions older than 2.6.8 are not supported."
+ fi
+}
+
+src_unpack() {
+ default
+ unpack "${WORKDIR}/linux-gpib-${PV}/linux-gpib-kernel-${PV}.tar.gz"
+}
+
+src_configure() {
+ set_arch_to_kernel
+
+ my_gpib_makeopts=''
+ use debug && my_gpib_makeopts+='GPIB-DEBUG=1 '
+
+ my_gpib_makeopts+="LINUX_SRCDIR=${KERNEL_DIR} "
+}
+
+src_compile() {
+ set_arch_to_kernel
+ emake \
+ ${my_gpib_makeopts}
+}
+
+src_install() {
+ set_arch_to_kernel
+ emake \
+ DESTDIR="${ED}" \
+ INSTALL_MOD_PATH="${ED}" \
+ DEPMOD="/bin/true" \
+ docdir="${ED}/usr/share/doc/${PF}/html" \
+ ${my_gpib_makeopts} \
+ install
+
+ dodoc ChangeLog AUTHORS README* NEWS
+}