summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Udvare <audvare@gmail.com>2024-02-13 22:28:46 -0500
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2024-10-14 09:19:18 +0200
commitc513a4f3013bd8fe45c5cfcbd42e238e455b5993 (patch)
tree2cf58d5a93c61dbb9f9cd5a75722f49928ca4f42 /sci-libs
parentsci-libs/coinasl: new package, add 2.0.1 (diff)
downloadgentoo-c513a4f3013bd8fe45c5cfcbd42e238e455b5993.tar.gz
gentoo-c513a4f3013bd8fe45c5cfcbd42e238e455b5993.tar.bz2
gentoo-c513a4f3013bd8fe45c5cfcbd42e238e455b5993.zip
sci-libs/ipopt: add USE +asl to build ipopt binary
This makes the `sci-libs/ipopt` build the `ipopt` binary by default. Currently this is not supported because there is no ASL library. Using the ThirdParty-ASL repo is necessary to ensure a pkg-config file is installed to be detected by ipopt configure. HSL support is removed due to treeclean of sci-libs/coinhsl. Signed-off-by: Andrew Udvare <audvare@gmail.com> Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/ipopt/ipopt-3.14.4-r1.ebuild (renamed from sci-libs/ipopt/ipopt-3.14.4.ebuild)17
-rw-r--r--sci-libs/ipopt/metadata.xml2
2 files changed, 7 insertions, 12 deletions
diff --git a/sci-libs/ipopt/ipopt-3.14.4.ebuild b/sci-libs/ipopt/ipopt-3.14.4-r1.ebuild
index 44a78114fdfa..9005696f3cee 100644
--- a/sci-libs/ipopt/ipopt-3.14.4.ebuild
+++ b/sci-libs/ipopt/ipopt-3.14.4-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -15,15 +15,15 @@ HOMEPAGE="https://github.com/coin-or/Ipopt"
SRC_URI="https://github.com/coin-or/Ipopt/archive/refs/tags/releases/${PV}.tar.gz -> ${P}.tar.gz"
S="${WORKDIR}/Ipopt-releases-${PV}"
-LICENSE="EPL-1.0 hsl? ( HSL )"
+LICENSE="EPL-1.0"
SLOT="0/1"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="hsl +lapack mpi mumps static-libs test"
+IUSE="+asl +lapack mpi mumps static-libs test"
RESTRICT="!test? ( test )"
RDEPEND="
virtual/blas
- hsl? ( sci-libs/coinhsl:0= )
+ asl? ( sci-libs/coinasl:0= )
lapack? ( virtual/lapack )
mpi? ( virtual/mpi )
mumps? ( sci-libs/mumps:0=[mpi=] )"
@@ -41,6 +41,8 @@ src_prepare() {
src_configure() {
local myeconfargs=(
$(use_with doc dot)
+ $(use_with asl)
+ --without-hsl
)
if use lapack; then
@@ -55,13 +57,6 @@ src_configure() {
else
myeconfargs+=( --without-mumps )
fi
- if use hsl; then
- myeconfargs+=(
- --with-hsl-incdir="${EPREFIX}"/usr/include
- --with-hsl-lib="$($(tc-getPKG_CONFIG) --libs coinhsl)" )
- else
- myeconfargs+=( --without-hsl )
- fi
econf "${myeconfargs[@]}"
}
diff --git a/sci-libs/ipopt/metadata.xml b/sci-libs/ipopt/metadata.xml
index f5b474167afc..1b9661483cd4 100644
--- a/sci-libs/ipopt/metadata.xml
+++ b/sci-libs/ipopt/metadata.xml
@@ -15,7 +15,7 @@
for Operations Research).
</longdescription>
<use>
- <flag name="hsl">hsl</flag>
+ <flag name="asl">AMPL Solver Library support and build the 'ipopt' binary</flag>
<flag name="mumps">Enable <pkg>sci-libs/mumps</pkg> support</flag>
</use>
<upstream>