summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2024-03-26 12:06:20 +0100
committerDavid Seifert <soap@gentoo.org>2024-03-26 12:06:20 +0100
commitca013469c4692182f51264a980af7b5688d34d15 (patch)
treea45373d4d7e0fd656b191f2ae143c3c0486193f8 /sci-libs
parentapp-editors/emacs: Stabilize 28.2-r11 amd64, #927819 (diff)
downloadgentoo-ca013469c4692182f51264a980af7b5688d34d15.tar.gz
gentoo-ca013469c4692182f51264a980af7b5688d34d15.tar.bz2
gentoo-ca013469c4692182f51264a980af7b5688d34d15.zip
sci-libs/htslib: add 1.19.1
Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/htslib/Manifest1
-rw-r--r--sci-libs/htslib/htslib-1.19.1.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/sci-libs/htslib/Manifest b/sci-libs/htslib/Manifest
index 38e157095820..23cea03c57b1 100644
--- a/sci-libs/htslib/Manifest
+++ b/sci-libs/htslib/Manifest
@@ -1 +1,2 @@
DIST htslib-1.17.tar.bz2 4619884 BLAKE2B c45591b3f1da4f6ddfdf5e1a20864583d57de2a460d42049715335fce7dafe1f5cd14403e6033fee4f9d0bfc75f8777b5835d2d01bf2cadff0155d9fc92b97d9 SHA512 624ab449d57713dab2d34399926c065f8cff8a45e6fbe68e0bb518c601421f587b613caeb095f8639b1d67cdb4a65d658c85f942173bcaa48da026fe15def5d3
+DIST htslib-1.19.1.tar.bz2 4775086 BLAKE2B 3af6770ade9505a3c71f6d522c0971eb77ea2549670043a539a2a4681e583554dc154b9b9fb33f1faa94be336a09945a28c57aa4bcfe0f39b03dd7585c49269a SHA512 a40de47ecae68756c158c1c7b578fa2a5c13bf6f98626e863af31a20d7880ffd415d966280c00bfe726f496d913eb0fcf014dd4beb8c1dbe36ed9735a48bd01e
diff --git a/sci-libs/htslib/htslib-1.19.1.ebuild b/sci-libs/htslib/htslib-1.19.1.ebuild
new file mode 100644
index 000000000000..2a38fa8634c8
--- /dev/null
+++ b/sci-libs/htslib/htslib-1.19.1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="C library for high-throughput sequencing data formats"
+HOMEPAGE="http://www.htslib.org/"
+SRC_URI="https://github.com/samtools/${PN}/releases/download/${PV}/${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0/3"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="+bzip2 curl +lzma"
+
+RDEPEND="
+ sys-libs/zlib
+ bzip2? ( app-arch/bzip2 )
+ curl? ( net-misc/curl )
+ lzma? ( app-arch/xz-utils )"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+
+ # upstream injects LDFLAGS into the .pc file,
+ # which is a big nono for QA
+ sed -e '/^\(static_l\|Libs.private\|Requires.private\)/d' \
+ -i htslib.pc.in || die
+}
+
+src_configure() {
+ econf \
+ --disable-gcs \
+ --disable-plugins \
+ --disable-s3 \
+ $(use_enable bzip2 bz2) \
+ $(use_enable curl libcurl) \
+ $(use_enable lzma)
+}
+
+src_compile() {
+ emake AR="$(tc-getAR)"
+}
+
+src_install() {
+ default
+
+ # doesn't use libtool, can't disable static libraries
+ find "${ED}" -name '*.a' -delete || die
+}