summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz93@gmail.com>2024-03-21 01:47:42 -0400
committerSam James <sam@gentoo.org>2024-03-21 05:57:42 +0000
commitec105e48578ab0964c600fcd6cb09d42e349215e (patch)
treebebc01eee1e12b29a2d6f7736cb6d265d754b2ee /sci-libs
parentsci-electronics/geda: avoid fatal warning for maybe-uninitialized (diff)
downloadgentoo-ec105e48578ab0964c600fcd6cb09d42e349215e.tar.gz
gentoo-ec105e48578ab0964c600fcd6cb09d42e349215e.tar.bz2
gentoo-ec105e48578ab0964c600fcd6cb09d42e349215e.zip
sci-libs/oc: mark as LTO-unsafe, strict-aliasing unsafe
Upstream is libdap. They exist. They have lots of maintained software, it is simply that oc isn't one of them as far as I can tell. What happened to it? I don't know. Maybe it's legacy abandoned software. Their distfiles server still has it, but that's it. Possibly we should delete the package instead... Closes: https://bugs.gentoo.org/862906 Signed-off-by: Eli Schwartz <eschwartz93@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/oc/oc-2.0.ebuild13
1 files changed, 12 insertions, 1 deletions
diff --git a/sci-libs/oc/oc-2.0.ebuild b/sci-libs/oc/oc-2.0.ebuild
index ee688999d5dd..9dd7413b919e 100644
--- a/sci-libs/oc/oc-2.0.ebuild
+++ b/sci-libs/oc/oc-2.0.ebuild
@@ -1,8 +1,10 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+inherit flag-o-matic
+
DESCRIPTION="Network Data Access Protocol client C library"
HOMEPAGE="https://opendap.org/"
SRC_URI="https://opendap.org/pub/OC/source/${P}.tar.gz"
@@ -18,6 +20,15 @@ RDEPEND="net-misc/curl"
DEPEND="${RDEPEND}"
src_configure() {
+ # -Werror=strict-aliasing
+ # https://bugs.gentoo.org/862906
+ #
+ # Upstream exists, they just don't seem to mention oc anymore, *anywhere*.
+ #
+ # Do not trust with LTO either.
+ append-flags -fno-strict-aliasing
+ filter-lto
+
econf --disable-static
}