summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2015-12-21 14:22:59 +0100
committerPatrick Lauer <patrick@gentoo.org>2015-12-21 14:22:59 +0100
commitb7240d561f244e5155d83f41dc916b09be5de1e4 (patch)
treed29b61840654d9e57ebf4314b5b4e5fbb59d8d5a /sci-mathematics/cado-nfs/cado-nfs-2.2.0.ebuild
parentmedia-video/movit: Bump (diff)
downloadgentoo-b7240d561f244e5155d83f41dc916b09be5de1e4.tar.gz
gentoo-b7240d561f244e5155d83f41dc916b09be5de1e4.tar.bz2
gentoo-b7240d561f244e5155d83f41dc916b09be5de1e4.zip
sci-mathematics/cado-nfs: Bump
Diffstat (limited to 'sci-mathematics/cado-nfs/cado-nfs-2.2.0.ebuild')
-rw-r--r--sci-mathematics/cado-nfs/cado-nfs-2.2.0.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/sci-mathematics/cado-nfs/cado-nfs-2.2.0.ebuild b/sci-mathematics/cado-nfs/cado-nfs-2.2.0.ebuild
new file mode 100644
index 000000000000..44c8e43b78fe
--- /dev/null
+++ b/sci-mathematics/cado-nfs/cado-nfs-2.2.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+DESCRIPTION="Number Field Sieve (NFS) implementation for factoring integers"
+HOMEPAGE="http://cado-nfs.gforge.inria.fr/"
+SRC_URI="https://gforge.inria.fr/frs/download.php/file/35401/${P}.tar.gz"
+
+PYTHON_COMPAT=( python{2_7,3_4} )
+PYTHON_REQ_USE="sqlite"
+inherit eutils cmake-utils python-r1
+
+# Fails F9_{k,m}bucket_test F9_tracektest
+RESTRICT="test"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ dev-libs/gmp
+ dev-lang/perl
+ !sci-mathematics/ggnfs
+ !sci-biology/shrimp
+ "
+DEPEND="${RDEPEND}
+ "
+
+src_prepare() {
+ # looks like packaging mistake
+ sed -i -e 's/add_executable (convert_rels convert_rels.c)//' misc/CMakeLists.txt || die
+ sed -i -e 's/target_link_libraries (convert_rels utils)//' misc/CMakeLists.txt || die
+ sed -i -e 's~install(TARGETS convert_rels RUNTIME DESTINATION bin/misc)~~' misc/CMakeLists.txt || die
+}
+
+src_configure() {
+ DESTINATION="/usr/libexec/cado-nfs" cmake-utils_src_configure
+}
+src_compile() {
+ # autodetection goes confused for gf2x
+ ABI=default cmake-utils_src_compile
+}