summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2023-08-12 12:18:03 +0700
committerAndrey Grozin <grozin@gentoo.org>2023-08-12 12:18:03 +0700
commitb3b821a8aebcef0ed19b43f9e17b5a312bdb8345 (patch)
tree39c3e5203bf2597122fc03d5432174ce29b024e3 /sci-mathematics/wxmaxima
parentapp-admin/awscli: Stabilize 1.29.15 ALLARCHES, #912158 (diff)
downloadgentoo-b3b821a8aebcef0ed19b43f9e17b5a312bdb8345.tar.gz
gentoo-b3b821a8aebcef0ed19b43f9e17b5a312bdb8345.tar.bz2
gentoo-b3b821a8aebcef0ed19b43f9e17b5a312bdb8345.zip
sci-mathematics/wxmaxima: bump to 23.07.0
Signed-off-by: Andrey Grozin <grozin@gentoo.org>
Diffstat (limited to 'sci-mathematics/wxmaxima')
-rw-r--r--sci-mathematics/wxmaxima/Manifest1
-rw-r--r--sci-mathematics/wxmaxima/metadata.xml5
-rw-r--r--sci-mathematics/wxmaxima/wxmaxima-23.07.0.ebuild80
3 files changed, 86 insertions, 0 deletions
diff --git a/sci-mathematics/wxmaxima/Manifest b/sci-mathematics/wxmaxima/Manifest
index 6d8f4b192994..fa6ee926a8f2 100644
--- a/sci-mathematics/wxmaxima/Manifest
+++ b/sci-mathematics/wxmaxima/Manifest
@@ -1,2 +1,3 @@
DIST wxmaxima-23.04.1.tar.gz 22060726 BLAKE2B 77583c2461f7c32ac53ad2890d1e7d07a9fc2dd0caa07a1fcdd7c62d39ec63c50173542c74ce2d21093ce724d1777b76e7789f8a5363ff20406d52177c86a016 SHA512 9846c11cbeec8411170e0d55916187cc77274e2758726784bcb5540d55f712b5a557562de0c37dac0c7ef119d43570bd33efc33252fc5359627e527d668580a4
DIST wxmaxima-23.05.1.tar.gz 16220058 BLAKE2B a680a562c92ac400c2e3e377e9f6aa387a259b3bfc9d533bba2f2fcc4c5abfca78c578935273932cbb4be6aa04c29c0316582472f212b0868cba2bfb0081234f SHA512 a36cf3207058065dbe68b8a75b7a97ab0ab827c9097f90a67af1c436703a22bff6978fbf173e0806e40d01270d97def1137de9af7d2501e96faca475d474c5af
+DIST wxmaxima-23.07.0.tar.gz 16427247 BLAKE2B c754e476adcf71b2074e5d20edc14ac0d81f453d2cfc1f69fb281c0e3290cf31487ee2772624f868bb1057c19e1dac3cee6bd402d2b7e8b35f1ef8e80c7611f5 SHA512 0b94443b2fa31c7f75f33d57285c5086e69f43abd53d2a66b78d946d5370982b5b3a2a53fc5c4b4631fec94453b6f94a209d7ba3d13b1518dbe597d62b7e4690
diff --git a/sci-mathematics/wxmaxima/metadata.xml b/sci-mathematics/wxmaxima/metadata.xml
index 3fdc2bb5429d..1af1aec16112 100644
--- a/sci-mathematics/wxmaxima/metadata.xml
+++ b/sci-mathematics/wxmaxima/metadata.xml
@@ -16,6 +16,11 @@
completion based on previous input (tab-key).
wxMaxima provides 2d formated display of maxima output.
</longdescription>
+ <use>
+ <flag name="webkit">Use <pkg>net-libs/webkit-gtk</pkg> to show help
+ (for maxima and wxmaxima) inside wxmaxima
+ </flag>
+ </use>
<upstream>
<remote-id type="github">wxMaxima-developers/wxmaxima</remote-id>
</upstream>
diff --git a/sci-mathematics/wxmaxima/wxmaxima-23.07.0.ebuild b/sci-mathematics/wxmaxima/wxmaxima-23.07.0.ebuild
new file mode 100644
index 000000000000..6b29481f6c3e
--- /dev/null
+++ b/sci-mathematics/wxmaxima/wxmaxima-23.07.0.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+WX_GTK_VER="3.2-gtk3"
+PLOCALES="ca cs da de el en es fi fr gl hu it ja kab nb pl pt_BR ru tr uk zh_CN zh_TW"
+inherit cmake plocale wxwidgets xdg
+
+DESCRIPTION="Graphical frontend to Maxima, using the wxWidgets toolkit"
+HOMEPAGE="https://wxmaxima-developers.github.io/wxmaxima/"
+SRC_URI="https://github.com/wxMaxima-developers/wxmaxima/archive/Version-${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}"/${PN}-Version-${PV}
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="test webkit"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ dev-libs/libxml2:2
+ x11-libs/wxGTK:${WX_GTK_VER}[webkit?]"
+RDEPEND="${DEPEND}
+ media-fonts/jsmath
+ sci-visualization/gnuplot[wxwidgets]
+ sci-mathematics/maxima"
+
+src_prepare() {
+ setup-wxwidgets
+ cmake_src_prepare
+
+ sed -e "s|GPL.txt ||g" -e "s|share/doc/${PN}|share/doc/${PF}|g" -i CMakeLists.txt \
+ || die "sed CMakeLists.txt failed"
+ sed -e "s|share/doc/${PN}|share/doc/${PF}|g" -i info/CMakeLists.txt \
+ || die "sed info/CMakeLists.txt failed"
+
+ # locales
+ rm_po() {
+ rm locales/wxMaxima/${1}.po || die "rm ${1}.po failed"
+ rm -f locales/manual/${1}.po
+ rm -f info/${PN}.${1}.md
+ rm -f info/${PN}.${1}.html
+ sed -e "\\|/${1}/wxmaxima.1|d" -i data/CMakeLists.txt
+ }
+ plocale_find_changes locales/wxMaxima '' '.po'
+ plocale_for_each_disabled_locale rm_po
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DWXM_UNIT_TESTS=$(usex test)
+ -DWXM_DISABLE_WEBVIEW=$(usex webkit OFF ON)
+ )
+
+ cmake_src_configure
+}
+
+src_test() {
+ # Just run the unit tests manually for now as tests fail in a non-descriptive
+ # way even with virtualx
+ # bug #736695
+ cd "${BUILD_DIR}/test/unit_tests" || die
+
+ local tests=(
+ AFontSize
+ CellPtr
+ ImgCell
+ )
+
+ local test
+ for test in "${tests[@]}" ; do
+ ./test_${test} || die "Unit test ${test} failed!"
+ done
+}
+
+src_install() {
+ docompress -x /usr/share/doc/${PF}
+ cmake_src_install
+}